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CHAPTER 1

Quick Start with Hosting Panel
In this chapter, we will explain how to create your first website, fill it with content, create
mailboxes for users of the site, and, finally, view the site visits statistics.
Once you are comfortable with basic Panel capabilities, try out some advanced hosting
features: Expand website functionality by installing web applications (on page 60),
secure your sites with SSL certificates (on page 69), employ databases (on page 169),
and much more.
Note: Hosting providers can turn off some of the advanced features to make your
Panel look simple and user-friendly. We have used the (Advanced) prefix to designate
the sections related to the features that may be turned off. If you require one of the
advanced options, contact your hosting provider.

In this chapter:
Set Up Your First Website ................................................................................. 4
User Accounts, Subscriptions, and Webspaces ................................................ 14

Set Up Your First Website
Now that you have a customer account and a domain name, the first thing you will want
to do is create a website. The information about the possible ways to do it is provided
in the section 1. Create Your Site (on page 5).
When your site is ready, you may want to take a look at the result in your browser.
Learn how to do it in the section 2. Preview your Site (on page 9).
Even a perfectly designed site will not be effective if no one knows about it. When all
the design work is done, you need to submit your site to popular search engines. The
corresponding instruction is located in the section 3. Submit Your Sites to Search Engines
(on page 10).

Next in this section:
1. Create Your Site ............................................................................................ 5
2. Preview Your Site .......................................................................................... 9
3. Submit Your Sites to Search Engines ............................................................ 10
Set Up Mail Accounts ........................................................................................ 10
View Site Visit Statistics .................................................................................... 13
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1. Create Your Site
There are three general ways to create a website:


Employ a web design studio to create a site for you, and then you will just update
its content.



Create a site by yourself using Presence Builder - the powerful tool that enables
you to create professional-looking websites in a few mouse clicks. Learn more in
the section Presence Builder (on page 6).



Create your website in a third-party Content Management System - an editor that
allows you to easily create and edit website content such as pages, scripts,
applications, and so on. To learn more about creating sites in third-party content
management systems, see the section Content Management Systems (on page 7).

If you have purchased a ready-made site or created it by yourself, you should upload
the site content to your account to make the site visible on the web. There are two
ways to upload content:


Using FTP. Learn more in the section Uploading Content Using FTP (on page 8).



Using an integrated File Manager. Learn more in the section Uploading Content with
File Manager (on page 8).

Next in this section:
Presence Builder ............................................................................................... 6
Content Management Systems ......................................................................... 7
Uploading Content............................................................................................. 7
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Presence Builder
Presence Builder is a tool that enables users with no knowledge of HTML markup or
graphic design skills to create professional-looking sites. This tool provides a simple
visual editor and a huge set of templates for different websites. You can create web
pages, add content of different types (text, images, video, scripts), and edit website
settings such as website name, keywords, icons, and so on.
To create websites in Presence Builder, ensure that your hosting subscription includes
this option. If it does not, choose another way or upgrade your subscription.

 To create a website with Presence Builder:
1. Go to the Websites tab and click your domain name.
2. Click the link Launch Presence Builder.
3. Select a topic that best suits your website.
4. Edit the website:
a. Structure: Add more pages, remove the predefined pages that
you do not need.
b. Content: Change the predefined content to your own, add text,
images, videos, scripts, and other required elements.
c. Design: Change the layout and color scheme.
5. Publish the website.
Find more information about creating websites with Presence Builder in the section
Creating Websites with Presence Builder (on page 101).

Quick Start with Hosting Panel

Content Management Systems
Content Management Systems (or CMS) are applications that provide a graphical user
interface for adding and editing website content: pages, scripts, files, multimedia
content, and so on.
Before you can create a website in a third-party CMS, you should install the CMS on
your hosting account. Note that you can install the CMS only if your hosting
subscription allows it.

 To create a website using a CMS:
1. Go to the Applications tab.
2. Find the CMS you need in the list of available applications, and install it
as described in the section Using Web Applications (on page 60).
3. Create your website in the CMS. For information about creating
websites with your CMS, refer to the relevant documentation.

Uploading Content
If you already have a website created by yourself or a web design studio, just upload
the website files and folders to your provider's server. You can do this in one of the
following ways:


Using FTP. This way is better when several people manage a website's content
because it does not require access to your customer account. You can just create
FTP users for them. Learn more about this method in the section Uploading Content
Using FTP (on page 8).



Using Panel's File Manager. This way is more convenient because it uses the
Panel GUI and provides a set of useful features, for example, a visual HTML editor
and a file permissions manager. Find more information on the features of File
Manager in the section Uploading Content with File Manager (on page 8).

Next in this section:
Uploading Content Using FTP ........................................................................... 8
Uploading Content with File Manager ................................................................ 8
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Uploading Content Using FTP
 To publish a website using FTP:
1. Connect to your webspace on the server with an FTP client program,
using your FTP account username and password.
You can change your username and password in the Panel at the Websites tab >
Web Hosting Access.
The FTP address should be ftp://your-domain-name.com, where your-domainname.com is your site's Internet address.
Enable the passive mode if you are behind a firewall.

2. Upload the files and directories of your site to the httpdocs directory.
If you use CGI scripts, place them in the cgi-bin directory.
3. Close your FTP session.
You can also set up additional FTP accounts if you need to collaborate on website
content with other users. For more information, see the section Adding FTP Accounts (on
page 155).

Uploading Content with File Manager
To upload a website from your computer to your hosting account with File Manager, go
to the Websites tab, click your domain name, click File Manager, and upload your files to
the httpdocs directory. You can also upload your website as a compressed ZIP file and
then extract the contents using the archiver integrated in File Manager.
With File Manager, you can also do the following:


Edit HTML files in the visual editor.



Preview website pages.




Edit files in the text editor.
Manage the file access permissions.

Learn more about uploading and editing website files and folders with File Manager in
the section Website Content (on page 53).
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2. Preview Your Site
After you uploaded website files to the webspace, you can check how your site will look
in a web browser, even before the information about the new site has spread in the
Domain Name System.

 To preview a site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Go the Websites tab.
3. Click Preview below the domain name of the website that you want to
preview.
Your site will open in a new browser window.
Note: The contents of password-protected directories might be inaccessible in the
Preview mode.
Sometimes, you may need to show your site to someone when your domain name is
not registered yet. There are several ways to do it without giving that person access to
your customer account. Learn more in the section Previewing Websites (on page 60).
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3. Submit Your Sites to Search Engines
To gain more visitors and drive traffic to your site after you publish it on the Internet,
you need to submit it to search engines. Before the site submission, you can improve
the site ranking in search results by the following content optimizations:


Include in the text contained in your web pages the frequently searched keyword
phrases, which are relevant to the topic of your site. For example, mention your
product or a topic of your interest several times in the text on a web page.



Add relevant keywords to the <title> and <meta> tags. Some search engines
look for keywords and descriptions in meta tags placed within web pages, and
present these keywords in search results.

For example, if you are selling hosting automation software, then you can include the
following tags in HTML pages of your website:
<HEAD>
<TITLE>Ordering hosting automation software
</TITLE>
<META name="keywords" content="order,hosting,software">
<META name="description" content="Ordering Hosting Automation
Software">
</HEAD>

Separate the keywords with a comma without white spaces.
After you optimize the website and publish it to your customer account, submit it to
search engines, such as Google, Yahoo, Bing, and other engines that you know to be
popular in your country.



To submit a site to Google, follow the instructions at
https://support.google.com/webmasters/answer/1352276.
To submit a site to Yahoo, visit http://search.yahoo.com/info/submit.html.



To submit a site to Bing, visit http://www.bing.com/toolbox/submit-site-url.

Set Up Mail Accounts
Once your website is ready, you can start creating mail accounts. You can choose, for
example, to create mail accounts for your friends or colleagues. Note that the number
and size of mailboxes is limited by your hosting plan.

Next in this section:
1. Create Mail Account ...................................................................................... 11
2. Access Your Mailbox ..................................................................................... 12
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1. Create Mail Account
 To create an email address:
1. If you are subscribed to several hosting packages, select the
subscription you need in the Subscription menu at the top of the screen.
If you have several webspaces, select the required webspace in the
Webspaces tab > Switch to webspace.
2. Click the Mail tab.
3. Click Create Email Address.
4. Type the left part of the e-mail address before the @ sign, and, if you
have several domain names on your account, select the domain name
under which the e-mail address will be created.
5. Leave the Mailbox checkbox selected.
Clearing this checkbox makes sense only if you want to use this address as a mail
forwarder, which will forward all incoming mail to another address.

6. Specify the mailbox size or use the default size defined by the
provider's policy or your service plan.
7. Specify a password consisting of five or more Latin characters.
8. Click OK.

12
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2. Access Your Mailbox
There are two ways to access a mailbox for sending and receiving email messages:




Set up and use an email client program on your computer. Typically, in such
programs you should specify the following settings:


Username. In this field, specify your full email address. For example,
johndoe@example.com.



Password. Most likely, the password to your email account.



Mail server protocol. This property defines whether you want to keep copies of
messages on the server. To keep the copies on the server, select the IMAP
option. If you do not want to keep them on the server, select POP3. Selecting
IMAP will also allow you to train the SpamAssassin spam filter on email
messages you receive, if the spam filter is switched on for your account.



Incoming mail server (POP3/IMAP). Type your mail server's address. Typically, it
is your website's address with the mail. prefix. For example, mail.example.com.
The POP3 port is 110. The IMAP port is 143.



Outgoing mail server (SMTP). Type your mail server's address. Typically, it is your
website's address with the mail. prefix. For example, mail.example.com. The
SMTP port is 25. This server requires authentication.

Use a web browser to connect to the webmail interface.

Note: If you cannot access your mailbox following the instructions in this section, this
might be caused by mail server settings. Contact your hosting provider to resolve the
issue.

Access from Webmail
 To access your mailbox through webmail, do any of the following:


In a Web browser, visit the URL webmail.example.com, where example.com is
the Internet address of your website. When prompted, specify your full email
address as the username (for example, mail@example.com), and specify the
password that you use for logging in to the Panel.



When logged in to the Panel, click the Mail tab, and in the list of email addresses,
click the icon

corresponding to the email address you need.
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View Site Visit Statistics
Finally, when your site works fine and search engines return it in search results, it is the
best time to evaluate site efficiency by viewing the visits statistics.

 To find out how many people visited a site, from what countries, and what
pages of the site they viewed:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Websites tab and click the domain name for which you want to
view the statistics.
3. Click Web Statistics.
The site visitor statistics will show in a new browser window.

4. To view statistics for web pages viewed from the SSL-secured area of
your site, select SSL Web Statistics in the menu.
5. To view statistics for files downloaded over the file transfer protocol
(FTP), select FTP Statistics in the menu.
Alternately, you can view the visits statistics for a site by visiting the following URL:
https://your-domain.com/plesk-stat/webstat. When prompted for username and
password, specify your FTP account username and password.
You have successfully completed the quick start part of the guide. Feel free to read
about other features that are available to you in the Hosting Panel.

CHAPTER 2

User Accounts, Subscriptions, and
Webspaces
After you subscribe to a hosting plan, a customer account in Panel is created to enable
you to log in to Panel and use the hosting services and resources such as mailboxes,
disk space, and bandwidth.

Customer Account, Multiple Subscriptions, and Webspaces
Depending on your provider's policy, you might be able to subscribe to multiple hosting
plans. For example, if you do not want your main site to share hosting resources with a
company's branch site, you can subscribe to another hosting plan under the same
customer account. In addition to having access to multiple subscriptions from a single
customer account, you might be able to have several webspaces under each of your
subscriptions.
Each webspace is limited to only one IPv4 and one IPv6 address. Thus, all domains
within a webspace share the same IP address (v4 or v6). If you need to host sites on
different IP addresses, you should set up new webspaces for that. Having a separate
(or dedicated) IP address for a site can be useful, for example, if you want to secure
connections to the site with a separate SSL certificate.
The number of subscriptions and webspaces that you can create depends on your
hosting plan.

System Users
For each hosting subscription, Panel creates a system user - a user account in the
hosting server's operating system. Customers obtain their system users' access
credentials from their service providers and use these credentials for connecting to the
server through FTP, SSH, and so on. In addition, all operations on files and directories
in Panel are performed on behalf of system users. For example, when a customer adds
a new file in File Manager, the subscription's system user becomes the owner of the
file.

Mail Management
Mail service settings can be defined per webspace: all domains inside the same
webspace will receive similar settings.

Quick Start with Hosting Panel
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Adding Resources to a Subscription
Purchasing a new subscription for extending hosting resources is not always
necessary. You can always improve just one of your subscriptions. For example, add
extra disk space or SSL support. This can be done by switching to another hosting plan
or by purchasing hosting plan add-ons.

Managing Customer Account
In Panel, you can perform a number of administrative operations on your customer
account:


Change an account password and personal information. Learn more in the section
Changing Your Password and Contact Information (on page 16).



View statistics on your account: For example, disk space or traffic usage. Learn
more in the section Viewing Statistics (on page 17).

Allowing Other Users to Access Your Account
If the number of hosting maintenance operations is too large to be handled by one
person, you can delegate some of them to other people. For this purpose, you can
create auxiliary user accounts grouped by means of user roles. For example, you can
create a group that is allowed only to upload content to websites. Users in this group
will not be able to perform any operations except for managing website content. For
more information about auxiliary users, refer to the section (Advanced) Managing Auxiliary
User Accounts (on page 20).

In this chapter:
Changing Your Password and Contact Information ........................................... 16
Working with Subscriptions and Webspaces ..................................................... 17
Viewing Statistics .............................................................................................. 17
(Advanced) Managing Auxiliary User Accounts ................................................. 20
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Changing Your Password and Contact Information
 To change your password for access to the Hosting Panel:
1. Go to the Users tab, click the link with your name, and then click Change
Settings.
2. Type a new password, and click OK.

 To change the username or password that you use for connecting to your
subscription over FTP or SSH:
1. Click the Websites tab.
2. Click Web Hosting Access.
3. Type the new username or password, and click OK.

 To change your contact information:
1. Go to the Users tab, click the link with your name, and then click Change
Settings.
2. Click the Contact Details tab.
3. Update your contact information and click OK.

Quick Start with Hosting Panel
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Working with Subscriptions and Webspaces
This section is intended only for the hosting customers whose hosting plan provides the
option to set up multiple subscriptions and webspaces.
When you have several subscriptions and webspaces under your account, then you
need to select the proper subscription and webspace before performing any website
management operations in Hosting Panel.

Selecting a Subscription and a Webspace
To select a subscription, open the Subscription menu in the upper right corner of the
page. To select a webspace, click the Webspaces tab, and then click the corresponding
link Switch to webspace.

Creating New Webspaces for Hosting Sites
To create a webspace, go to the Webspaces tab, and click Create New Webspace. In the
next step, specify the domain name with which the webspace will be associated,
specify the system user name and password that will be used for uploading website
content over FTP, and select the type of IP address and the services that should be
available to the site hosted under that webspace.

Suspending and Unsuspending Webspaces
Suspending a webspace can be useful when you need to make the hosted website and
all related services (such as mailboxes under that site's domain name) temporarily
unavailable.
To suspend a webspace, go to the Webspaces tab, select the checkbox next to the
domain name of that webspace, and click Disable.
To unsuspend a webspace, go to the Webspaces tab, select the checkbox next to the
domain name of that webspace, and click Enable.

Removing Webspaces
Removal of a webspace results in deleting all related data from the hosting account:
website settings and content, mailboxes and messages, databases, and any data
backups.
To remove a webspace, go to the Webspaces tab, select the checkbox next to the
domain name of that webspace, and click Delete.

18
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Viewing Statistics
 To view the reports on disk space and traffic usage by your account:
1. If you have several subscriptions associated with your account, in the
Subscription menu at the top of the screen, select the required
subscription.
2. Click the Statistics tab.
The following information is presented in charts:




Disk space used by the following files and directories in the subscription:


Websites



Mail accounts



Databases



Logs



Backups



Chroot directories



Configuration files



Anonymous FTP directory

Traffic used by FTP, web, and mail services during the current month.
FTP field shows the information about the total size of files transferred to and
from the webspace over the file transfer protocol.
HTTP field shows the information about the total amount of data transferred from
all of your websites over HTTP protocol, that is, retrieved by web browsers.
POP3/IMAP field shows the total amount of data received by all mail accounts
under your domains.
SMTP field shows the total amount of data sent by all mail accounts under your
domains.

3. Do any of the following:


To view a report on the amount of data transferred to and from your sites over
FTP, click FTP Statistics.



To view a report on the amount of traffic used by services during a certain
month, click Data Transfer Statistics, and select the required month from the menu.



To view a report on how your websites are visited, click Web Statistics.
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Log Files
All connections to the web server and requests for files that were not found on the
server are registered in log files. These log files are analyzed by the statistics programs
running on the server, which then present graphical reports on demand. You may want
to download these log files to your computer for processing by third-party statistics
programs, or view their contents for web server debugging purposes.

 To prevent these log files from growing too large, you should enable
automatic cleanup and recycling of log files:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Websites tab > <domain name> > Logs > Log Rotation.
3. Click Switch On. If you see only the Switch Off button there, this means
that log recycling is already switched on.
4. Specify when to recycle log files and how many copies of each log file
to store on the server. Also specify whether they should be compressed
and sent to an email address after processing.
5. Click OK.

 To view the contents of a log file or download it to your computer:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Websites tab > <domain name> > Logs. A list of log files opens.
3. Do any of the following:


To view all entries in a log file, click the log file name. If you want to view only a
few last lines from the log file, type the number of lines into the input box under
the Settings group, and then click the log file name.



To download a file to your computer, click the corresponding icon



To remove a processed log file from the server, select the corresponding
checkbox and click Remove. Confirm removal and click OK.

.

 To download log files to your computer via FTP:
1. Connect to your hosting account via FTP.
2. Go to the <domain_name>/logs directory and copy the log files to
you computer.

20
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(Advanced) Managing Auxiliary User Accounts
If you want to allow other users to access the Panel for managing websites and
installed applications, or to use email services under your domains, then you need to
create user accounts for them.

Auxiliary Users and User Roles
Auxiliary user accounts are created based on user roles. The roles include privileges to
access certain areas of the Panel and perform operations in the Panel. There are
several predefined user roles, namely: Accountant, Application User, Owner, and
Webmaster. You can review and modify the Accountant, Application User, and
Webmaster roles to suit your needs, or you can create your own custom roles. For
more information on user roles and user account creation, refer to the sections User
Roles (on page 21) and Auxiliary User Accounts (on page 23) respectively.
After auxiliary user accounts are created, the users will be able to log in to their
accounts in Panel and use shortcuts in their Panels to access their mailboxes and work
with applications.

Auxiliary Users and Multiple Subscriptions
If your customer account includes more than one subscription, you can allow auxiliary
users to access only a specified subscription. If the Access to subscriptions property of a
user account is set to a certain subscription, the user will always log in to this
subscription and will not be able to switch to other subscriptions.

Next in this section:
User Roles ........................................................................................................ 21
Auxiliary User Accounts .................................................................................... 23
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User Roles
 To create a user role:
1. Go to the Users tab > User Roles tab > Create User Role.
2. Specify the following:


User role name.



Access to Panel services. Grant the required permissions for operations to the
user:


Manage users and roles. Add, modify, and remove user accounts and roles.
Note that even if this permission is not granted to a user, the user will be
able to browse contact information of other users after logging in to the
Panel.



Create and manage sites. Set up, modify, remove domain names and
subdomains, host websites and change web hosting settings.



Configure log rotation. Manage settings for recycling of web server access and
error log files. View, download, and remove log files.



Configure anonymous FTP service. Set up a directory accessible to all Internet
users over FTP without authorization.



Create and manage scheduled tasks. Schedule execution of scripts or programs
on your customer account.



Configure spam filter. Set up spam protection for mailboxes.



Configure antivirus. Set up virus protection for mailboxes.



Create and manage databases. Add, modify, and remove databases stored on
your customer account.



Configure and perform data backup and restoration. Back up and restore data
related to your customer account, websites, and mailboxes under your
domains.



View statistics. View reports on disk space and traffic usage by your websites,
and website visits.



Install and manage applications. Install applications on websites and manage
them.



Design sites in Presence Builder. Create websites using Presence Builder.



Upload and manage files. Manage files and directories located in the webspace
by using the Panel's file manager.



Create and manage additional FTP accounts. Set up additional FTP accounts for
other users.



Manage DNS settings. Manage DNS settings for domains.



Install and manage Java applications. Install on websites third-party Java
applications.



Create and manage mail accounts. Create, modify, and remove e-mail accounts.
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Access to apps. This group is shown if at least one application is installed on the
website. Here you can select the applications that the user should be able to
access and use.
For more information about installing applications and providing access to
users, refer to the section Granting Auxiliary Users Access to Apps (on page 63).

3. Click OK.

 To modify user role properties:
1. Go to the Users tab > User Roles tab.
2. Click the link with the role name that you want to change.
3. Change the role properties as required and click OK.

 To remove a user role:
1. Go to the Users tab > User Roles tab.
2. Select the checkbox corresponding to the role you want to remove and
click Remove. Note that it is impossible to remove the Owner role and
other roles that are assigned to one or more users.
3. Click Yes to confirm the removal.

Quick Start with Hosting Panel
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Auxiliary User Accounts
 To create a user account:
1. Go to the Users tab > Create User Account.
2. Specify the following:


Contact name.



E-mail address. The email address will be used as a user name for logging in to
Panel, unless you specify another name in the Username box.


To create a new email address for the user, select the option Create an email
address under your account,
type the desired left part of the address which goes before the @ sign, and,
if you have a number of domains on your account, select the domain name
under which the email address should be created.



To associate with this user account an external email address, select the
option Use an external email address, and specify an existing external email
address.



User role. Select the required user role from the menu.



Access to subscriptions. Allow a user to access only a specified subscription. The
All value grants them access to all subscriptions within your customer account.



Username. The user name for access to Panel.



Password. The password for access to Panel.

3. Leave the User is active checkbox selected. Otherwise, the user will not
be able to access the Panel and use applications on your customer
account.
4. Click OK.
5. Now, if you want to add contact information for the user, click a link with
the user's name, and then click the Contact Details tab, and specify the
user's contact information.
6. Click OK.
Now you can notify the user about creation of his or her account and ability to access
Panel. Provide the user with the address to open in his or her browser, the username
(which is the user's email address), and the password that you specified in the account
settings.

 To change user account properties:
1. Click the Users tab.
2. Click a link with the user's name.
3. Make the required changes and click OK.
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 To suspend or activate a user account:
1. Click the Users tab.
2. Click a link with the user's name.
3. Do any of the following:


To suspend a user account, clear the User is active checkbox. The user will no
longer be able to log in to the Panel and access applications.



To activate a user account, select the User is active checkbox.

4. Click OK.

 To remove a user account:
1. Click the Users tab.
2. Select a checkbox corresponding to the user account you want to
remove, and click Remove. Note that you cannot remove your own
account.
3. Click Yes to confirm the removal.

CHAPTER 3

Websites and Domains
The creation of your web presence typically starts with purchasing a domain name. The
domain name is the address people use to access your site from their browsers, for
example, www.example.com. Domain registration is carried out by authorized
companies - domain name registrars. Hosting providers often carry out this function.
For detailed information about how to manage domains in Panel, refer to the section
Domains and DNS.
Panel provides a full range of operations in regard to domains and websites:



Adding and removing domains, subdomains, and aliases.
Managing the content of your websites.



Installing various web apps.



Securing connections to your websites and much more.

This chapter provides detailed information about all possible operations on websites
and domains in Panel. Note that some of these operations may be unavailable
according to your hosting plan.
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Domains and DNS
A domain name is hierarchical and can consist of a number of parts called labels:


The label furthest to the right is called the top-level domain. For example, com is
the top-level domain of www.example.com. The number of top-level domains is
limited and all of them are managed by separate international authorities.



The second-level domain is the label that is typically used to convey the purpose of
a website. In www.example.com it is the example part. The combination of the
second-level and top-level domain names specifies the exact location of your
website.



Each label to the left is a subdomain of the domain to the right. For example, www
is the subdomain of example.com. Subdomains can be convenient when you want
to isolate some content from the main site, for example, you can organize your
personal blog on myblog.example.com. For information on how to add
subdomains in Panel, refer to the section Adding Subdomains.

If you want to host more than one website under your subscription, you can register
more domains and add them to your subscription. Registering new domains may be
available to you in the Hosting Panel if your hosting provider allows this. For
information on how to purchase and add domains in Panel, refer to the section Adding
Domains.
In fact, domain names exist only for convenience; the real communication between
browser and web servers uses IP addresses - the numerical host identifiers. For
example, the real address of www.example.com may be 192.0.2.12 (IPv4). To resolve
domain names into IP addresses, web hosts use the DNS technology. To learn more
about how DNS is implemented in Panel, refer to the section (Advanced) Configuring DNS
for a Domain.
DNS allows several domains to be resolved into one IP address. Such additional
names are called domain aliases. This is convenient when you have purchased several
domain names that you want to point to the same website. For information on how to
add aliases for existing domains, refer to the section Adding Domain Aliases.

Next in this section:
Adding Domains ................................................................................................ 27
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Adding Domains
If your hosting package includes more than one domain name (website), then you can
easily add new domains to your account. Before you start adding a new domain that
will use a second-level domain name, like example.com, be sure to register this domain
name with your hosting provider or with another domain name registration authority.
You can set up the following types of site configurations through Panel:




Website addressed by a second-level domain name. The following services are available
for websites:


A unique Internet address (domain name), like example.com.



Additional domain names (domain aliases).



Subdomains - divisions of a site accessible by easy-to-remember addresses
that are added to the main site, like mail.example.com.



Separate FTP accounts for collaboration on the site content. For every FTP
account, you can specify which directories can be accessed.



Creating content using Presence Builder.



Simplified deployment of applications, such as content management systems,
photo galleries, shopping carts, blogging platforms, and many more.



Secure data exchange implemented by SSL protocol. This requires that a site
be hosted on a dedicated IP address, which is not shared among other users
and sites.



Mailboxes.



Viewing statistics on site visits.

Website or a division of a website addressed by a third-level domain name (subdomain). This
is usually a division of an existing site. It has an Internet address comprising of
three parts separated by dots. The following services are available for subdomains:


Separate document root from the main site. Document root is a directory on the
server where web pages of a site are stored.



Access over FTP for content management.



Creating content using Presence Builder.



Simplified deployment of applications.



Secure data exchange implemented by SSL protocol.



Viewing statistics on site visits.

Adding More Domains
 To host a new website with a second-level domain name:
1. If you are subscribed to several hosting packages, select the required
subscription in the Subscription menu at the top of the page. If you have
a number of webspaces, select the required webspace in Webspaces tab
> Switch to webspace.
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2. Click the Websites tab, click Add New Domain and follow the on-screen
instructions.
Note: If you select the recommended option, you should associate the domain's
DNS settings with the domain name at the registrar's side. To achieve this, enter
the Panel name server's IP address into the corresponding NS record in the
registrar's system. How to find out this IP address: go to the DNS tab > <domain
name> > DNS tab > DNS Records, find the NS record, and then find the A record
corresponding to the NS record value.
For example, if your NS record is
example.com.
NS
ns.example.com,
find the A record with ns.example.com, for example,
ns.example.com. A
192.0.2.12
The resulting value, 192.0.2.12, is the Panel name server IP you need.

3. Click OK.
The new domain name is now shown in the list at the bottom of the page.
You can now start creating your website with Presence Builder or upload your web
content to the webspace of the new website, as described in the section Website Content
(on page 53).

Registering Domains
If your service provider offers the domain name registration service, you can initiate
domain name registration directly from Panel. To register a domain name, add it as
described above and then click the link Register Domain Names on the Websites tab. This
will redirect you to the provider's online store where you can complete the registration.

Removing Domains
When you delete a domain name from Panel, all data related to the corresponding site
are deleted from the server. The first domain name (default domain) that was created
for your account cannot be deleted; however, it can be renamed.

 To remove a domain:
1. If you are subscribed to several hosting packages, select the required
subscription in the Subscription menu at the top of the page. If you have
a number of webspaces, select the required webspace in Webspaces tab
> Switch to webspace.
2. Go to the Websites tab and click the name of the domain or subdomain
you want to remove.
3. Click Remove Website or Remove Subdomain.
4. Confirm removal and click OK.
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Note: Removing domain names from the Hosting Panel does not cancel the
registration of these names. If you registered these domain names, you can still use
them for your websites.

Adding Subdomains
If your hosting package includes subdomains, which are additional third-level domain
names, then you can use them to:


Organize logically the structure of your site.



Host additional websites or parts of a website on the same server without the need
to pay for registration of additional domain names.

An example of using subdomains:
You have a website called your-product.com, which is dedicated to promoting and
selling your product. For publishing information related to customer service and online
order tracking, you can organize the subdomain "orders" so that your users will be able
to access this information directly by visiting the Internet address "orders.yourproduct.com".
You can use the same set of tools and services for working with subdomains. For
example, switch on SSL protection, create a site with Presence Builder, view site visit
statistics.

 To set up a subdomain for a site division or a separate site:
1. If you are subscribed to several hosting packages, select the required
subscription in the Subscription menu at the top of the page. If you have
a number of webspaces, select the required webspace in Webspaces tab
> Switch to webspace.
2. Click the Websites tab.
3. Click Add New Subdomain.
4. Specify the following:
a. In the Subdomain name box, type the portion of address that will
be added to the domain name of your main site.
b. In the Document root box, type the desired location of the
directory where all files and subdirectories of this site will be
kept. You can use the default directory of the main site, called
httpdocs, or specify another directory.
5. Click OK.
The new subdomain name is now shown in the list at the bottom of the page.
You can now upload your web content to the subdomain's webspace (a directory on
the server), as described in the section Uploading Content Using FTP (on page 8).
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Wildcard Subdomains
If you enter the asterisk (*) symbol as the subdomain name, Panel will create a socalled wildcard subdomain. When site visitors enter any subdomain name that is not
registered in Panel, they will be redirected to this wildcard subdomain. You can create
wildcard subdomains at any domain name level. For example, you can create the
*.mystore.example.com subdomain. Learn more about wildcard subdomains in the
section Adding Wildcard Subdomains (Linux Hosting) (on page 32).

Adding Domain Aliases
By using domain aliases, you can point several domain names to the same website.
This can be useful, for example, for branding purposes.

 To set up a domain alias in Panel:
1. If you are subscribed to several hosting packages, select the required
subscription in the Subscription menu at the top of the page. If you have
a number of webspaces, select the required webspace in Webspaces tab
> Switch to webspace.
2. Click the Websites tab.
3. Click Add New Domain Alias.
4. Specify the domain for which you are creating an alias (the primary
domain) and the alias’s domain name, for example alias.tld, and set
up the following:


Mail service
Panel does not allow creating mailboxes under domain aliases. Instead, the
mailboxes of the primary domain are used. If you select the Mail service option, the
mailboxes created under the primary domain will also be available under the alias.
To enable users to read mail sent to mailboxes under the alias, Panel redirects it to
the corresponding mailboxes under the primary domain.
For example:
You have an email address mail@domain.tld. Then you set up an alias for
domain.tld, for example, alias.tld. If you select the Mail service option, all mail
sent to mail@alias.tld will be available at mail@domain.tld. Otherwise, the
mailbox mail@domain.tld will not receive mail sent to mail@alias.tld.



Web service
If this option is turned on, the website will open in the browser at the alias’s URL. If
you clear the Web service check box, the alias will be used for mail only provided that
Mail service is selected.



Redirect with the HTTP 301 code
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By default, Panel uses the web server's internal redirection for aliases. In this case,
the alias appears to be a separate website for visitors and for web search engines.
This causes the problem because search engines index the content of the alias
separately, so your primary domain loses search engine rankings.
To avoid this, you can use redirection with the HTTP 301 code (Moved
permanently) by selecting Redirect with the HTTP 301 code. In this case, only the
primary domain will rank in search engines. Learn more at
http://support.google.com/webmasters/bin/answer.py?hl=en&answer=93633


Java web applications
If you use hosting services based on a Linux platform, and you have Java
applications installed on your site that you want to make accessible through the
domain alias, select the Java web applications option.

5. Click OK.
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Adding Wildcard Subdomains (Linux Hosting)
Use wildcard subdomains to redirect visitors from non-existent subdomains to one of
your websites. Wildcard subdomains can be used in the following typical cases:


Improvement of the website organization and running marketing campaigns.
For example, you do not have the vps-limited-offer subdomain but wish to forward
users from limited-vps-offer.example.com to example.com.



Helping users reach your website even if they mistype a subdomain name.
It is a widespread mistake to mistype a website name if it has the leading www
prefix (for example, typing ww.example.com).



Finally, some website applications (WordPress) use wildcard subdomains to create
dynamic subdomains for convenience and better user experience.

Note: Traffic to existing subdomains will not be affected in any way if you add a
wildcard subdomain.

How to Add Wildcard Subdomains
You can add one wildcard subdomain per each domain name under a subscription. To
do this, go to the Websites tab > Add New Subdomain > and set up a new subdomain
whose name consists of an asterisk (*). Example: *.example.com. If you want this
subdomain to have a custom set of scripts or website content, specify a custom
document root for it.

Limitations of Wildcard Subdomains
Wildcard subdomains act like typical subdomains with the following exceptions:



Linux-only feature. Currently, wildcard subdomains are supported only on Linuxbased hosting accounts.
Renaming is not available. It is not possible to rename such subdomains.



No DNS zone. This type of subdomains does not have its own zone records in the
DNS server. Instead, they have an A record that points to the IP address
associated with the corresponding domain name.



Installation of APS apps is not supported. You cannot install APS apps on wildcard
subdomains.



No Presence Builder sites. You cannot edit and publish sites to these subdomains
from Presence Builder.
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Adding a Domain Forwarder
 To create a domain forwarder in Panel:
1. If you are subscribed to several hosting packages, select the required
subscription in the Subscription menu at the top of the page. If you have
a number of webspaces, select the required webspace in Webspaces tab
> Switch to webspace.
2. Click the Websites tab.
3. Click Add New Domain.
4. Specify the following:


In the Domain name box, type the domain name that you have registered with
your service provider or a domain name registration company and from which
you want to redirect visitors.



Under DNS server configuration, select the option Use our DNS settings.



Under Hosting type, select the Forwarding option.



In the Destination address box, type the URL address to which you want to
redirect visitors.



Under Forwarding type, select standard or frame forwarding. To learn more about
forwarding types, see Forwarding (on page 41).

 To turn an existing domain into a domain forwarder:
On the Websites tab, click Hosting Settings beside the name of the domain that you want
to make a forwarder, and click the Change link next to the Hosting type field. Specify the
following:


Under Hosting type, select the Forwarding option.



In the Destination address box, type the address to which you want to redirect
visitors.



Under Forwarding type, select standard or frame forwarding. To learn more about
forwarding types, see Forwarding (on page 41).
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(Advanced) Configuring DNS for a Domain
The Domain Name System (DNS) is a hierarchical naming system that translates
understandable domain names into the numerical identifiers (IP addresses) associated
with servers. Such translation is called resolving. When you add a domain name (using
the Websites tab > Add New Domain), you should choose the role of Panel in resolving
your resources: It can directly process all translation requests or pass them to a remote
server.
In the former case, you can change the DNS zone settings through the Hosting Panel.
Learn more about it in the section Using Your Provider's DNS Servers (on page 35).
If you no longer need your provider's DNS server to serve the DNS zones for some of
your websites, make the adjustments described in the section Using External DNS Servers
for Your Sites (on page 37).

Next in this section:
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Using Your Provider's DNS Servers
For each new domain name, the Panel automatically creates a DNS zone in
accordance with the settings configured by your service provider. The domain names
should work fine with the automatic configuration, however, if you need to perform
custom modifications in the domain name zone, you can do that through your Panel.

 To view the resource records in a DNS zone of a domain:
1. Go to the DNS tab and click the domain name whose DNS settings you
want to view.
2. Click the DNS tab > DNS Records.

 To add a new resource record to the zone:
1. Go to the DNS tab and click the domain name whose DNS settings you
want to manage.
2. Click the DNS tab > DNS Records.
3. Click Add New DNS Record.
4. Select a resource record type, and specify the appropriate data:


For an NS record, which specifies the domain name of a name server that is
responsible for a DNS zone of a domain, you need to specify the domain name
(or a subdomain), and then the corresponding name server's domain name. If
you are defining an NS record for your main domain, then you should leave the
domain name field empty. If you are defining a name server for a subdomain,
then type the subdomain into the Domain field. After that, type the appropriate
name server's domain name into the Name server field. For example:
ns1.mynameserver.com.



For A and AAAA records, which associate IP addresses with domain names,
you need to specify the domain name and IP address. If you are simply defining
a record for your main domain, then you should leave the Domain field empty. If
you are defining a record for a name server, then type ns1 or ns2 into the
Domain field. Then specify the appropriate IP address with which to associate the
domain name.



For a CNAME record, which specifies which subdomains (or domain aliases that
look like subdomains, for example, www) should be associated in the Domain
Name System with the main domain address, you need to type the subdomain
name or www alias, and then, the main domain name.



For an MX record, which specifies the host name of the preferred mail server for
the given domain, you need to specify the mail domain (or subdomain), the
domain name of the mail exchange server responsible for receiving email, and
the server's priority. For the mail domain, you would simply leave the available
field blank. Then type the domain name of your mail server in the Mail exchanger
field. If you are running a remote mail server named 'mail.myhostname.com',
then simply type 'mail.myhostname.com' into the Mail exchanger field. After that,
specify its priority: 10 is the highest and 40 is the lowest.
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For a TXT record, which is used for specifying arbitrary human-readable text,
you can type an arbitrary text string, or an SPF record.



For an SRV record, which is used for specifying location of services other than
mail, you will need to enter the service name, protocol name, port number, and
target host. You can also specify the priority of the target host, and relative
weight (for records with the same priority) in the appropriate fields.

4. Click Finish.
Note: Editing or removal of resource records is not possible. You can only deactivate
the existing predefined records and add new records instead. To deactivate a record,
go to DNS tab > domain name > DNS tab > DNS Records, select the record, and click
Deactivate record. To add a new record, follow the steps above.

In addition to the resource records described above, there is also a Start of Authority
record. This record indicates that this DNS name server is responsible for the domain's
DNS zone. It also contains settings that affect the propagation of information about the
DNS zone in the Domain Name System.

 To modify the entries in the Start of Authority (SOA) record for a domain:
1. Go to the DNS tab and click the domain name whose DNS settings you
want to manage.
2. Click the DNS tab > Zone Settings > Edit.
3. Specify the required values:


Refresh interval. This is how often the secondary name servers check with the
master name server to see if any changes have been made to the domain's
zone file. The time is specified in seconds.



Retry interval. This is the time, in seconds, a secondary server waits before
retrying a failed zone transfer. This time is typically less than the refresh interval.



Expire interval. This is the time, in seconds, before a secondary server stops
responding to queries, after a lapsed refresh interval where the zone was not
refreshed or updated.



Minimum TTL. This is the time, in seconds, that other servers should keep the
data in cache.



Mailbox of the person responsible for this zone.

4. Click Submit.
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Using External DNS Servers for Your Sites
If you no longer need your provider's DNS server to serve the DNS zones for some of
your websites, switch off the Panel's DNS service for each of these sites.

 To switch off the Panel's DNS service for a site served by external name
servers:
1. Go to the DNS tab and click the domain name whose DNS settings you
want to manage.
2. Click the DNS tab.
3. Click Change DNS Hosting to External.
4. Click Finish.

Hosting Settings
The website’s hosting settings are available on the Websites tab of the Hosting Panel.
All per-website hosting settings form the following groups:


General.
Hosting type, security, scripting and statistics settings. See General Settings (on page
38).



PHP.
PHP scripting language settings. See PHP Settings (on page 43).



Web Server.
Web server settings (Apache or IIS). Web server type depends on your hosting
plan. See Apache Web Server Settings (on page 49) and IIS Web Server Settings (on page
50) correspondingly.
Note that in the IIS web server settings, you can configure basic website security
settings, such as anonymous access, SSL usage, and directory browsing.

On Windows, you can also set up custom ASP.NET settings in Websites > select a
domain > ASP.NET Settings. For details, see ASP.NET Settings (Windows) (on page 46).

Next in this section:
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Web Scripting Settings ...................................................................................... 43
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General Settings
To view a website's general hosting settings, go to the Websites tab, and click Hosting
Settings next to the domain name. The general website hosting settings are divided into
groups:

Basic Settings


Domain name. The domain name that you register with a domain registrar and will
use for this website.



Hosting type. The hosting type (Website hosting, Forwarding, and No hosting) defines
the website behavior. By default, all websites belong to the Website hosting type as
they are physically hosted on the server.
If you want to change the hosting type, use the Change link. To learn more about
hosting types, see Hosting Types (on page 39).
Note: Other basic settings depend on the selected hosting type. See Hosting Types
(on page 39).



Website status. The website status defines whether the site is accessible and other
hosting services are available. The site can be suspended so it will not open in
browsers, and even more, the hosting features of the site (such as the mail service
and DNS service) can be disabled. You should change the status if you want the
site to be temporarily unavailable, for example, for maintenance purposes. Learn
more in Website Status (on page 42).



Document root. Displayed for domains with the Website hosting type. See Website
Hosting (on page 40).



Preferred domain. Displayed for domains with the Website hosting type. See Website
Hosting (on page 40).

Security Settings


SSL support. Secure Sockets Layer encryption is generally used for protecting
transfer of sensitive data during online transactions on e-commerce websites
that run on dedicated IP addresses. SSL certificates that participate in the
encryption process are usually applied to a single domain name on a single IP
address, therefore, each site that needs SSL protection must be hosted on a
dedicated IP address. An exception to this is subdomains, which you can
protect with a wildcard certificate. Installing an SSL certificate on a web server
that hosts several websites with different domain names on a single IP address
is technically possible, however, it is not recommended: the encryption will be
provided, but users will get warning messages on attempt to connect to the
secure site. To allow SSL encryption for the website, select the SSL support
checkbox.
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Web Scripting and Statistics


Scripting languages. Specify the programming and scripting languages you want
the website to support. For PHP, you can also select the custom PHP version
and handler type. To learn more about PHP handlers and PHP configuration,
see PHP Settings.



Microsoft FrontPage settings. These are available only for Windows-based hosting
accounts. Microsoft FrontPage is a popular website authoring tool. To enable
content creation and publishing through Microsoft FrontPage, select the options
Microsoft FrontPage support, Microsoft FrontPage over SSL support, and Remote
FrontPage authoring allowed.



Web statistics. Select the web statistics software that you want to use for viewing
graphical reports and charts on website visitors. Also, select the corresponding
checkbox if you want to be able to access the statistical reports by visiting the
password-protected directory http://your-website/pleskstat/webstat.



Custom error documents. When visitors coming to a site request pages that the
web server cannot find, the web server generates and displays a standard
HTML page with an error message. If you want to create your own error pages
and use them on the web server, select the Custom error documents checkbox.



Additional write and modify permissions (available only for Windows hosting). This
option is required if web applications on the site will be using a file-based
database (like Jet) located in the root of the httpdocs directory. Note that
selecting this option will seriously compromise the website security.

Hosting Types
The hosting type defines the website's behavior. Panel supports three types of hosting:
Website hosting, Forwarding, and No hosting.

Next in this section:
Website Hosting ................................................................................................ 40
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Domains Without Web Hosting .......................................................................... 42
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Website Hosting
The Website hosting means that a website is physically located on the server.
For the website hosting type you can specify:


Document root. The location of the directory where all files and subdirectories of the
site will be kept. You can use the default directory httpdocs or specify another
directory.



Preferred domain. Typically, any website is available on two URLs: with the www
prefix (like in www.example.com) and without it (like in example.com). We
recommend that you always redirect visitors to one of these URLs (typically to the
non-www version). For example, after you set the preferred domain to the non-www
version (example.com), site visitors will be redirected to this URL even if they
specify www.example.com in their browsers.
Panel uses the search engine-friendly HTTP 301 code for such a redirection. This
allows preserving search engine rankings of your site (preferred domain). If you turn
off the redirection by choosing None, search engines will treat both URL versions
(www and non-www) as URLs of different sites. As a result, rankings will be split
between these URLs.
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Forwarding
You can point one or more registered domain names to the same physical website by
using domain name forwarding. This allows automatic redirection of visitors from the
URL they specify in a browser to a site with a different URL. For example, visitors of
the site www.example.com can be redirected to www.somedomain.tld. There are
two types of forwarding in Panel: standard forwarding and frame forwarding.

Standard Forwarding
With the Standard forwarding, users who have been redirected to another URL can see
the destination URL in the browser's address bar.
Depending on how long you intend to use the redirection, you can select the type of
redirection – Moved permanently (code 301) or Moved temporarily (code 302). These
are HTTP response codes which Panel sends to browsers to perform the redirection.
From visitors’ point of view, the response code does not matter: in both cases they will
be simply redirected to the destination URL. For search engines, the code defines how
they should treat the redirected site and affects search engine rankings.


Moved permanently (code 301).
Use this redirection type if you want to keep search engine rankings of your site
after moving it permanently to another address.
For example, if example1.com has been moved permanently to the domain
example2.com, the rankings will not be split between example1.com and
example2.com – search engine crawlers will treat them as a single website.



Moved temporarily (code 302).
Use this redirection type when the destination domain is used temporarily, for
example, when you are testing a new version of your site with real visitors while
keeping the old version intact. If you set this redirection for a newly created
destination domain, this domain will not be indexed by search engines.

Frame Forwarding
With the Frame forwarding, when visitors are redirected to another site, the address bar
of their browsers continues to show the source URL. Thus, visitors remain unaware of
the redirection. This is called frame forwarding as the index page of the source site
contains a frame with the destination site.
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Domains Without Web Hosting
You can switch off the website hosting service and use only email services under a
domain. To do this, go to Websites tab > Hosting Settings, click the Change link next to
Hosting Type, and select the No web hosting option.

Website Status
The website status defines whether a website is available over the Internet and what
hosting services are provided for it. Hosting providers may need to change the status of
sites if the site owners do not pay for the services. Site owners can change the status
of their sites if they want the sites to be temporarily unavailable.
Panel supports three types of website status: Suspended, Disabled, and Active.

Suspended Sites
If you want to shut down a site for maintenance and let your visitors know that it is
temporarily unavailable, you can suspend the website so that it will not open in
browsers (Websites tab > the Suspend link below the domain name). Visitors will be
redirected with the search engine-friendly 503 HTTP code (Service Unavailable) to the
"503 Service Unavailable" error page. The site's search engine rankings will not be
affected, and the hosting services such as mail will still be available and manageable
by means of Panel.
You can customize the error page using the link Edit error page, which appears on the
Websites tab next to the suspended domain name.
Note: The link Edit error page is displayed only if your hosting plan provides the option to
customize web server error documents.

Disabled Sites
If you want to suspend a website for a long time, and leave the site content available
over FTP, go to the Websites tab, and click the Disable link below the domain name.
Visitors will see the web server's default page set by the hosting provider, and the site's
search engine rankings will drop.
Disabled websites are not served to users; however, the physical directories and files
of disabled sites can be accessed by FTP clients and File Manager. Mail services are
not available.

Active sites
To bring the website back online, go to the Websites tab, and click the Activate link below
the domain name. The website will start working as usual.
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Web Scripting Settings
For each website in your subscription you can specify which of the following
programming and scripting languages should be supported by the web server: Active
Server Pages (ASP), Microsoft ASP.NET, Server Side Includes (SSI), PHP hypertext
preprocessor (PHP), Common Gateway Interface (CGI), Fast Common Gateway
Interface (FastCGI), Perl, and Python.
Starting from PPA 11.5, you can also configure PHP settings individually for each
website in your subscription, if your service plan provides that option. To learn about
custom PHP configuration, refer to the section PHP Settings (on page 43).

Next in this section:
PHP Settings ..................................................................................................... 43
ASP.NET Settings (Windows) ........................................................................... 46

PHP Settings
PHP is one of the most popular scripting languages for creating dynamic web pages.
The majority of today's websites and web applications are based on PHP scripts. This
is why site administrators should clearly understand how they can control the execution
of PHP scripts.
How PHP scripts are executed for a certain website is fully defined by two aspects:
PHP handler and PHP settings for the site. You can set up these parameters for a
certain website in the Hosting Panel as described below.

PHP Handler
When a visitor accesses a site based on PHP scripts, a web server interprets site
scripts to generate a page that will be shown to the visitor. PHP handler calls PHP
libraries needed for this interpretation. You can choose from a number of PHP
handlers: ISAPI (Windows), Apache module (Linux), FastCGI, CGI, or PHP-FPM
(Linux). The decision on what PHP handler to choose should depend on the number of
factors such as security considerations, script execution speed, and memory
consumption.

 To choose a PHP handler for your website:
1. Go to the Websites tab.
2. Click Hosting Settings next to the domain name of the website for which
you want to choose the PHP handler.
3. Choose one of the following PHP handlers as the value of the Run PHP
as parameter (beside the PHP support option).
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Run PHP as

Performance

High.
Apache
module (Linux Runs as a part of
the Apache web
only)

Memory
Usage

Security

Low

This handler (also known as mod_php)
is the least secure option as all PHP
scripts are executed on behalf of the
apache user. This means that all files
created by PHP scripts of any plan
subscriber have the same owner
(apache) and the same permission
set. Thus, a user might be able to
affect the files of another user or some
critical system files.

server.

Note: You can alleviate some
security issues by turning the PHP
safe_mode option on. It disables a
number of PHP functions that bring
potential security risk. Note that this
may lead to inoperability of some
web apps. The safe_mode option is
considered to be obsolete and is
deprecated in PHP 5.3.
ISAPI
extension
(Windows
only, not
supported
since PHP
5.3)

High.

Low

Runs as a part of
the IIS web server.

The ISAPI extension can provide site
isolation when a dedicated IIS
application pool is switched on for
subscriptions. Site isolation means that
sites of different customers run their
scripts independently. Thus, an error in
one PHP script does not affect the
work of other scripts. In addition, PHP
scripts run on behalf of a system user
associated with a hosting account.

Note: The ISAPI extension handler
is not supported since PHP 5.3.
CGI
application

Low.
Low
Creates a new
process for each
request and closes it
once the request is
processed.

The CGI handler provides PHP script
execution on behalf of a system user
associated with a hosting account. On
Linux, this behavior is possible only
when the suEXEC module of the
Apache web server is on (the default
option). Otherwise, all PHP scripts are
executed on behalf of the apache
user.
We recommend that you use the CGI
handler only as a fallback.
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FastCGI
application

High (close to
Apache module and
ISAPI extension).

High

The FastCGI handler runs PHP scripts
on behalf of a system user associated
with a hosting account.

Low

The PHP-FPM is an advanced version
of FastCGI which offers significant
benefits for highly loaded web
applications.
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Keeps the
processes running
to handle further
incoming requests.

PHP-FPM
application
(Linux only)

High

The PHP-FPM handler is available
only if it was installed by the hosting
provider and if the option Process PHP
by nginx in the website’s settings is
turned on (Websites tab > select a
domain > Web Server Settings).

Note: Switching PHP from Apache module to FastCGI application may disrupt the
operation of existing PHP scripts. Switching to PHP-FPM by selecting Process PHP by
nginx in the website’s web server settings may do the same.

PHP Version
Panel supports different versions of PHP. For each handler, one or more PHP versions
can be available. The list of available versions is defined by your hosting provider and
is available to you in the same location where you select the PHP handler: Websites tab
> Hosting Settings.
Note: Always use PHP 5.x except for the cases when you need PHP 4.x to host some
old PHP apps.

PHP Settings
The processing of PHP scripts depends on several configuration settings. These
settings specify various script execution aspects, such as performance (for example,
the amount of memory a script can use), security (for example, access to file system
and services), and so on. You might need to adjust these settings for a number of
reasons:


Preventing a memory leak or server hang-up by poorly written scripts.



Protecting data from malicious scripts.



Meeting the requirements of a certain web app.



Testing your own scripts, and other.

PHP settings are located in the Hosting Panel, Websites tab > click the domain name of
your site > PHP Settings. For convenience, all PHP settings are divided into two groups:
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Performance settings.
These settings define how scripts work with system resources. For example: Use
the memory_limit parameter to limit the amount of memory for a script to prevent
a memory leak. In addition, you can prevent scripts from tying up the server by
limiting the maximum time scripts are allowed to run using max_execution_time.



Common settings.
This group contains other commonly used PHP settings. Generally, these are:
Security settings (for example, the PHP safe mode toggle or the permission to
register global variables), error reporting settings (for example, the directive to log
errors), and others.

You can set the value of each parameter in PHP Settings either by selecting a value from
a preset, typing a custom value, or leaving the Default value. In the latter case, Panel
uses the values defined by the server-wide php.ini file. For information about certain
PHP settings, refer to the respective documentation. For example,
http://php.net/manual/en/ini.list.php.
It is possible to use three placeholders in parameter values:


{DOCROOT} for the document root directory of a domain that gets a custom PHP
configuration.



{WEBSPACEROOT} for the root directory of a subscription (webspace).



{TMP} for the directory that stores temporary files.

Notes: The default values of PHP settings in Panel differ from the ones suggested by
the official PHP documentation at http://php.net/manual/en/ini.list.php.
The custom PHP configuration for a website acts as a preset for all subdomains under
that site. You can perform further per-subdomain PHP configuration in the same way
as for websites.

ASP.NET Settings (Windows)
 To configure ASP.NET Settings for a site:
1. Go to the Websites tab and click your website's domain name.
2. Click ASP.NET Settings.
3. Set up the strings that determine database connection data for
ASP.NET applications that use databases. This option is available only
for ASP.NET 2.0.x.
When you open the ASP.NET configuration screen for the first time, sample
connection parameters with common constructions are displayed. You can
delete them and specify your own strings.


To add a string, enter the required data into the Name and Connection Parameters
input fields and click
next to them.



To remove a string, click

next to it.

4. Set up custom error messages that will be returned by ASP.NET
applications in the Custom Error Settings field:
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To set the custom error messages mode, select an appropriate option from the
Custom error mode menu:


On - custom error messages are enabled.



Off - custom error messages are disabled and detailed errors are to be
shown.



RemoteOnly - custom error messages are displayed only to remote clients,
and ASP.NET errors are shown to the local host users.

To add a new custom error message (which will be applied unless the Off mode
was selected), enter the values in the Status Code and Redirect URL fields, and
click .


Status Code defines the HTTP status code resulting in redirection to the error
page.



Redirect URL defines the web address of the error page presenting
information about the error to the client.

Due to possible conflicts, you cannot add a new custom error message with an
error code that already exists, but you can redefine the URL for the existing
code.


To remove a custom error message from the list, click

next to it.

5. Configure compilation settings in the Compilation and Debugging field:


To determine the programming language to be used as default in dynamic
compilation files, choose an entry from Default web page language list.



To enable compiling retail binaries, leave the Switch on debugging checkbox
empty.



To enable compiling debug binaries, select the Switch on debugging checkbox. In
this case, the source code fragments containing error will be shown in a
diagnostic page message.

Note. When running applications in debug mode, a memory and/or performance
overhead occurs. It is recommended to use debugging when testing an application
and to disable it before deploying the application into production scenario.

6. Configure encoding settings for ASP.NET applications in the Globalization
Settings section:


To set an adopted encoding of all incoming requests, enter an encoding value
into the Request encoding field (default is utf-8).



To set an adopted encoding of all responses, enter an encoding value into the
Response encoding field (default is utf-8).



To set an encoding which must be used by default for parsing of .aspx, .asmx,
and .asax files, enter an encoding value into the File encoding field (the default
is Windows-1252).



To set a culture which must be used by default for processing incoming web
requests, select an appropriate item from the Culture list.



To set a culture which must be used by default when processing searches for a
locale-dependent resource, select an appropriate item from the UI Culture list.
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7. Set a code access security trust level for ASP.NET applications in the
Code Access Security field.
CAS trust level is a security zone to which applications execution is assigned,
defining what server resources the applications will have access to.
Important: When an assembly is assigned a trust level that is too low, it does not
function correctly. For more information on the permissions levels see
http://msdn.microsoft.com/library/enus/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010.

8. Enable the usage of the auxiliary scripts in the Script Library Settings field.
Specifying the script library settings is necessary if the validation web
controls are used on your web site. This option is available only for
ASP.NET 1.1.x.


If you need to use auxiliary scripts (specifically, scripts implementing objects for
validating input data), provide the settings for .NET framework script library. To
do so, enter the path beginning with the domain root directory preceded by the
forward slash into the Path to Microsoft script library field, or click the folder icon
next to the Path to Microsoft script library field and browse for the required location.



To initiate the auto-installation of files containing the scripts to the specified
location, select the Install checkbox. If the files already exist there, they will be
rewritten.

9. Set client session parameters in the Session Settings field:


To set up the default authentication mode for applications, select an appropriate
item from the Authentication mode list. Windows authentication mode should be
selected if any form of IIS authentication is used.



To set up time that a session can remain idle, type the number of minutes into
the Session timeout box.

10. Click OK to apply all changes.

Web Server Settings
Web server type depends on the type of your hosting package: Apache is used for
Linux-based hosting, and IIS, for Windows-based hosting. Depending on the type of
your web server, refer to Apache Web Server Settings (on page 49) or IIS Web Server
Settings (on page 50).

Next in this section:
Apache Web Server Settings ............................................................................ 49
IIS Web Server Settings .................................................................................... 50
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Apache Web Server Settings
Panel uses the Apache web server (http://en.wikipedia.org/wiki/Apache_HTTP_Server)
to deliver the pages of your website to clients (such as browsers through which visitors
access your website). The default web server settings are specified by the hosting
provider. For example, these settings can determine how web servers process different
types of files, how they use SSL, where they store log files, and so on.
However, you (as a website owner) can set up custom web server settings for your
website. For example, add a new type of the index file, restrict access to the site, and
so on.
Note: You can adjust web server settings for your websites only if your hosting
subscription provides the corresponding permission.

Next in this section:
Adjusting Apache Web Server Settings ............................................................. 49

Adjusting Apache Web Server Settings
All customizable web server settings are located in Websites tab > <domain_name> > Web
Server Settings. Custom settings work only for the selected website. These settings are
typically changed by site owners, who may want to add a new type of index files (Index
files), or a MIME type for files with a certain extension (MIME types), to restrict access to
the site (Deny access to the site), or specify Apache handlers for a certain file type
(Handlers).
Note that subdomains have their own web server settings, therefore, when you change
web server settings for a site that has subdomains, the subdomains will not receive
these changes.
If you do not find the necessary setting, contact your hosting provider, who can set up
more custom settings for websites.

The Default Value of Server Settings
You can set the value of each parameter either by typing a custom value, or leaving the
Default value. In the latter case, Panel uses the values from the default web server
configuration defined by the hosting provider.
Your values override the default ones. The only exception is the Deny access to the
site setting: IP addresses from the default configuration, as well as the IP addresses
specified by you, will all be applied to your website. In case of a conflict (for example,
when you allow the IP address that is denied in the default configuration), Apache uses
your settings.
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IIS Web Server Settings
Panel uses the IIS web server
(http://en.wikipedia.org/wiki/Internet_Information_Services) to deliver the pages of your
website to clients (such as browsers through which visitors access your website). The
behavior of IIS is defined by a variety of settings.
The default web server settings are specified by the hosting provider. For example,
these settings can determine how IIS process different types of files, how it uses SSL,
and so on.
However, you (as a website owner) can set up custom web server settings for your
website. For example, add a new type of the index file, restrict access to the site, and
so on.
Note: You can adjust web server settings for your websites only if your hosting
subscription provides the corresponding permission.

Next in this section:
Adjusting IIS Web Server Settings..................................................................... 51
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Adjusting IIS Web Server Settings
All customizable web server settings are located in Websites tab > select a website >
Web Server Settings. Custom settings work only for the selected website. The settings
are divided into groups:

Common Settings
These settings are typically changed by site owners, who may want to:


Allow site visitors to view the listing of files and subdirectories of the site’s directory
in their browsers (Directory browsing). The directory listing will be displayed if there
are no matches for default index pages in the site’s root directory.



Add a new type of default index pages (Default documents).



Add a new MIME type for files with a certain extension (MIME types).

Directory Security Settings
These settings allow site owners to:


Restrict access to the site by username and password – only system users will be
able to access the site (Anonymous access). Denying anonymous access may be
useful if your site is not intended for any visitor, for example, it is a web application
for internal use. Note that FTP users and additional FTP users created in Panel will
have access to such a site if they were granted access to the site’s directory.



Force all clients (such as browsers or FTP clients) to use the secure HTTPS
protocol to access their site (Require SSL). You need this option, for example, if the
site contains and transmits personal information.

Access Restriction Settings
These settings allow site owners to restrict access to the site by IP address of the
visitor (Deny access to the site) by denying and allowing access from certain IP
addresses.
Note: Subdomains have their own web server settings; therefore, when you change
web server settings for a site that has subdomains, the subdomains will not receive
these changes.
If you do not find the necessary setting, contact your hosting provider who can set up
more custom settings for websites.

The Default Value of Server Settings
You can set the value of each parameter either by typing a custom value, or leaving the
Default value. In the latter case, Panel uses the values from the default web server
configuration defined by the provider.
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Your values override the default ones. The only exception is the Deny access to the site
setting - IP addresses from the default configuration, as well as the IP addresses
specified by you, will all be applied to your website. In case of a conflict (for example,
when you allow the IP address that is denied in the default configuration), IIS uses your
settings.
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Website Content
To create your website and fill it with the content you need (text, images, videos, and
so on), use one of the methods provided by the Panel:




Using website creation and management tools. If you do not have a website yet,
consider setting one up by yourself with a tool for creating, editing, and publishing
websites. You can do this even if you do not possess the necessary web
programming and design skills. The best tools of this sort are the following:


Presence Builder - a website editor integrated with the Hosting Panel.



Third-party Content Management Systems (CMS) - web applications for creating
and editing websites.

Uploading existing websites to your hosting account using one the following
methods:


FTP client program. You can obtain a free FTP client from the Internet, or, if you
are using Windows, use Windows Explorer. This enables you to access your
directory on the hosting server and manage your files. If you collaborate with
other people when managing your website (such as programmers or designers),
you can provide them with access to your directory using FTP to let them edit
the website by themselves.



File Manager. A tool for uploading and managing website files and directories
through the Panel web interface.

Note: If you have a website created in Microsoft FrontPage editor, refer to the section
Working with Microsoft FrontPage Websites (Windows) (on page 83) for details on managing
this site in Panel.
Below you will find detailed descriptions of the ways to manage your content.

Presence Builder
Presence Builder is a great tool that enables users with no knowledge of HTML markup
or graphic design skills to create professional-looking sites. Just pick a suitable page
design and content template, add your text to the pages, and publish the site.
You can create and publish websites using Presence Builder if your hosting
subscription provides this option. If it does not, or if you have already created and
published the allowed number of sites, you still can create a new website with
Presence Builder and edit it. However, to publish this website, you will need to upgrade
your hosting plan.
To start creating a website using Presence Builder or edit an existing Presence Builder
site, go the Websites tab, click you domain name, and click Launch Presence Builder. Find
more information on creating and editing websites in Presence Builder in the chapter
Creating Websites with Parallels Presence Builder (on page 101).
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Third-Party Content Management Systems
To create and maintain a website, you can use third-party Content Management
Systems (CMS) - web applications that let you easily edit a website's structure and
content with a graphical user interface. Examples of such systems are Drupal and
Joomla.
CMS are usually server applications, so to start using one of them you should install it
on your hosting account. Hence, if you plan to use a CMS, ensure that your hosting
subscription allows such applications to be installed.

 To create a website using a CMS:
1. Go to the Applications tab.
2. Find the CMS you need in the list of available applications, and install it
as described in the section Using Web Applications (on page 60).
3. Create and edit your website in the CMS. For information on how to
create websites with your CMS, refer to the relevant documentation.

Uploading Using FTP
If you already have all your website files and directories, consider uploading them to
your hosting account using FTP. This is the quickest way for simple uploading of files
when you do not need to edit or manage them on the server.

 To upload files using FTP:
1. Connect to your site's domain name with an FTP client program using
your FTP access credentials. Learn how to configure these credentials
in the section Adding FTP Accounts (on page 155).
2. Copy the website files and directories to your directory on the server.

File Manager
Another way to publish a website created outside the Panel is File Manager - a tool that
provides a set of file management functions through the web interface. File Manager is
accessible from the Websites tab > domain name > File Manager. There you can upload
your websites files one by one, or in a single ZIP archive. Then you can extract them
by clicking Extract Files in the More menu.
If you want to edit pages of your website, you can do it in File Manager. It provides an
HTML editor that allows visual editing of HTML pages (without needing to manually
type HTML tags). To edit a file in the HTML editor, place the mouse pointer over the
file, click the link
to open the file's context menu, and select Edit in HTML Editor.
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You can also edit files in File Manager's text editor. To open a file in the text editor,
open the file's context menu and select the Edit in Text Editor.
If you have files or web pages that you want to make inaccessible on the Internet,
change these files' access permissions in File Manager. To edit access permissions for
a file or a directory, click the corresponding link in the Permissions column. To learn how
to review and edit the permissions, refer to the sections Setting File and Directory Access
Permissions (on page 56).

Next in this section:
Setting File and Directory Access Permissions .................................................. 56
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Setting File and Directory Access Permissions
 To review or change the permissions set for files and directories on Linux
accounts:
1. Go to the Websites tab, click your domain name, and then click File
Manager.
The permissions set for files and directories are shown in the Permissions column.
They are represented as three sets of symbols, for example, 'rwx rwx r--'. The first
set tells what the owner of the file or directory can do with it; the second tells what
the user group, the file or directory belongs to, can do with the file or directory; the
third set indicates what other users (the rest of the world, that is, Internet users
visiting a site) can do with the file or directory. R means the permission to read the
file or directory, W means the permission to write to the file or directory, and X
means the permission to execute the file or look inside the directory.

2. Locate the file or directory for which you want to modify permissions
and click a hyperlink in the Permissions column.
3. Modify the permissions as desired and click OK.

 To set access permissions for a file or directory on Windows accounts:
1. Go to the Websites tab, click your domain name, and then click File
Manager.
2. Locate the file or directory for which you want to set access
permissions, and click the corresponding icon .
3. Do the following:


To make the file or folder inherit permissions from a parent folder (if it does not),
select the checkbox Allow inheritable permissions from the parent to propagate to this
object and all child objects. Include these with entries explicitly defined here.



To make the files and folders, which are contained in this folder, inherit the
folder permissions you define, select the checkbox Replace permission entries on
all child objects with entries shown here that apply to child objects.



To change or remove permissions from a group or a user, click the required
name in the Group or user names list. If the group or user is not listed in the Group
or user names list, select the required user or group name from the menu located
above the list and click : the user/group appears in the list. Select it.
To allow or deny permissions to a selected group/user, select the Allow or Deny
checkboxes corresponding to permissions listed under Permissions for <user/group
name>. If the checkboxes in the Allow or Deny columns are shown in grey, it
means that the corresponding permissions are inherited from a parent folder.



To deny the permissions, which are inherited from a parent object as allowed,
select the required checkboxes under Deny. This will override inherited
permissions for this file/folder.
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To allow the permissions, which are inherited from a parent object as denied,
clear the Allow inheritable permissions from the parent to propagate to this object and all
child objects. Include these with entries explicitly defined here checkbox: this removes
the inherited permissions. Then select the required checkboxes under Allow and
Deny.



To remove access permissions from a group or user, select the required name
in the Group or user names list and click the icon
next to it.

4. If you need advanced fine-tuning of permissions, click the Advanced
button, and do the following:


To create a permission entry for a group or user, select the required name from
the Group or user names list and click .



To set or change file/folder permissions for a group or user, select the required
name from the Group or user names list, select the required Allow and Deny
checkboxes corresponding to permissions listed under Permissions for <user/group
name>.



To remove a permission entry for a group or user, select the required name from
the Group or user names list and click .



To make child objects of a folder inherit its permissions defined under
Permissions for <user/group name>, select the Replace permission entries on all child
objects with entries shown here that apply to child objects checkbox, and select
checkboxes in the Apply to list which correspond to the objects that must inherit
the permissions.

5. Click OK.
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(Advanced) Restricting Access to Content
If you have directories in a site that only authorized users should see, restrict access to
these directories with password protection.

 To protect a directory in your site with a password and to specify
authorized users:
1. Go to the Websites tab and click the site's domain name.
2. Click Password-Protected Directories.
3. Click Add Protected Directory.
4. In the Directory name box, specify the path to the directory that you want
to protect with a password.
This can be any directory existing in the site, for example: /private. If the
directory that you would like to protect has not yet been created, specify the path
and the directory name – the Panel will create it for you.

5. In the Title of the protected area box, type a resource description or a
welcoming message that your users will see when they visit the
protected area.
6. Click OK. The directory you specified will be protected.
7. To add authorized users, click Add New User.
8. Specify the username and password that will be used for accessing the
protected area. The password should be from 5 to 14 symbols in length.
Click OK.

 To add an authorized user of a protected directory:
1. Go to the Websites tab and click the site's domain name.
2. Click Password-Protected Directories.
3. Click on the name of the directory you need.
4. Click the Add New User icon.
5. Specify the username and password that will be used for accessing the
protected area. The password should be from 5 to 14 symbols in length.
6. Click OK.

 To change password for an authorized user of a protected directory:
1. Go to the Websites tab and click the site's domain name.
2. Click Password-Protected Directories.
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3. Click on the name of the directory you need. A list of authorized users
will open.
4. Click on the user’s name.
5. Specify the new password and re-type it for confirmation.
6. Click OK.

 To revoke a permission to access the protected directory from a user:
1. Go to the Websites tab and click the site's domain name.
2. Click Password-Protected Directories.
3. Click on the name of the directory you need. A list of authorized users
will open.
4. Select a checkbox corresponding to the user’s name.
5. Click Remove. Confirm the operation and click OK.

 To remove password protection and make the resource available to the
public:
1. Go to the Websites tab and click the site's domain name.
2. Click Password-Protected Directories.
3. Select a checkbox corresponding to the name of the directory from
which you want to remove protection.
4. Click Remove Protection. The protection will be removed and the contents
of the directory will be accessible to the public without restrictions.
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Previewing Websites
After you purchase a domain, its registration can require some time. The reason for the
delay is that name servers update their zone information periodically. Thus, until all
name servers have received the information about your zone, you will not be able to
access your site by its domain name. Nevertheless, you can always access your site
during domain name propagation using the Preview button on the Websites tab.
During domain name propagation other people can access your site too. For this
purpose, Panel registers your website as a subdomain of one of the provider's sites.
For example, if your website is my-domain.tld and the provider has configured the
preview service on provider-domain.tld, you can access your site on mydomain.tld.192-0-2-12.provider-domain.tld. Here 192-0-2-12 is the site's IP address
where dots are replaced with dashes.
Notes: The contents of password-protected directories might be inaccessible in the
preview mode.

Using Web Applications
You can significantly increase your website functionality by using different web apps.
Apps installed on a website can perform a number of tasks. If you are an individual,
you can, for example, present yourself with a blog or organize an online storage of your
media files. Companies can move their businesses online using the e-commerce or
CRM web apps. All these apps are available for installation from the Applications tab of
the Hosting Panel.
The list of available apps is governed by your hosting plan. For example, it might
include only free apps or no apps at all. For more information on available apps,
contact your hosting provider.

App Types
There are two types of web apps:


Apps installed directly on your website (for example, the WordPress blogging
platform or the Joomla! content management system).



Apps installed on external servers and provided by third parties.

Regardless of the installation type, apps can be either free or commercial. Commercial
apps require you to obtain a license key to start working with them. You can recognize
commercial apps in the catalog on the Application tab by the button Buy now (instead of
Install for free apps). If you decide to use commercial apps, read the Managing
Commercial App Licenses (on page 65) section to learn more about acquiring and
managing app licenses.
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App Installation and Maintenance
The installation process is fully automated and does not require any specific skills. To
learn how to install web apps from the Hosting Panel, refer to the section Installing Apps
(on page 62).
Further app management is also facilitated as you can update or remove apps directly
in Panel. Moreover, you can access some functions from the Hosting Panel, without
the need to log in to an app. For example, you can add SugarCRM user account right
from your Hosting Panel. Such app functionality is a service provided by the app.
After you install an app, grant other auxiliary user accounts access to it if you want
them to be able to use the app. To get started with managing apps, see the section
Managing Apps (on page 63).

App Databases
If an app requires a database, Panel creates it automatically during installation of the
app. To create a database, Panel uses app database settings, which you can change
in the Main configuration section (Show All Settings link) when installing an app:


A database name and a database server where the app will store the database.



Database user credentials, which Panel will use to access the app database. It may
be convenient to employ a single database user with access to all databases. In
this case, you can create a universal user account and specify it when installing
apps. To learn more, refer to the section Managing Database User Accounts (on page
172).

Note that if you exceed the maximum number of databases allowed for your
subscription, a new app does not create a new database. Instead, it adds tables to one
of the existing databases, and adds prefixes to table names. Prefixes make it easier to
distinguish tables of different apps. For example, the Wordpress app will add the
“wpress_” prefix to the names of its tables.

Access to Apps
By default, after you install an app, it is available only to users with the Owner role. You
can make your apps available to certain auxiliary users by adjusting their permissions.
For details on setting up access to apps for auxiliary users, refer to the section Granting
Auxiliary Users Access to Apps (on page 63).
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Apps and Auxiliary User Accounts
Some apps let you create and manage user accounts directly in Panel. For example,
the SugarCRM app allows you to add SugarCRM users without logging in to the app.
All apps with such "account services" can associate their accounts with users of a
Panel subscription (auxiliary users). To perform such an association, you should grant
the auxiliary users access to that account service (in the same way as you grant
access to apps). For details on account association, refer to the section Linking Apps
and Auxiliary User Accounts (on page 64).

Next in this section:
Installing Apps ................................................................................................... 62
Managing Apps ................................................................................................. 63
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Installing Apps
 To install an app:
1. Go to the Applications tab and find the app you need.
2. Click Install.
3. Specify the settings required for installation of the app.
Note: For commercial apps, you should obtain a license key by clicking Buy now before
starting the installation. To learn more about using commercial apps refer to the section
Managing Commercial App Licenses (on page 65).
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Managing Apps
Generally, all apps allow the configuration of their main parameters directly in the
Hosting Panel. You can access app settings by selecting the app from the list in
Applications > Manage My Applications. After you select an app, you can configure the
following:


General settings.
These are basic settings (for example, the app administrator password) that can be
changed with Change Settings.



Service settings.
If an app provides a part of its functionality to Panel by means of services, you have
the option to configure them. For example, the SugarCRM app allows the creation
of user accounts and provides this ability as a service in the Hosting Panel. After
you select this service in Provided services, you can view all app user accounts and
create new ones.
For some apps, you can associate the app accounts with auxiliary user accounts.
Learn more about account association in the section Linking App and Auxiliary User
Accounts (on page 64).

Granting Auxiliary Users Access to Apps
By default, after you install an app, only users with the Owner role can access it. To
allow other subscription users to access the app:


Grant permission to access the app to a certain user group in Users > User Roles.



Be sure to add users of your choice to the group.

Once you allow users to access the app, a link to the app appears on the Websites tab
under the name of the corresponding website. Note that you can control app access
only for user groups, so you should either modify the permissions of an existing group
or create a new one, and then assign users to it.
By default, the app administrator is a subscription user with the Owner role. As well as
accessing the apps from the Websites tab, this user can also install and manage apps
within a subscription. For these purposes, their interface has the additional Applications
tab. You can provide the same administrative privileges to other subscription users by
granting the Install and manage applications permission to their role in Users > User Roles.
This gives users full administrative access to all apps within a subscription. As well as
the administrator, the users with this permission can install, configure, update, and
remove apps through the Applications tab in their Hosting Panel.
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Linking Apps and Auxiliary User Accounts
Some apps let you create and manage user accounts without logging in to the app. If
an app provides such an account service, you can link users of a Panel subscription
with accounts in the app. To perform such an association:
1. Organize the users into a certain group (Users > User Roles).
2. Grant one of these group permissions:


Public access.
If granted, all users in the group will have access to the app through the link on
the Websites tab.



Personal access.
If granted, the app will automatically create accounts for all users in the group.
After that, the users' Websites tab will contain an additional link that allows
logging in to a personal account in the app. Note that if you deny the Personal
access permission, the app will automatically remove all accounts associated
with this group.

Updating Apps
Automatic Updates
By default, Panel installs the latest available app versions and updates apps
immediately once the newer versions are available. However, updating an app can
significantly change its functionality: For example, plug-ins or extensions developed for
a particular app version may be incompatible with newer versions. Therefore, you
might want to turn off automatic updates for a certain app.

 To turn automatic updates on or off:
1. Go to Applications > Manage My Applications and click the app's name.
2. Click Change Settings.
3. Select or clear the checkbox Automatically update this app when updates are
available.

Manual Updates
If you prohibit automatic updates for an app, Panel will inform you about the availability
of newer versions by adding the link Update available under the app name in Applications
> Manage My Applications. Click this link to review the changes available in the new
version and decide whether to update the app or continue using the current version.
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Managing Commercial App Licenses
If you decide to buy an application license in the Hosting Panel and click the
corresponding button on the Applications tab, you will be forwarded to Storefront, the
online store where you complete your order. Actually it is not only a store, it also
includes its own web interface to help you perform various operations on the licenses
you own. For example, from this web interface you can renew a license, cancel it,
change your payment methods and so on. This section explains how to carry out these
operations.

Storefront Basics
When you order a first license in Storefront, it creates an account for you. This account
contains your personal and financial information; if you log in to Storefront under this
account, you will be able to do various operations with your licenses.
Each time you successfully check out in Storefront, a purchase order is generated. It is
a document that lists the cart items you ordered. Storefront assigns different statuses
to orders. These statuses explain the current state of your purchase - whether it is
unpaid, canceled, or successfully delivered.
Storefront and Panel share the service plans business model. In Storefront, each
application is presented by a separate service plan, and when you order an application
license you subscribe to one of the service plans. In other words, each license you
purchase is shown as a subscription in the web interface. For instance, if you would
like to view a license price, terms, or an expiration date, you should open the
corresponding subscription.

How to Obtain a License Key
After you order a license and pay for it, Storefront sends you an email with your license
key. We recommend that you keep the information in a safe place because there is no
way to request it again or view it from the web interface. If you did not receive the email
with a license file or key, contact us at https://support.parallels.com/.

Available Operations
The operations you can carry out in Storefront fall into three groups:


Operations on your user account. These operations include viewing and modifying
your personal information and preferences and changing the password to your user
account.



Operations on payments and payment methods. This group comprises operations
on your credit cards, payments, and orders.



Operations on subscriptions. Use them to acquire new licenses, obtain information
about your existing licenses, and check the subscription renewal method for a
particular subscription.

Learn more about these operations in the following sections.
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User Account
You can do the following operations on your user account.

View and Change Your Account Information
The system uses your account information to add your personal and financial details
into invoices. If you see that you need to update your details, open the My Contact Info
submenu on the Navigation menu and select Account Info.

View and Change Your Personal Information
Your personal information mostly duplicates the account information. It does not
appear in financial documents, but some services use this information as technical
contact details. For example, it is possible to order a domain name through Storefront,
and if you do so, Storefront will send your personal information (as the technical
contact) to a domain name registrar.
To view user personal information, open the My Contact Info > Personal Info menu on the
left panel. Here you can also edit your personal information and change the password
to your Storefront account.

Configure Email Notifications
Email notifications are sent on different events to your account contact email address.
They fall into a number of categories. For example, subscription renewal and
expiration, your credit card expiration, and so on. You can select message format for
every group of messages and decide whether to send certain messages or not. To
configure message types to receive, open My Contact Info > Notification Methods.
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Payments and Payment Methods
This section describes operations on payments and credit cards available to you in
Storefront.

Registering a Credit Card
Before a credit card becomes available for making online payments, it is necessary to
register it in Storefront. To register a credit card, open Billing Manager > My Financial Info
> Payment Methods and click the appropriate button.

Configuring Automatic Payments
You can assign one of the registered credit cards to be used for paying orders
automatically. In this case, you will not need to pay each order manually. If you assign
a payment method to be used for automatic payments, the previous default one is
deselected automatically. Thus, only one payment method can be used for automated
payments.
To turn on automatic payments from a card, go to Billing Manager > My Financial Info >
Payment Methods, select the card by clicking its ID or Type, and, finally, enable automatic
payments in card properties.

Making a Payment
To add a new payment, open the Billing Manager > New Payment link on the dashboard.
The adding new payment wizard starts. The list of pending documents appears on the
screen. If there are no pending documents, click Cancel to finish the wizard. Otherwise,
go through the wizard by providing the payment settings.

Viewing Open Orders
Your open orders are available in the Billing Manager > My Financial Info > Open Orders
submenu.
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Subscriptions
Storefront offers you a powerful and comprehensive mechanism of subscriptions
(licenses) management, allowing you to perform the following operations.

Buying a Subscription
If you want to purchase one more app license or another service offered by Storefront,
there is no need for you to go to the Hosting Panel. The Storefront web interface
provides all facilities for making the purchase. To start the subscription ordering wizard,
open Billing Manager > Subscription Management and click Buy New Subscription.

Renewing a Subscription Manually
If you did not configure an auto-renewal, your subscription will expire unless you renew
it manually. The auto-renewal setup instructions are given later in this section. To
renew a subscription manually, open Billing Manager > Subscription Management > Renew
Subscription and follow the steps of the wizard.

Renewing Subscriptions Automatically
Configuring a subscription for auto-renewal helps renewing your subscriptions in a
timely manner. To allow auto-renewal, open Billing Manager > Subscription Management >
Renew Subscription, click a subscription for which you want to turn the option on, and
click Turn On AutoRenew Option. Clear the option to cancel the auto-renewal.

Canceling a Subscription
A subscription cancellation results in the termination of the subscription services and
money refund. To cancel a subscription, open Billing Manager > Subscription Management
> Renew Subscription, click a subscription you want to cancel, and start the cancellation
wizard by clicking Cancel Subscription.

(Advanced) Website Security
Next in this section:
Securing Connections with SSL Certificates ...................................................... 69
Protecting Sites from Hotlinking (Windows) ....................................................... 73
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Securing Connections with SSL Certificates
If your website transfers sensitive data, for example, visitors' credit card numbers, we
recommend that you secure the communications between the site and its visitors by
means of SSL encryption. To set up such a secure channel, you should purchase an
SSL certificate for your website.
Not only are SSL certificates used for establishing secure communication channels on
the Internet, but also for verifying a website's identity as well. When users visit your
secure online store, they are notified that your website is really what it claims to be and
that all sensitive data, such as credit card numbers, will be transferred over a secure
channel.
SSL certificates are issued by organizations - SSL certificate providers. However, some
hosting providers allow customers to purchase SSL certificates directly from Panel.

Purchasing SSL Certificates
Depending on your hosting provider, you can use the following ways of purchasing SSL
certificates:


Order an SSL certificate from Panel. This way is available to you if your provider
configures the corresponding Panel settings. The links for purchasing SSL
certificates from Panel may let your purchase certificates either from your provider
in their online store or from Parallels in the MyPlesk outlet. To learn how to order an
SSL certificate through Panel, see the section Purchasing SSL Certificates Through
Panel (on page 70).



Order an SSL certificate from the SSL certificate provider you like. In this case, you
should create a certificate signing request (CSR) for your website in Panel and
submit it to an SSL certificate provider. To learn how to create such request and
purchase a certificate with it, refer to the section Generating Certificate Signing
Requests (on page 71).

Securing Websites
After you obtain a certificate for your website, you should secure the connection to the
website with the certificate. The section Securing Websites (on page 72) explains how to
do this.

Next in this section:
Purchasing SSL Certificates Through Panel ...................................................... 70
Generating Certificate Signing Requests ........................................................... 71
Securing Websites ............................................................................................ 72
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Purchasing SSL Certificates Through Panel
The links for purchasing SSL certificates in Panel let you purchase either certificates
from your provider if they offer their own certificates, or certificates from Parallels in the
MyPlesk store. These links may also be unavailable to you if your provider decides so.

 To purchase an SSL certificate through Panel:
1. Go to the Websites tab and click the domain name of the site that you
want to protect with an SSL certificate.
2. Click Secure Your Sites.
3. Click Add SSL Certificate.
4. Specify the following certificate parameters:


Certificate name. This will help you identify this certificate in the repository.



Your location and organization name. The values you enter should not exceed
the length of 64 symbols.



The domain name for which you want to purchase an SSL certificate. This
should be a fully qualified domain name. Example: your-domain.com.



The website administrator's email address.

5. Make sure that all the provided information is correct and accurate, as it
will be used to generate your private key.
6. Click Buy SSL Certificate.
7. Complete all steps of an SSL certificate purchase in the online store
and you will receive your SSL certificate by email.
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Generating Certificate Signing Requests
If your hosting provider does not allow purchasing SSL certificates through Panel, you
can create a certificate signing request and submit it to an SSL certificate provider. The
provider will generate an SSL certificate for your website based on this request.

 To generate a certificate signing request:
1. Go to the Websites tab and click the domain name of the site that you
want to protect with an SSL certificate.
2. Click Secure Your Sites.
3. Click Add SSL Certificate.
4. Specify the following certificate parameters:


Certificate name. This will help you identify this certificate in the repository.



Your location and organization name. The values you enter should not exceed
the length of 64 symbols.



The domain name for which you want to purchase an SSL certificate. This
should be a fully qualified domain name. Example: your-domain.com.



The website administrator's email address.

5. Make sure that all the provided information is correct and accurate, as it
will be used to generate your private key.
6. Click Request. Panel will generate your private key and a certificate
signing request and add them to your certificates repository (Websites
tab > Secure Your Sites).
7. In the list of certificates, click the name of the certificate you need.
8. Locate the CSR section on the page, and copy the text that starts with the
line -----BEGIN CERTIFICATE REQUEST----- and ends with the line -----END
CERTIFICATE REQUEST----- to the clipboard.
9. Visit the website of the certification authority from which you want to
purchase an SSL certificate, and follow the links on their site to start a
certificate ordering procedure. When you are prompted to specify CSR
text, paste the data from the clipboard into the online form and click
Continue. The certification authority will create an SSL certificate in
accordance with the information you supplied.
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Securing Websites
After you receive an SSL certificate for your website, secure the website with this
certificate.

 To secure a website with an SSL certificate:
1. Go to the Websites tab and click the domain name of the website that you
want to protect with an SSL certificate.
2. Click Secure Your Sites.
3. Upload the SSL certificate: Click Browse in the middle of the screen and
navigate to the location of the saved certificate. Select it, and then click
Send File.
This will upload and install the certificate against the corresponding private key.

4. To install the certificate on a site, return to the Websites tab, and click the
domain name of the website that you want to secure.
5. Click Website Scripting and Security.
6. Select the SSL support checkbox.
7. From the Certificate menu, select your SSL certificate and click OK.
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Protecting Sites from Hotlinking (Windows)
Hotlinking (also called file leeching, remote linking, direct linking, bandwidth stealing or
bandwidth banditism) is a term used for describing a situation when a web page of one
domain owner is directly linking to images (or other multimedia files) on the web pages
of another domain owner, usually using an <IMG> tag. If your domains are hotlinked,
you may face the problem of excessive bandwidth usage.

 To protect a website from hotlinking:
1. Go to the Websites tab and click the website's domain name.
2. Click Hotlink Protection.
3. Click Switch On to enable the protection from hotlinking.
4. Specify the extensions of files that you want to protect from hotlinking
(for example, jpg, bmp, and so on) in the Protected files extensions field.
When listing several file extensions, separate them with white spaces.
5. If you want to allow direct linking to your files from certain sites, type
the website addresses into the Addresses of friendly websites field, and click
Add.
6. Click OK.

(Advanced) Extended Website
Management
Panel provides a number of operations on websites and domains for advanced users:
Working with third-party applications and services, fine tuning of some system services,
and much more. This section contains the detailed instructions on all these operations.

Next in this section:
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Hosting Personal Web Pages Under Your Domains .......................................... 80
Limiting Bandwidth and Number of Connections to Websites ............................ 82
Working with Microsoft FrontPage Websites (Windows) .................................... 83
Using Virtual Directories (Windows) .................................................................. 88
Setting Up IIS Application Pool (Windows) ........................................................ 100

74

Websites and Domains

Working with a Staging Site
If you have a production website and are planning major site changes, consider setting
up a staging site — a separate location on the server where you can conveniently
update and test a copy of the site before putting it into production.
We recommend that you work with a staging site in the following way:
1. Decide where you want to host the development copy and prepare the
development environment. You can choose to host it in the same webspace, in a
separate webspace on the same server, or upload it to an FTP account on another
server.
If you choose the same webspace, then you first need to set up a new website by
adding a domain or a subdomain.
2. (Optional step.) If you set up your development environment under your account in
the Panel and your production site has APS applications installed via the Panel (at
the Applications tab), install the desired site applications in your development
environment in the same subdirectory as you have on your production site. This
step is optional; however, it will help you avoid changing manually database
connection settings in the application scripts.
3. Make a copy of the website and place it in the staging environment.
4. Make copies of the databases used by the site and deploy them in the staging
environment.
5. Change database connection settings in the scripts to point at the databases in the
staging environment.
6. (Optional step.) Complete APS applications setup. Go to the Applications tab for
your development site, locate the application in the list of installed applications,
open its Settings screen and re-save the parameters. With this operation, the APS
scripts should stop pointing at the production database and reconnect the
application to the database copy. This step is needed if your production site has
APS apps installed via the Panel and you performed Step 2 of the current
instruction.
7. Make the required changes to the site copy in the staging environment, and test
them to make sure everything works as intended.
8. Publish the updated site. This is done by pointing the document root of the
production site to the staging site location.

 To set up a site for staging purposes:
1. Go to the Websites tab.
2. Click either Add New Domain or Add New Subdomain.
We recommend that you use a subdomain for staging purposes.

3. Proceed as described in Adding Domains or Adding Subdomains.
If you do not want your staging site to be accessible to the Internet users, do not
register the newly added domain or subdomain name with a domain name registrar, or
use an .htaccess file (on Linux hosting) to restrict access to it.
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 To make a copy of website files:
1. Go to the Websites tab and click the name of the website you want to
copy.
2. Click Website Copying.
3. To copy website files to the document root of an existing site:
a. Select the option Website in the Panel.
b. Select the destination site from the Site name menu.
c. Specify what to do with the files that might already be present in
the destination directory.
4. To copy website files to an FTP account on this or another server:
a. Select the option FTP storage.
b. Specify the server's host name and credentials for connecting to
the FTP account.
c. In the FTP connection method field, leave the Active mode option
selected. If the Panel fails to connect to the external FTP
account, select the Passive mode option here.
5. Click OK.
If the site uses scripts that work with a database, copy the database to the staging
environment:


If the database is hosted on the same server managed by Panel, use the procedure
below to copy it.



If the database is hosted on a server which is not managed by Panel, use the
mysqldump utility to export the database, move the resulting data dump file to the
staging environment and deploy it there. Modify the site's scripts in the staging
environment so that they connect to the copied database.

 To make a copy of a database from the Panel-managed server:
1. Go to the Websites tab > Databases.
2. Click Copy in the databases list for the database you want to copy.
3. Specify the following:


Destination database server. You can select the same Panel-managed database
server, or a database server located elsewhere. For an external database
server, specify the host name or IP address, and access credentials: the
username and password of a database management system user authorized to
create new databases and database tables.



Destination database. You can choose to create a new database or copy the data
to an existing database.



Create a full copy. Leave this option selected to copy the database structure and
all data.
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4. Click OK.
The copy of the database will be deployed on the destination server.

5. Modify the site's scripts in the staging environment so that they connect
to the copied database.
When the site copy in the staging environment is updated and ready to go live, publish
it as described in the following steps.

 To publish the updated site to the production environment:
1. Go to the Websites tab.
2. In the list of domain names, locate the name of your production site and
click it.
3. Click the link Hosting Settings next to the domain name.
4. In the Document root box, specify the document root directory of the
staging site.
5. Click OK.
This will make the updated site copy in the staging site location accessible to visitors of
your production site address.
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Setting Up Custom Error Pages
When visitors coming to a site request pages that the web server cannot find, the web
server generates and displays a standard HTML page with an error message. You may
want to create your own error pages and use them for your sites or individual virtual
directories (on Windows). The following error messages are the ones customized most
often:


400 Bad File Request. Usually means the syntax used in the URL is incorrect (for
example, uppercase letter should be lowercase letter; wrong punctuation marks).



401 Unauthorized. The server is looking for some encryption key from the client
and is not getting it. Also, a wrong password may have been entered.



403 Forbidden/Access denied. Similar to 401; a special permission is needed to
access the site – a password or username, if it is a registration issue.



404 Not Found. The server cannot find the requested file. The file has either been
moved or deleted, or the wrong URL or document name was entered. This is the
most common error.



500 Internal Server Error. Could not retrieve the HTML document because of server
configuration problems.



503 Service Temporarily Unavailable. The site is temporarily unavailable due to
maintenance.

Next in this section:
Setting Up Custom Error Pages on Windows-Based Hosting Accounts............. 78
Setting Up Custom Error Pages on Linux-Based Hosting Accounts .................. 79
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Setting Up Custom Error Pages on Windows-Based Hosting
Accounts
 To configure the web server to show custom error pages for a site or a
directory within a site:
1. Switch on support for custom error documents.
a. Go to the Websites tab and click the link Hosting Settings next to
the domain name you need.
b. Select the Custom error documents checkbox.
c. Click OK.
2. Go to the Websites tab.
3. Click the domain name you need.
4. Click Virtual Directories to see the list of error documents for the root web
directory. Error documents located here are used for all web pages of
the selected site. If you want to customize error pages for a specific
virtual directory, navigate to that directory.
5. Click the Error Documents tab and click the required error document in the
list.


To use the default document provided by IIS for this error page, select Default in
the Type menu.



To use a custom HTML document already located in the error_docs directory
in the virtual host directory of the domain, select File in the Type menu and
specify the file name in the Location field.



To use a custom HTML document located in a directory other than
error_docs on a domain, select URL in the Type menu and enter the path to
your document in the Location field. The path should be relative to the virtual
host root (that is, <vhosts>\<domain>\httpdocs).
For example, you have created a file forbidden_403_1.html and saved it in
the my_errors directory located in the httpdocs. To use this file as an error
document, you need to type the following path into the Location field:
/my_errors/forbidden_403_1.html.

Note: You can use a connection over FTP or File Manager in the Panel to upload
your custom error document to the server. By default, all error documents are
stored in the /vhosts/your-domain.com/error_docs/ directory (located in
C:\InetPub by default).

6. Once the web server is restarted, it will start using your error
documents.
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Setting Up Custom Error Pages on Linux-Based Hosting
Accounts
 To configure the web server to show custom error pages for a site:
1. Switch on support for custom error documents.
a. Go to the Websites tab and click the link Hosting Settings next to
the domain name you need.
b. Select the Custom error documents checkbox.
c. Click OK.
2. Connect to your FTP account, and go to the error_docs directory.
3. Edit or replace the respective files. Be sure to preserve the correct file
names:


400 Bad File Request - bad_request.html



401 Unauthorized - unauthorized.html



403 Forbidden/Access denied - forbidden.html



404 Not Found - not_found.html



405 Method Not Allowed - method_not_allowed.html



406 Not Acceptable - not_acceptable.html



407 Proxy Authentication Required - proxy_authentication_required.html



412 Precondition Failed - precondition_failed.html



414 Request-URI Too Long - request-uri_too_long.html



415 Unsupported Media Type - unsupported_media_type.html



500 Internal Server Error - internal_server_error.html



501 Not Implemented - not_implemented.html



502 Bad Gateway - bad_gateway.html



503 Service Temporarily Unavailable - maintenance.html

The web server will start using your error documents in a few hours, after it is restarted.
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Hosting Personal Web Pages Under Your Domains
On your web server, you can host personal web pages for users who do not need their
own domain names. These pages usually have web addresses like http://yourdomain.com/~username.

 To accommodate a personal web page under your domain and set up an
FTP account for publishing:
1. Go to the Websites tab and click the domain name under which you want
to create a personal web page.
2. Click Web Users.
3. Click Settings.
4. If you want to allow execution of scripts embedded in personal web
pages, select the Allow web users to use scripts checkbox.
5. Click OK.
The settings you have defined in step 3 are common for all personal web pages you
might host on your account. Therefore, you will not need to perform the steps from
3 to 5 next time you set up a new web user account.

6. Click Add New Web User.
7. Specify a username and a password that will be used for accessing the
webspace through FTP and publishing the web pages.
You can use only lower-case alphanumeric, hyphen and underscore symbols in the
username. The username should begin with an alphabet character. It cannot
contain white spaces. The password cannot contain quotation marks, white space,
username, and should be between 5 and 14 characters in length.

8. If you want to limit the amount of disk space that can be occupied by
the web page content, type the desired value in megabytes into the Hard
disk quota box.
When the specified limit is exceeded, the web page owner will not be able to add
files to his or her webspace.

9. Specify the programming languages that should be supported for the
web page.
For example, if the web page is written in PHP, select the PHP support checkbox.

10. If you use a Windows-based hosting account and this personal web
page's applications need to use a file-based database (like Jet) located
in the root of httpdocs directory, select the Additional write/modify
permissions option. Note that selecting this option might seriously
compromise the website security.
11. Click OK.
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Now you can tell your user the FTP account credentials, so that he or she can publish
their web page.

 To change FTP password for a web page owner:
1. Go to the Websites tab and click the name of the domain that contains
the personal page.
2. Click Web Users.
3. Click the user name you need.
4. Type the new password into the New password and Confirm password
boxes.
5. Click OK.

 To allocate more disk space to the web page owner:
1. Go to the Websites tab and click the name of the domain that contains
the personal page.
2. Click Web Users.
3. Click the user name you need.
4. Type the amount of disk space in megabytes into the Hard disk quota box.
5. Click OK.

 To remove a web page owner’s account together with their web page:
1. Go to the Websites tab and click the name of the domain that contains
the personal page.
2. Click Web Users.
3. Select the checkbox corresponding to the user account you want to
remove and click Remove.
4. Confirm removal and click OK.
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Limiting Bandwidth and Number of Connections to
Websites
To avoid excessive usage of bandwidth, and protect your site from Denial Of Service
attacks, you can limit bandwidth usage for a site and the number of simultaneous
connections.

 To limit bandwidth usage and the number of connections to a site:
1. Go to the Websites tab and click the site's domain name.
2. Click Bandwidth Limiting.
3. Select the Switch on bandwidth limiting checkbox.
4. In the Maximum bandwidth usage (KB/S) box, specify the maximum speed,
measured in kilobytes per second, that a website can share among all
its connections.
5. Select the Switch on connections limiting checkbox.
6. In the Connections limited to box, specify the maximum number of
simultaneous connections to the site.
7. Click OK.
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Working with Microsoft FrontPage Websites (Windows)
Microsoft FrontPage deals with two kinds of websites: disk-based and server-based. In
short, a disk-based site is a FrontPage website you create on your local hard disk and
then later publish to the server. A server-based site is one you create and work with
directly on the server, without the extra step of publishing. This section provides you
with instructions on publishing only disk-based websites.
You can publish disk-based websites either through FTP or HTTP. If your hosting
account supports FrontPage Server Extensions, you would publish your site over
HTTP. For example: http://your-domain.com/MyWebSite. If your hosting server
supports FTP, you would publish to an FTP location. For example: ftp://ftp.yourdomain.com/myFolder.
After publishing, you can manage your site through FrontPage Server Extensions.

 To access FrontPage Server Extensions management interface:
1. Click the Websites tab and click the domain name of the website you
want to manage in FrontPage.
2. Click FrontPage.
3. Do either of the following:


To manage a site over HTTP connection, click Frontpage Webadmin.



To manage a site over a secure SSL connection, if SSL support is enabled for
the site, click Frontpage SSL Webadmin.

4. Type your FrontPage administrator’s username and password, and click
OK.
For instructions on using FrontPage server extensions, see online help (Frontpage
Webadmin > Help) or visit Microsoft website.
The following FrontPage settings are changeable through the Panel:


The use of Microsoft FrontPage IIS Index Server for building the full-text index
of your website.



SMTP mail server and sender's email address. These options are applicable if
you use FrontPage forms that submit information from your site by email. By
default, the SMTP server specified in the domain's DNS zone is used for
sending mail. If no SMTP server is specified in the zone, then FrontPage uses
the mail service running on the server where the site is hosted.

 To change any of these settings:
1. Click the Websites tab and click the domain name of the website you
want to manage in FrontPage.
2. Go to FrontPage > Settings.
3. Make the required changes and click OK.
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Publishing FrontPage Websites
 To publish files through FTP:
1. Open your FrontPage program.
2. Open a FrontPage website: open File menu and select the Open Site item.
3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web
Site button at the bottom of the window.
4. Set up your Remote Web Site Properties:


Click the Remote Web Site Properties button in the upper-right corner of the
window.



Select FTP as the remote Web server.



In the Remote Web site location box, type your host name (for example,
ftp://ftp.your-domain.com)



In the FTP directory box, type your FTP directory if your hosting company
provided one. Leave it blank if they did not specify one.



Select the Use Passive FTP check box if your computer or network is protected by
a firewall.

5. Click OK to connect to the remote site.
The Remote Web site view will show files that you have in your local and remote
sites.

6. Click the Publish Web site button in the lower-right corner of the window.

 To publish files through HTTP on a server that supports FrontPage Server
Extensions:
1. Open your FrontPage program.
2. Open a FrontPage website: open File menu and select the Open Site item.
3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web
Site button at the bottom of the window.
4. Click the Remote Web Site Properties button in the upper-right corner of the
window.
5. On the Remote Web Site tab, under Remote Web server type, click FrontPage or
SharePoint Services.
6. In the Remote Web site location box, type the Internet address, including
the protocol, of the remote website that you want to publish folders and
files to, for example, http://www.your-domain.com, or click Browse to
locate the site.
7. Do any of the following:
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To use Secure Sockets Layer (SSL) for establishing a secure communication
channel to prevent the interception of critical information, click Encryption
connection required (SSL). To use SSL connections on your web server, the server
must be configured with a security certificate from a recognized certificate
authority. If the server does not support SSL, clear this checkbox. Otherwise,
you will not be able to publish folders and files to the remote website.



To remove specific types of code from web pages as they are being published,
on the Optimize HTML tab, select the options you want.



To change the default options for publishing, on the Publishing tab, select the
options you want.

8. Click OK to connect to the remote site.
The Remote Web site view will show files that you have in your local and remote sites.

9. Click the Publish Web site button in the lower-right corner of the window.
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Adding FrontPage Accounts
If you are using Microsoft FrontPage for collaborating on website content with other
users, then you need to create additional Microsoft FrontPage accounts.

 To create an additional Microsoft FrontPage account:
1. Go to the Websites tab and click the domain name of the website for
which you want to create the account.
2. Click FrontPage.
3. Click Add New FrontPage Account.
4. Specify the following:


Username and password for the account.



Limit on disk space. If you want to limit the amount of disk space that can be
used by this account, clear the Unlimited checkbox and type the desired value in
megabytes into the Hard disk quota box.
When the specified limit is exceeded, the user will not be able to upload more
files to the webspace.

5. Click OK.

 To change settings for an additional Microsoft FrontPage account:
1. Go to the Websites tab and click the domain name you need.
2. Click FrontPage.
3. Click the required account name in the list.
4. Adjust the settings as necessary and click OK to save changes.

 To remove an additional Microsoft FrontPage account:
1. Go to the Websites tab and click the domain name you need.
2. Click FrontPage.
3. Select the checkbox corresponding to the account you want to remove.
4. Click Remove.
5. Confirm the removal and click OK.
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Using Virtual Directories (Windows)
A virtual directory is a link to an existing physical directory that is present on the
server's hard disk. Virtual directories can have a number of specific settings such as
custom ASP.NET configuration, access permissions, and protection with a password.
Because any virtual directory can have its own settings, including customized
ASP.NET configuration, virtual directories are very useful in setting up your web
applications, especially those written in ASP.NET. For example, if you have three web
applications that use ASP.NET version 1.1, and you need to install one web application
that uses ASP.NET version 2.0, you can create a virtual directory for the ASP.NET 2.0
application, configure ASP.NET settings for this directory so as to enable support for
version 2.0, and then successfully install the required application.
Virtual directories can also be used as aliases. For example, you have a web
application installed on your domain "example.com" in the physical directory
"/my_data/web_apps/forum". To access this web application, users need to type
"example.com/my_data/web_apps/forum", which is hard to remember and too
long to type. You can create virtual directory called forum in the root of your virtual
host, and link this virtual directory to "/my_data/web_apps/forum", so the users
who want to access the web application will need to type "example.com/forum",
which is much shorter and easier to remember.

Next in this section:
Creating Virtual Directories................................................................................ 89
Configuring ASP.NET for Virtual Directories ...................................................... 91
Configuring PHP Settings for Virtual Directories ................................................ 93
Setting Up Access to Virtual Directories ............................................................ 94
Changing Virtual Directory Settings ................................................................... 96
Adding and Removing MIME Types .................................................................. 98
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Creating Virtual Directories
 To create a virtual directory within a website:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories. You are in your web site root now.
3. Navigate to the directory in which you want to create a new virtual
directory.
4. Click Create Virtual Directory.
Note: To create a physical directory instead of virtual directory, click Create Directory,
specify the name of the directory and click OK.

5. Specify the required parameters:


Name - specify the virtual directory name.



Path - specify the virtual directory path:


Select the Create physical directory with the same name as virtual directory
checkbox to automatically create a physical directory with the same name as
the virtual directory you are creating.



Clear the Create physical directory with the same name as virtual directory
checkbox and specify the path in the field to select a physical directory that
already exists.



Script source access - select this checkbox to allow users to access source code if
either Read or Write permissions are set. Source code includes scripts in ASP
applications.



Read permission - select this checkbox to allow users to read files or directories
and their associated properties.



Write permission - select this checkbox to allow users to upload files and their
associated properties to the virtual directory or to change content in a writeenabled file. Write access is allowed only if browser supports the PUT feature of
the HTTP 1.1 protocol.



Directory browsing - select this checkbox to allow users to see a hypertext listing
of the files and subdirectories in the virtual directory.



Log visits - select this checkbox if you want to store the information about visits
of the virtual directory.



Create application - select this checkbox to make the directory an IIS application.
The directory becomes logically independent from the rest of the website.



Execute permissions - select the appropriate program execution level allowed for
the virtual directory.





None - allow access only to static files such as HTML or image files.



Scripts only - allow running scripts only, not executables.



Scripts and Executables - remove all restrictions so that all file types can be
executed.

ASP Settings - set specific settings for ASP-based web applications.
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If you are using ASP-based applications that cannot operate correctly under
data transfer restrictions currently set by IIS, clear the Defined by parent
directory checkbox corresponding to the field you want to change and type in
the required number.



If you want to enable debugging of ASP applications on the server side,
clear the corresponding Defined by parent directory checkbox and select the
Enable ASP server-side script debugging checkbox.



If you want to enable debugging of ASP applications on the client side, clear
the corresponding Defined by parent directory checkbox and select the Enable
ASP client-side script debugging checkbox.

Note that if you are trying to change ASP Settings for the root virtual directory,
the default checkbox names will be Defined by IIS instead of Defined by parent
directory.

6. Click OK.

 To remove a virtual directory from a website:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories.
3. Select the checkbox corresponding to the directory you want to remove.
4. Click Remove.
5. Confirm the removal and click OK.
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Configuring ASP.NET for Virtual Directories
 To configure ASP.NET settings for a virtual directory within a website:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories.
3. Browse to the required directory and click a link with its name.
4. Click ASP.NET Settings.
5. Set up the strings that determine database connection data for
ASP.NET applications that use databases. This option is available only
for ASP.NET 2.0.x.
When you open the ASP.NET configuration page for the first time, sample
connection parameters with common constructions are displayed. You can
delete them and specify your own strings.


To add a string, enter the required data into the Name and Connection Parameters
input fields and click
next to them.



To remove a string, click

next to it.

6. Set up custom error messages that will be returned by ASP.NET
applications:




To set the custom error messages mode, select an appropriate option from the
Custom error mode menu:


On - custom error messages are enabled.



Off - custom error messages are disabled and detailed errors are to be
shown.



RemoteOnly - custom error messages are displayed only to remote clients,
and ASP.NET errors are shown to the local host.

To add a new custom error message (which will be applied unless the Off mode
was selected), enter the values in the Status Code and Redirect URL fields, and
click .


Status Code defines the HTTP status code resulting in redirection to the error
page.



Redirect URL defines the web address of the error page presenting
information about the error to the client.

Due to possible conflicts, you cannot add a new custom error message with an
error code that already exists, but you can redefine the URL for the existing
code.


To remove a custom error message from the list, click

next to it.

7. Configure compilation settings in the Compilation and Debugging field:


To determine the programming language to be used as default in dynamic
compilation files, choose an entry from the Default web page language menu.
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To enable compiling of retail binaries, leave the Switch on debugging checkbox
empty.



To enable compiling of debug binaries, select the Switch on debugging checkbox.
In this case, the source code fragments containing an error will be shown in a
diagnostic message.

Note: When running applications in debug mode, a memory and performance
overhead occurs. We recommended that you use debugging when testing an
application, and disable it before deploying the application into production scenario.

8. Configure encoding settings for ASP.NET applications in the Globalization
Settings section:


To set an adopted encoding of all incoming requests, enter an encoding value
into the Request encoding field (default is utf-8).



To set an adopted encoding of all responses, enter an encoding value into the
Response encoding field (default is utf-8).



To set an encoding which must be used by default for parsing of .aspx, .asmx,
and .asax files, enter an encoding value into the File encoding field (default is
Windows-1252).



To set a culture which must be used by default for processing incoming web
requests, select an appropriate item from the Culture list.



To set a culture which must be used by default when processing searches for a
locale-dependent resource, select an appropriate item from the UI Culture list.

9. Set a code access security trust level for ASP.NET applications in the
Code Access Security field.
CAS trust level is a security zone to which applications execution is assigned,
defining what server resources the applications will have access to.
Important: When an assembly is assigned a trust level that is too low, it does not
function correctly. For more information on the permission levels, see
http://msdn.microsoft.com/library/enus/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010.

10. If you are using ASP.NET 1.1.x, then you can enable the usage of the
auxiliary scripts in the Script Library Settings field. Specifying the script
library settings is necessary if the validation web controls are used on
your web site.


If you need to use auxiliary scripts (specifically, scripts implementing objects for
validating input data), provide the settings for .NET framework script library. To
do so, enter the path beginning with the domain root directory preceded by the
forward slash into the Path to Microsoft script library field, or click the folder icon
next to the Path to Microsoft script library field and browse for the required location.



To initiate installation of files containing the scripts to the specified location,
select the Install checkbox. If the files already exist there, they will be rewritten.

11. Set client session parameters in the Session Settings field:


To set up the default authentication mode for applications, select an appropriate
item from the Authentication mode list. Windows authentication mode should be
selected if any form of IIS authentication is used.

Websites and Domains



93

To set up the allowed session idle time, enter appropriate number minutes into
the Session timeout field.

12. Click OK to apply all changes.

Configuring PHP Settings for Virtual Directories
To use web applications that require PHP4 or PHP5, you can select the required PHP
version for individual virtual directories.

 To select a PHP version for a virtual directory within a website:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories.
3. Browse to the required directory and click a link with its name.
4. In the Tools group, click PHP Settings.
5. Select the required version of PHP and click OK.
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Setting Up Access to Virtual Directories
 To set access permissions for a virtual directory within a website:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories.
3. To set access permissions for the current virtual directory, in the Tools
group, click Directory Access Permissions. If you want to set permissions for
a subdirectory located within the current directory, click the
corresponding icon .
4. Do the following:


To make the file/folder inherit permissions from a parent folder (if it does not),
select the checkbox Allow inheritable permissions from the parent to propagate to this
object and all child objects. Include these with entries explicitly defined here.



To make the files and folders, which are contained in this folder, inherit the
folder permissions you define, select the checkbox Replace permission entries on
all child objects with entries shown here that apply to child objects.



To change or remove permissions from a group or a user, click the required
name in the Group or user names list. If the group or user is not listed in the Group
or user names list, select the required user or group name from the menu located
above the list and click : the user/group appears in the list. Select it.
To allow or deny permissions to a selected group/user, select the Allow or Deny
checkboxes corresponding to permissions listed under Permissions for <user/group
name>. If the checkboxes in Allow or Deny columns are shown in grey, it means
that the corresponding permissions are inherited from a parent folder.



To deny the permissions, which are inherited from a parent object as allowed,
select the required checkboxes under Deny. This will override inherited
permissions for this file/folder.



To allow the permissions, which are inherited from a parent object as denied,
clear the Allow inheritable permissions from the parent to propagate to this object and all
child objects. Include these with entries explicitly defined here checkbox: this removes
the inherited permissions. Then select the required checkboxes under Allow and
Deny.



To remove access permissions from a group or user, select the required name
in the Group or user names list and click the icon
next to it.

5. If you need advanced fine-tuning of permissions, click the Advanced
button, and do the following:


To create a permission entry for a group or user, select the required name from
the Group or user names list and click .



To set or change file/folder permissions for a group or user, select the required
name from the Group or user names list, select the required Allow and Deny
checkboxes corresponding to permissions listed under Permissions for <user/group
name>.
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To remove a permission entry for a group or user, select the required name from
the Group or user names list and click .



To make child objects of a folder inherit its permissions defined under
Permissions for <user/group name>, select the Replace permission entries on all child
objects with entries shown here that apply to child objects checkbox, and select
checkboxes in the Apply to list which correspond to the objects that must inherit
the permissions.

6. Click OK.

 To restrict access to files and directories located within a virtual directory:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories.
3. Navigate to the directory you want to protect and click the Protection tab.
4. Click Protect.
5. To specify users who will be able to access the directory, click Add User,
specify username and password, and click OK.
6. If you want to specify a title for the protected area that will be shown to
users when they attempt to access the directory, click Settings, specify a
title, and click OK.

 To revoke a permission to access a directory from a user:
1. Go to the Websites tab and click the website's domain name.
2. Go to the Virtual Directories > Protection tab.
3. Select the checkbox corresponding to the user's name and click Remove.

 To remove protection from a directory and allow the general public to see
the directory contents without restrictions:
1. Go to the Websites tab and click the website's domain name.
2. Go to the Virtual Directories > Protection tab.
3. Click Remove Protection.
4. Click OK to confirm removal.
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Changing Virtual Directory Settings
 To change the settings of a virtual directory within a website:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories.
3. Browse to the directory whose preferences you want to change, and
click the corresponding icon , or click Directory Properties when inside
the required directory.
4. Change the settings as required:


Name - specify virtual directory name.



Path - specify the path to the physical directory to which the virtual directory is
linked.



Script source access - select this checkbox to allow users to access source code if
either Read or Write permissions are set. Source code includes scripts in ASP
applications.



Read permission - select this checkbox to allow users to read files or directories
and their associated properties.



Write permission - select this checkbox to allow users to upload files and their
associated properties to the virtual directory or to change content in a writeenabled file. Write access is allowed only if browser supports the PUT feature of
the HTTP 1.1 protocol.



Directory browsing - select this checkbox to allow users to see a hypertext listing
of the files and subdirectories in the virtual directory.



Log visits - select this checkbox if you want to store the information about visits
to the virtual directory.



Create application - select this checkbox to make the web directory an IIS
application. The directory becomes logically independent from the rest of the
website.



Execute permissions - select the appropriate program execution level allowed for
the virtual directory.





None - allow access only to static files such as HTML or image files.



Scripts only - allow running scripts only, not executables.



Scripts and Executables - remove all restrictions so that all file types can be
executed.

Allow to use parent paths - select this checkbox to allow using double period in the
path name when referring to a folder above the current directory. This enables
users to move up the folder tree without knowing the folder name or the
whereabouts in the hierarchy. If the option is selected, parent path directories
should not have the Execute permission checkbox selected in their properties, so
that applications do not have the ability of unauthorized running of programs in
the parent paths.
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Allow application execution in MTA (multi-threaded apartment) mode - select this
checkbox to allow the application execution in multi-threaded apartment (MTA)
mode. Otherwise, the application will run in a single-threaded apartment (STA)
mode. Using STA, each application pool is executed in a dedicated process.
With MTA, several concurrent application pools are executed in one thread
which can increase performance in some cases.



Use default documents - select this checkbox to allow the use of default
documents for the current directory. The default document is sent when users
access the directory on the web without a specific file name (for example, using
http://www.example.com as opposed to http://www.example.com/index.html). If
this checkbox is cleared and the Directory browsing checkbox is selected, the web
server returns a folder listing. If this checkbox is cleared and the Directory
browsing checkbox is cleared as well, the web server returns an "Access
Forbidden" error message.



Default documents search order - specifies the order in which IIS searches for the
default document, sending user the first available file it finds. If no match is
found, IIS behaves as in the cases when the default content page is disabled.



Allow anonymous access - select this checkbox if you want to make the directory
public so that the Internet users could access it without authentication.



Require SSL - select this checkbox to enable access to the folder only via SSLencrypted connections.



ASP Settings - set specific settings for ASP-based web applications.


If you are using ASP-based applications that cannot operate correctly under
data transfer restrictions set by IIS, clear the Defined by parent directory
checkbox corresponding to the field you want to change and type in the
required number.



If you want to enable debugging of ASP applications on the server side,
clear the corresponding Defined by parent directory checkbox and select the
Enable ASP server-side script debugging checkbox.



If you want to enable debugging of ASP applications on the client side, clear
the corresponding Defined by parent directory checkbox and select the Enable
ASP client-side script debugging checkbox.
Note that if you are trying to change ASP Settings for the root directory, the
default checkbox names will be Defined by IIS instead of Defined by parent
directory.

5. Click OK to save changes.
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Adding and Removing MIME Types
Multipurpose Internet Mail Exchange (MIME) types instruct a web browser or mail
application how to handle files received from a server. For example, when a web
browser requests an item on a server, it also requests the MIME type of the object.
Some MIME types, like graphics, can be displayed inside the browser. Others, such as
word processing documents, require an external application to be displayed.
When a web server delivers a web page to a client web browser, it also sends the
MIME type of the data it is sending. If there is an attached or embedded file in a
specific format, IIS also tells the client application the MIME type of the embedded or
attached file. The client application then knows how to process or display the data
being received from IIS.
IIS can only operate files of registered MIME types. These types could be defined both
on the global IIS level and on the website or virtual directory level. Globally-defined
MIME types are inherited by all websites and virtual directories while ones defined on
the website main or virtual directory level are used only for the area where they are
defined. Otherwise, if the web server receives request for a file with unregistered MIME
type, it returns the 404.3 (Not Found) error.

 To add a new MIME type for a virtual directory within a website:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories.
3. Navigate to the required virtual directory and click the corresponding
link with its name.
4. Click the MIME Types tab.
5. Click Add MIME Type.
6. Specify the following:


Type the file name extension in the Extension field. File name extension should
begin with a dot (.), or a wildcard (*) to serve all files regardless of file name
extension.



Specify the file content type in the Content field.



You can either select the appropriate value from the list or define a new content
type. To do this, select Custom and enter the content type in the input box
provided.

7. Click OK to finish the creation.

 To edit a MIME type for a virtual directory within a website:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories.
3. Navigate to the required virtual directory and click the corresponding
link with its name.
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4. Select the MIME Types tab.
5. Select the required MIME type in the list.


Type the file name extension in the Extension field. File name extension should
begin with a dot (.), or a wildcard (*) to serve all files regardless of file name
extension.



Specify the file content type in the Content field.



You can either select the appropriate value from the list or define a new content
type. To do this, select Custom and enter the content type in the input box
provided.

6. Click OK to save changes.

 To remove a MIME type for a virtual directory within a website:
1. Go to the Websites tab and click the website's domain name.
2. Click Virtual Directories.
3. Navigate to the required virtual directory and click the corresponding
link with its name.
4. Select the MIME Types tab.
5. Select the checkbox corresponding to the MIME type you want to
remove.
6. Click Remove.
7. Confirm removal and click OK.
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Setting Up IIS Application Pool (Windows)
IIS application pool contains all web applications installed on your sites. If your service
provider allocated a dedicated IIS application pool for your sites, then you can have a
level of isolation between web applications used by your sites and web applications
used by other hosting users who host their websites on the same server. Because
each application pool runs independently, errors in one application pool will not affect
the applications running in other application pools.
Once you switch on the application pool, all web applications on your websites will be
using it.

 To switch on a dedicated IIS application pool for your websites:
1. Go to the Websites tab > Dedicated IIS Application Pool for Your Websites.
2. Click Switch On.
3. To limit the amount of CPU resources that this application pool can use,
select the Switch on CPU monitoring checkbox and type a number in
percents into the Maximum CPU use (%) box.
4. Click OK.

 To stop all applications running in the application pool:
1. Go to the Websites tab > Dedicated IIS Application Pool for Your Websites.
2. Click Stop.

 To start all applications in the application pool:
1. Go to the Websites tab > Dedicated IIS Application Pool for Your Websites.
2. Click Start.
If you run applications that are known to have memory leaks or become unstable after
working for a long time, then you might need to restart them from time to time.

 To restart all applications running in the application pool:
1. Go to the Websites tab > Dedicated IIS Application Pool for Your Websites.
2. Click Recycle.

 To switch off the dedicated IIS application pool for your websites:
1. Go to the Websites tab > Dedicated IIS Application Pool for Your Websites.
2. Click Switch Off.

CHAPTER 4

Creating Websites with Parallels
Presence Builder
Parallels Presence Builder (also referred to as editor) is a visual editor that lets small
business owners and individuals create their websites quickly and easily. With
Presence Builder, you do not have to write code or configure servers to start a blog,
open an online store, or set up any other form of website. You just add the content
blocks that comprise your site (text, image gallery, online store) by dragging them to
pages, fill these blocks with your content, and publish the result. That’s it!

Start Creating a Website
When you start working on your website, you do not have to write text, search for the
images, and adjust the site look. Just choose a topic that best suits your website, and
Presence Builder will generate a site template that already contains a set of pages,
pictures, and text relevant to the selected topic. Each time Presence Builder generates
a website, it uses a random set of element designs, so you can be sure that your
website design is never repeated.
Once you have selected the topic, you will be prompted to enter some additional
information that Presence Builder will add to the website's pages, for example, your
phone number, which will appear on the Contact Us page.
For more details on how to start creating your website, see the section Creating a
Website (on page 105).

Import Websites Created in SiteBuilder 4.5
If you already have a website created with SiteBuilder 4.5 and hosted elsewhere, you
can import your website to your new customer account. Learn how to move your
SiteBuilder 4.5 website to Presence Builder in the section Importing Sites from SiteBuilder
4.5 (on page 106).

Fill the Site with Content
As soon as Presence Builder creates your website, you can fill it with your content.
Your main editing tool is the Presence Builder's main menu. You can do the following
by using the menu:


Change the structure of your site: Add or remove pages.



Edit the website design: Change colors and layout.



Fill the site with your content: Remove unused predefined content and add your
own elements:
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Text



Images and image galleries



Videos



Scripts



Blogs



Search boxes



Other elements

Let your visitors share the information in your website in social media such as
Facebook or Twitter: Add the corresponding buttons to the pages of your site.

To learn more about the actions available to you in the editor, refer to the section
Getting Familiar With the Presence Builder Editor (on page 103).
Find instructions on managing website look and content in the section Editing Websites
(on page 107).

Make the Site Available on the Internet
After you finish editing the website, make it available on the Internet. To let people see
your site at your domain name, publish the website by clicking the corresponding
button in the main menu. When you click this link, Presence Builder generates the
static pages and scripts that comprise your website and places them in the appropriate
locations on the server so that people see them when they enter your domain name in
their browsers. Learn more about publishing websites in the section Publishing a Website
to the Internet (on page 148).
You can also attract more visitors to your sites by placing a site copy on Facebook - a
popular social network. Refer to the section Publishing a Website Copy to Facebook (on
page 149) for detailed instructions on how to do this.

In this chapter:
Getting Familiar With Presence Builder ............................................................. 103
Creating a Website ............................................................................................ 105
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Publishing a Website Copy to Facebook ........................................................... 149
Viewing Site Visits Statistics, Comments, and New Orders on the Dashboard .. 151
Deleting Websites ............................................................................................. 153
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Getting Familiar With Presence Builder
The interface of the Presence Builder editor has two main parts: your website and the main
menu.
A website consists of a number of elements, or modules. Each module can be edited
separately. Here we will familiarize you with the basic principles of website module editing.
These are similar for all modules.
When adding a module to a page, you can choose whether it should be shown only on the
current page (page-specific module) or on all pages of the site (site-wide module). The only
exceptions are the Search, Advertisement, Site Logo, Navigation, and Breadcrumbs modules:
when you add them, they are placed on all pages of the website.
To place a module only on the current page, select the module under the Modules tab, and
drag it to any of the areas marked with the text ONLY ON THIS PAGE. Such areas are located
within the main content block and near the top of each sidebar.
To place a module on all pages of the website, select the module under the Modules tab, and
drag it to any of the areas marked with the text ON ALL PAGES. Such areas are located above
and below the main content block, in sidebars, header, and footer.
To locate or edit a website module, hover the mouse pointer over the part of the website you
want to change. A dotted frame will appear around the module. A control panel prompting
you to move, edit, or remove the module will appear next to the dotted frame.
The dotted frame around page-specific modules is green, but around site-wide modules it is
blue.
The editor's main menu offers website editing options grouped under five tabs:


Modules. Here you can choose necessary modules and drag them to any place on the
page to fill your website with content.



Design. Here you can select the layout and general color scheme for your website,
change colors of different elements, and select fonts and border style.



Pages. Here you can add and delete pages, rename them, edit page meta information
such as descriptions and keywords for use by search engines, or mark a page as hidden
so that your visitors cannot access it from the site menu.



Documents. Here you can upload documents, images, and other files in various formats to
your hosting account. You can then easily insert links to these documents into your
website pages. Or, you can just keep the files on the hosting account for your own needs.



Settings. Here you can edit your website name, description and keywords for search
engines, upload a site icon (favicon), optimize the ranking of your website in search
engine results, connect your site to Google Analytics, and add a copy of your site to a
Facebook page.

From the main menu, you can also do the following:


Access the Dashboard to perform the following operations:


View statistics on website visits. The statistics are provided by Google Analytics.
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View new comments left by site visitors on your website pages. The commenting
functionality is provided by Disqus.



View new orders from customers visiting your online stores. The online store
functionality is provided by Ecwid.



Save and load copies of your website by using the Save and Revert options.



Access Presence Builder Getting Started video tutorial, view User’s Guide, or send us your
feedback. To do this, select the corresponding option from the Help menu.



Publish your website by using the Publish button.



Discard any changes made to a site and start creating the site anew by selecting More >
Start Over. This does not delete your already published site copy.



Delete a current website draft from the editor by selecting More > Remove Site. This does
not delete your already published site copy.

You can drag the main menu to any place on the page for your convenience, or minimize it.
You can also access all options of the main menu in the context menu at any place on the
page. To open the context menu, click the right mouse button.
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Creating a Website
To minimize your efforts when creating a website, Presence Builder offers you a set of
predefined website topics. When you start creating a website, choose a topic that is most
appropriate for you, and Presence Builder will generate a website with the content relevant to
this topic. For example, it will include a price list template for a retail store or an image gallery
for an artist's site.
When you start creating a website, Presence Builder also prompts you to provide information
about yourself or your company. Presence Builder will automatically add this information to
certain pages as appropriate, for example, to the About Us and Contact Us pages.
Note: Presence Builder will not store or use the information you provide anywhere except for
your website pages. You can change or remove this information later.

 To start creating a website in Presence Builder:
1. Go to the Websites tab and click the desired domain name.
2. Click Launch Presence Builder.
3. Select a website topic.
4. Type the website name and select website language.
5. Provide the information to pre-fill your website.
6. Click Create Site.
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Importing Sites from SiteBuilder 4.5
If you have a site created with SiteBuilder 4.5, you can import it to Presence Builder.
Note: The import of sites from earlier versions of SiteBuilder or other content management
systems is not supported.
If your site was created with an earlier version of SiteBuilder (4.4 or earlier), and you would
like to transfer your site, you can do the following:


Contact your hosting provider and ask them to upgrade your account to the latest version
of Presence Builder.



Transfer your site manually by copying and pasting the content.

During site import, most parts of the site structure and content can be transferred
successfully. However, we cannot guarantee that all content will be transferred.
In most cases, the following elements are imported successfully:


Site map.



Static pages, including links and images in text modules. Note that text blocks exceeding
30 kilobytes may be cut; therefore, some parts of the text may be missing.



Banner (if it is not a custom image).



Slogan, site title.



Logo (if it is not a custom image).




Footer text.
Meta info (keywords, description).

The other modules can be imported only as text widgets with static content, links and
images. Buttons will not work. The image gallery structure can be imported without images.

 To import a site from SiteBuilder 4.5:
1. Open the Presence Builder editor, and on the topic selection screen, c lick
Import Site from SiteBuilder 4.5.
2. Type the Internet address (domain name) of the site that you want to import.
For example: http://example.com.
3. Select the checkbox to confirm that you are aware of possible import issues,
and click Import Site.
4. After the site is imported, review and edit it as required. You can compare
the imported site version with your original site and add the missing
information manually.
5. When finished with editing, publish the site to your hosting account.
If you are publishing your new site to the same webspace on which your site created with
SiteBuilder 4.5 was hosted, the old site will be overwritten.
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Editing Websites
In Presence Builder, you can change almost any element of your website. Most of the
elements are changed in place - you open a page where the element is used, edit it and see
the result right away. Site-wide elements, such as Search block and Advertisement block are
changed in one place but the changes are applied to each page of your website.
Note: If you are using Internet Explorer, we strongly recommend that you avoid using
browser zoom to change the size of text displayed in your browser window. Please note that
websites in Presence Builder will perform and look best at normal zoom (100%).

Next in this section:
Structure: Pages and Navigation ....................................................................... 107
Design: Design Templates, Layout, Styles, Color Scheme, and Header ............ 110
Content: Text, Tables, Images, Video, Forms, and Scripts ................................ 118
Settings and Tools for Webmasters ................................................................... 141

Structure: Pages and Navigation
This section describes how to add pages to a site, set their location in the site structure, and
add navigation links.

Next in this section:
Adding and Removing Pages ............................................................................ 108
Adding and Removing Navigation Links ............................................................ 109
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Adding and Removing Pages
Your site can have two levels of nested pages. The total number of pages you can create
depends on your hosting plan. The editor will let you know when you have reached the
allotted number of pages: an icon with the dollar sign ($) will be shown over the Add page
button.
Note: For Presence Builder performance reasons, the total number of pages for a website
cannot be more than 500.

 To add a new page to your website:
1. Go to the Pages tab.
2. Click Add page. The new page appears highlighted in green.
3. Position the new page by dragging it to the right place or by clicking the
arrows.
4. Specify the page title.
5. Give a concise description of the page content that will be displayed on
search engine results pages and the keywords by which the page will be
found by search engines.
Note: Page name and Page link name are required fields. Description and Keywords are
optional fields. If you specify keywords for a page, they should be separated by commas
without white spaces.

6. If you want to make the page invisible to your website visitors, select the
Hidden page checkbox.
7. If you want to restrict access to the page with password authentication,
select the Protected page checkbox and specify a username and a password.
8. Click OK to save changes.

 To change the location or properties of a page:
1. Go to the Pages tab.
2. Select the page you want to edit.
3. Change the page position by dragging it to the right place or by clicking the
arrows.
4. Edit the page title.
5. Edit or remove the concise description of the page content that will be
displayed on search engine results pages and the keywords by which the
page will be found by search engines.
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Note: Page name and Page link name are required fields. Description and Keywords are
optional fields. If you specify keywords for a page, they should be separated by commas
without white spaces.

6. If you want to make the page invisible to your website visitors, select the
Hidden page checkbox.
7. If you want to restrict access to the page with password authentication,
select the Protected page checkbox and specify a username and a password.
8. Click OK to save changes.

 To delete a page from your website:
1. Go to the Pages tab.
2. Select the page you want to delete.
3. Click Delete page.
4. Click OK to save changes.

Adding and Removing Navigation Links
By default, a horizontal navigation bar with links to site pages is inserted below or above the
header of your site. It is automatically updated every time you add, change, move, or remove
pages from the site.
If you use sidebars on the site, then the horizontal bar under the header includes only links to
the first level pages, and the sidebars show the links of the second and third levels.
You can move navigation blocks by dragging them to other areas of the site.
For each navigation block, you can specify what levels of pages should be included in the
menu, change menu alignment (for example, show it in the middle of the page instead of the
default alignment to the left), and change the color, style, and size of the font used for the
links. To change any of these settings, place the mouse pointer over a navigation block and
click Edit.
If you occasionally remove a navigation block, you can re-insert it. To do this, go to the
Modules tab, select Navigation, and drag the block to the area on the page where you want to
add it. The navigation block will be inserted into all pages of the website.
For the convenience of your site visitors, you might also want to add breadcrumb navigation
blocks. Breadcrumb navigation is a chain of links that represents the user's path from the
site's main page to a current page. To add a breadcrumb navigation block, go to the Modules
tab, select Breadcrumbs, and drag the module to the area on the page where you want to add
it. The navigation block will be inserted into all pages of the website.
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Design: Design Templates, Layout, Styles, Color Scheme,
and Header
This section describes how to change the layout, color scheme, and header elements of the
site.

Next in this section:
Selecting a Website Design Template ............................................................... 111
Changing Your Website Layout ......................................................................... 113
Selecting Website Colors, Background Images, Fonts, and Styles for Borders and Corners
Changing the Website Header Elements ........................................................... 117

115
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Selecting a Website Design Template
When a new website is generated, the editor applies a random design template to the site. A
design template is a combination of website elements (banner, footer, sidebars), page layout
settings, and colors.
The editor provides a selection of 24 design templates, 16 of which are randomly generated,
and 8, created by graphic designers especially for Presence Builder.
You can review the list of design templates and select the design you like the most, or you
can individually adjust the layout and colors of website elements, as described further in this
document.
You can also prepare your own design templates and save them to ZIP archives, upload
them to the editor, and apply to websites.

Selecting and Applying a Design Template
Note: When you apply a design template, all site-wide elements and modules are overwritten
along with the content they might contain.

 To select a design template and apply it to a site:
Go to the Design tab > Templates, select the template you want, and click OK.
Randomly generated designs are listed in the Generated section, and the templates prepared
by designers, in the Special section.

Preparing a Custom Design Template
The following site elements and settings can be saved in a design template:



The website layout: the location and size of the header, footer, content areas, and
sidebars.
The banner image.



All site-wide modules.



The color scheme or individually selected colors.



The fonts.



The information about the borders and shapes of the page elements' corners.

 To create a custom design template:
1. Adjust the layout and design, as described in Changing Your Website Layout (on
page 113) and Selecting Website Colors, Fonts, and Styles for Borders and Corners (on
page 115).
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2. Add the necessary site-wide modules and a banner, as described in the
chapter Content: Text, Tables, Images, Video, Forms, and Scripts (on page
118), and in the section Changing the Website Header Elements (on page
117).
3. Save the design template: Go to the Design tab, and click Export Design.

Importing and Applying a Custom Design Template
Note: When you import and apply a design template, all site-wide elements and modules
contained on the site are overwritten along with the content they might contain.

 To upload and apply a design template:
1. Go to the Design tab, and click Import Design.
2. Select the ZIP archive containing the design template.
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Changing Your Website Layout
The layout of your site can consist of the following elements:










Header. This is the topmost area where a banner image and a company logo are usually
placed. You can do the following to the header:


Move the banner image and logo from the header area to any place on the page.



Reduce the header height to 25 pixels by removing all elements from it.



Change the header width from the default size to 100 percent, so that it is expanded
to fit the page width.

Content area. This is the main part of a webpage where most of the content is placed. You
can do the following to the content area:


Adjust the height of the content area.



Divide the content area into several columns. You can do this by dragging new
modules to the left or right edge of the content area and inserting them.



Change location of the columns in the content area by moving the content to the left
or to the right.

Sidebars. These are vertical columns that can be used for placing all kinds of modules,
site-wide and page-specific. You can do the following to sidebars:


Add one sidebar and place it to the left or to the right of the content area.



Add two sidebars. They will be placed to the left and to the right of the content area.



Adjust the height and width of the sidebars.



Move the sidebars to the top of the page and place them to the left or to the right of
the header area.



Switch places of the sidebars.

Footer. This is the lowest area where the company name, contact information, or a
copyright notice are usually placed. You can do the following to the footer:


Reduce the footer height to 25 pixels by removing all elements from it.



Change the footer width from the default size to 100 percent, so that it is expanded to
fit the page width.

Advertisement block below the footer. Depending on your hosting plan, an additional text
block containing some advertisement from your hosting provider might appear below the
website footer. If that advertisement block appears on your site, you might want to
upgrade to another hosting plan to remove it.

 To change the layout of your site:
1. Go to the Design tab > Layout tab.
2. Select the number of sidebars: Under Sidebars, select No, One, or Two.
3. Select the locations of sidebars:


To move a sidebar to another side of your website, or to switch places of sidebars (if
you have two sidebars on your site), click Switch sidebars.



To move the sidebars to the top of the page, click them in the layout model.
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4. Set the size of page elements:


To set the total width of the website pages, under Website width, select either of the
following:


Fixed layout: your website will be of a specific size regardless of the size of the
browser window viewing the page. In this case, specify your website width in
pixels.



Liquid layout: based on percentages of the current browser window's size. In this
case, specify your website width as a percentage of the browser window's size.



To change the width of the header, footer, and the main content area to fit the page
width, click the corresponding elements in the layout model.



Under Minimal column height in pixels, specify the height of the main content area and
each sidebar, if you have chosen to use them.
This value shows the height of your website elements without content. When you add
content to the main content area and to the sidebars, they will stretch in height to fit
the content.



To ensure that the sidebars and the content area are vertically aligned, select the
checkbox Stretch the sidebars and the content area down to the footer.



If you use one or two sidebars, under Sidebar width in pixels, specify the width of each
sidebar. The size of the main content area will be determined automatically.



Under Margin sizes in pixels, specify the size of vertical and horizontal margins. A
margin is the space between the edges of neighboring elements.

5. Click OK to save changes.
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Selecting Website Colors, Background Images, Fonts, and Styles for
Borders and Corners
The general color scheme, or styleset, of your website comprises four colors. Each color is
used for several website elements at once. You can adjust colors of individual elements on
the Design tab > Colors tab.

 To select the general color scheme for your website:
1. Go to the Design tab > Scheme tab.
2. Select the color scheme, or styleset, of your website in the menu.
You will see the four colors used in the color scheme of your website.

3. To adjust one of the colors of your website color scheme, click the respective
color field and change the hexadecimal color code value or select a color
with the color picker.
Note: These changes will override any previous changes of individual elements' colors
made on the Colors tab.

4. Click OK to save changes.

 To set colors or background images for individual website elements:
1. Go to the Design tab > Colors tab.
2. Select the website element in the Page area menu.
3. Click the arrow in the Color or image menu.
4. Do any of the following:


To fill with a solid color, leave the Solid color option selected, and select a color with
the color picker.



To fill with a gradient, select the Gradient option, and then select a pattern from the
library.



To fill with a background image, select the Image option, select a pattern from the
library or click Upload to upload your own image. Specify where it should be placed
and whether it should be tiled.

5. For an element with text, adjust font colors by clicking the respective color
field and editing the hexadecimal color code value or by selecting a color
with the color picker.
Note: Modifying the styleset on the Scheme tab will override the changes made on the
Color tab.

6. Click OK to save changes.

 To select fonts for headings and body text of your website:
1. Go to the Design tab > Fonts tab.

116

Creating Websites with Parallels Presence Builder

2. For each font type, select the font face and size in the menus.
3. For headings, select the font decoration. You can use bold (the B icon) and
italics (the I icon).
Note: The settings made here define only general rules for your website fonts. You can
always adjust fonts of individual elements in place.

4. Click OK to save changes.

 To select the shape of corners (square or rounded) for website elements:
1. Go to the Design tab > Corners tab.
2. In the Page area menu, select the element whose corners you want to change.
3. Do any of the following:


To make rounded corners, select the corresponding checkboxes.



To make square corners, clear the corresponding checkboxes.

4. Click OK to save changes.

 To select borders for website elements:
1. Go to the Design tab > Borders tab.
2. Select the border type for elements inside your website from the Internal
containers border menu.
3. Select the elements that will have the border.
Note: You can select only one internal border type for all elements on your website, but
you can select whether this border will be used for certain elements.

4. Select the external border for your website from the External site border menu.
5. Click OK to save changes.
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Changing the Website Header Elements
The site header consists of the following elements:


Banner. You can do the following to the banner:


Upload your own banner image or a Flash file in SWF format.



Select and apply a banner from the Presence Builder library.



Remove the banner and use a background filled with a color or images.



Remove the banner and all other elements from the header area to reduce its height
to 25 pixels.



Move the banner to the content area and insert it into a specific page or into all pages
of the website.
Note: You can use only one banner per site. If you choose to insert it into a specific
page, you will not be able to add it to other pages of the website. For this reason,
we recommend that you place it into the site-wide areas.






Logo image. You can do the following to the logo:


Upload your own logo image or a Flash file in SWF format.



Move the logo from the header area to other parts of webpages, such as sidebars and
content area.



Insert any number of logo images into the site-wide areas.



Resize the logo by specifying the desired dimensions in pixels, or by dragging the
sides and corners of the image with a mouse pointer.



Remove the logo.

Site name. This usually contains a company name or a brief site description like, for
example, "John Doe's Recipes".
Site slogan. This usually includes a description of your site or a company slogan.

 To change the banner image or other elements of the header (logo, site name,
or slogan):
1. Click the banner image.
2. Select the option Use an image, and then click the image in the Image list menu.
3. Do any of the following:


To use an image from the library, select it. To find relevant images, type a keyword
into the input box.



To use your own image or a Flash file in the SWF format, click Upload, and select the
file that you want to use. Images should be in the GIF, JPEG, and PNG formats,
preferably not wider than 900 pixels.

4. If you want to scale a banner to fit the header area, select the Fit image size
checkbox.
5. Under Show banner elements, select the checkboxes corresponding to the
elements that you want to show in the header.
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6. If you want to remove a logo image or upload your own logo, click the logo
image.
7. If you want to change the site name or slogan, click the corresponding fields
on the header and change them as you want.
To make it easier to see the site name or slogan, select the Outline checkbox. This adds a
black or white outline around text, one pixel in width. If the font color in site title or slogan
is black, then the outline is white, and vice versa.
Note that you can freely move the blocks with website name, description, and logo within
the header area.
If you occasionally remove the banner, you can re-insert it.

 To remove the banner:
Click the banner, select.the option Do not use an image, and specify the height of the header
block in pixels. Click OK.

 To insert a banner:
Go to the Modules tab, select Banner, and drag the module to any of the site-wide areas on the
page where you want to add it.

 To insert a logo:
Go to the Modules tab, select Site Logo, and drag the module to any of the site-wide areas on
the page where you want to add it. You can upload a new logo image or a Flash file in the
SWF format, and align it to the left, center, or right.
You can also resize the logo image by specifying the desired dimensions in pixels, or by
dragging the sides and corners of the image with a mouse pointer.
Note: When you resize the image with a mouse pointer, the option to keep the original aspect
ratio is switched off automatically.

Content: Text, Tables, Images, Video, Forms, and Scripts
This section describes how to fill your site with content and enhance it with useful functions
provided by the editor's modules.
When adding a module to a page, you can choose whether it should be shown only on the
current page (page-specific module) or on all pages of the site (site-wide module). The only
exceptions are the Search, Advertisement, Site Logo, Navigation, and Breadcrumbs modules:
when you add them, they are placed on all pages of the website.


To place a module only on the current page, select the module under the Modules tab,
and drag it to any of the areas marked with the text ONLY ON THIS PAGE. Such areas are
located within the main content block and near the top of each sidebar.
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To divide the content area into columns and insert a module into one of them, drag the
module to the left or right edge of the content area and then insert it. Note that sidebar
areas cannot be divided into columns.


To place a module on all pages of the website, select the module under the Modules tab,
and drag it to any of the areas marked with the text ON ALL PAGES. Such areas are
located above and below the main content block, in sidebars, header, and footer.

The number of modules that you can add to a website depends on your hosting plan. The
editor will let you know when you have used the allotted number of modules: icons with the
dollar sign ($) will be shown over the module icons in the editor's toolbar.

Next in this section:
Text, Tables, Hyperlinks, Flash Files, and Images............................................. 120
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Text, Tables, Hyperlinks, Flash Files, and Images
Before you start working on website content, we suggest that you select the appropriate
website language in Settings tab > Languages > Website language menu.
The website language is a site-wide setting that defines the language in which you will be
adding content to your website. It affects the following:


The language in which certain website elements (in particular those provided by thirdparty services), such as Google Search and navigation buttons in image galleries, will be
shown. Note that not all third-party services and modules provided by the editor support
all available languages.



The direction in which you will type text in the editor (from left to right or from right to left).
If you select a right-to-left language, your website content and design will be RTLenabled.

Note: Changing a website language does not reload the currently selected website topic in a
different language. The topic language will remain unchanged, however, the text orientation
will change.

 To add text, lists, tables, or images to a page:
1. Go to the Modules tab, select Text & Images, and drag the module to the page:


To add a block with text and images to the current page, drag the module to any of
the areas marked with the text ONLY ON THIS PAGE. Such areas are located within the
main content block and near the top of each sidebar.
To divide the content area into columns and insert a block into one of them, drag the
module to the left or right edge of the content area and then insert it. Note that sidebar
areas cannot be divided into columns.



To add a block with text and images to all pages of the site, drag the module to any of
the areas marked with the text ON ALL PAGES. Such areas are located above and
below the main content block, in sidebars, header, and footer.

2. Type the text on the screen and use the icons on the module's toolbar to
format the text, add tables, hyperlinks, and images.
The toolbar of the Text & Images module provides access to the following tools and functions.
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1. Move the text and image block within the webpage.
2. Remove the block with its contents.
3. Save changes.
4. Cancel the changes made.
5. Move the toolbar.
6. Select the paragraph style and font face. Note that the Terminal font is not supported by
Google Chrome.
7. Select the font size.
8. Select the font style: bold, italics, underlined, and strikethrough.
9. Select the text and background colors.
10. Select text alignment: left, center, right, or justified (aligned to both the left and right
margins with added extra spaces between words).
11. Increase and decrease the indent level of the paragraph.
12. Start a numbered or bulleted list.
13. Insert a table and specify the number of rows and columns.
After you insert a table, a number of additional icons become accessible from the toolbar.
Use them to change the properties of the table rows and cells, to insert and remove rows
and columns, or to split and merge table cells.
14. Insert symbols that are not on your keyboard, such as copyright and trade mark signs,
and other Unicode symbols.
15. Insert a horizontal line.
16. Edit the HTML source code of the page.
17. Undo and redo changes.
18. Insert a Flash object in the SWF format.
19. Insert an image, adjust its size, specify a description, and text wrapping.
You can choose to show the description below the image, show it over the image only
when users hover the mouse pointer over it, or to not show it. The description also serves
as alternative text: In browsers that do not support or are configured to not show images,
the description will be shown instead.
If you want to insert many pictures into a single page, consider using the Image Gallery
module instead of the Text & Images module. With Image Gallery, you can upload pictures
from your local computer or use pictures published to the Picasa Web Albums photo
sharing service. To learn more about the Image Gallery module, see the section Image
Gallery (on page 125).
If you want to add a slide show with multiple images, use the Image Slider module. To
learn more about the Image Slider module, see the section Image Slider (on page 127).
20. Insert HTML anchors into particular sections of webpages so that you can link to them
from the same or other pages of your site.
21. Remove hyperlinks from selected text.
22. Add hyperlinks to pages of your website or external resources.
23. Add a link to an email address.
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To learn more about adding hyperlinks, see the section Hyperlinks, Links to Email Addresses,
and Anchors (on page 123).

Next in this section:
Hyperlinks, Links to Email Addresses, and Anchors .......................................... 123
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Hyperlinks, Links to Email Addresses, and Anchors
Creating Links to Other Pages
 To insert a hyperlink into text:
1. Select the text that you want to make a link.
2. On the toolbar of the Text & Images module, click the icon

.

3. Do any of the following:


To add a link to another webpage on your site, select the option A page of this site. In
the Select page menu, select the target webpage or a webpage section where you have
placed an anchor.



To add a link to a webpage or a file located on another site, select the option A
webpage or file on the Internet, and type the address. For example,
http://example.com.



To add a link to a document or another downloadable file that you have previously
uploaded through the Document Manager (as described in Documents and Other
Downloadable Files (on page 135)), select the option A document on this site, and select
the target file.

4. In the Open link in menu, select where you want to open the target page. You
can choose to open it in the same or in a new browser window or tab.
5. In the Title box, type the description that should appear when users place the
mouse pointer over the link.
6. Click OK.

Creating Links to Different Sections of a Webpage
If you have a lengthy webpage consisting of several sections, consider inserting a table of
contents with links to these sections in the top of the page, to help your site visitors navigate
through the page content. You can do this with the help of so-called anchors.

 To add links to different sections within a webpage:
1. Insert an anchor in the beginning of each section.
a. In the text block, highlight with the mouse pointer a section heading
or, if there is no heading, a first letter at the beginning of a
paragraph.
b. On the Text & Images module's toolbar, click the icon

.

c. Specify a name for the anchor and click OK.
Anchor names should begin with a Latin alphabet letter. They can contain Latin
alphabet letters, underscore, and numbers. For example: section_1.
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d. Repeat these steps to add as many anchors as needed.
2. Insert a table of contents or a list of sections in the top of the page.
3. Add hyperlinks to the table of contents or the list of sections.
a. Highlight with the mouse pointer a section name.
b. On the Text & Images module's toolbar, click the icon

.

c. Leave the option Link to a page of this site selected.
d. In the Select page menu, select the required anchor name.
e. Click OK.
f. Repeat these steps to add hyperlinks to all the sections you need.

Creating Links to Email Addresses
 To insert a link to an email address into text:
1. Select the text that you want to make a link.
2. On the toolbar of the Text & Images module, click the icon

.

3. Specify the email address and click OK.

If you want to specify multiple email recipients or predefine the message subject, use the
following alternative method:

1. Select the text that you want to make a link.
2. On the toolbar of the Text & Images module, click the icon

.

3. Select the option A webpage or file on the Internet, and type
mailto:<address>. For example, mailto:postmaster@example.com.
You can also:


Specify multiple recipients in the To field, separating addresses with a comma (,)
or a semicolon (;). For example:
mailto:postmaster@example.com,mail@example.com.

Note: It is better to separate addresses with a semicolon because users of Microsoft
Office Outlook might experience issues with sending email to recipient addresses
separated with commas. Microsoft Office Outlook 2003 and later versions do not
recognize a comma as an email address separator, unless they are specifically
configured to do so. For details, see the article at
http://support.microsoft.com/kb/820868.


Predefine the message subject line. For example:
mailto:postmaster@example.com?subject=My%20Subject.
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Add recipients to CC and BCC lists. For example:
mailto:postmaster@example.com?subject=My%20Subject&cc=addres
s1@example.com&bcc=address2@example.com.



Predefine text to put in the message body. For example:
mailto:postmaster@example.com?subject=My%20Subject&body=This
%20is%20sent%20from%20your%20site!

Note: You should replace white spaces with %20.

4. Click OK.

Image Gallery
 To add an image gallery to your site and upload pictures:
1. Go to the Modules tab, select Image Gallery, and drag the module to the page.
2. In module settings, on the Image Storage tab, select where you want to keep
pictures:


If you do not have a Picasa Web Albums account that you would like to use, leave the
Presence Builder option selected. All images you use on your site will be kept on your
customer account.



If you have an account in Picasa Web Albums and want to use pictures that you store
there on your site, do the following:

a. Select the Picasa option, click the link on the Image Storage tab to sign
in to Google, and grant access to your albums from Presence
Builder.
b. Select the album whose pictures you want to use or click Create Album
to create a new album.
c. If you want Presence Builder to remove images from Picasa Web
Albums when you remove them from the gallery, select the checkbox
Delete images when I remove them from gallery.
When you upload images to an image gallery through the Presence Builder editor,
they are automatically copied to your Picasa Web Albums account. When you remove
images from the gallery, they are removed from Picasa Web Albums only if you have
selected the option Delete images when I remove them from gallery.

3. (Optional steps.) If you want to select the size of image thumbnails to be
shown in the image gallery, change the gallery alignment (place it to the left,
in the center, or to the right), or adjust the number of images to be displayed
per page, click the Gallery Properties tab and make the desired changes.
The following thumbnail sizes are available:


Small (95 x 75 pixels).



Normal (140 x 130 pixels). This is the default setting.



Large (170 x 170 pixels).
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4. To add images to the gallery, on the Image Storage tab, click the text Click here
to upload your images, select the images that you want to upload, and click OK.
You can select and upload multiple images at once. Only images in GIF, JPEG, and PNG
formats are supported.
We recommend that you use resized images that do not exceed 1024 x 768 pixels.

5. To change image title and description, click the corresponding thumbnail,
click the title or description, and edit the text.
If you delete the default text entirely, it will not be shown on your published site; however,
it will still be shown when you edit the site in the Presence Builder editor.

6. To rearrange images in the gallery, drag them to the desired location.

 To remove an image from the gallery:
Place the mouse pointer over the image thumbnail and click the icon [x].

 To remove an image gallery with all pictures:
Place the mouse pointer over the image gallery block and click Remove.
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Image Slider
The Image Slider module enables you to add a slide show with multiple images and various
transition effects. The following image formats are supported: GIF, JPEG, and PNG.
Images are not resized automatically; for this reason, we recommend that you upload images
of the same dimensions. Otherwise, the slide show will not look good.
When adding images, you can add descriptions to them and link the images to specific
pages of your website.
The following transition effects are supported:


Random



Slice down and to the right



Slice down and to the left



Slice up and to the right



Slice up and to the left




Slice up and down
Slice up and down and to the left



Fold



Fade




Box random
Box rain



Reverse box rain



Growing box rain



Reverse growing box rain

The effect names might tell you little about how the effects look, so it is better to see them in
action. To do this, add the Image Slider module, upload at least two images, go to the
module settings (Settings tab), and select an effect from the Transition effect menu.

 To add Image Slider to your site and upload pictures:
1. Go to the Modules tab, select Image Slider, and drag the module to the page.
2. Click Add Images, select the images that you want to upload, and click OK.
You can select and upload multiple images at once. We recommend that you use resized
images that do not exceed 1024 x 768 pixels.
Once you have uploaded images, you can arrange them in the desired order, and remove
them. To do any of these actions, place the mouse pointer over an image thumbnail, and
use the corresponding icons:

.

3. To add an image description, select a thumbnail, and type the text into the
Description box.
4. To add a link to a webpage, select a thumbnail, select the option Link to a
webpage, and select the page from the menu below.
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5. Click the Settings tab and select the desired transition effect from the Transition
effect menu.
6. Specify how long each image must be shown.
7. Specify whether the round navigation icons for switching between slides
must be shown.
The option Inside will show the icons over the images, in the upper right corner of Image
Slider, and Below will show the icons below the images.

8. Specify whether the navigation arrows for switching between slides must be
shown.
9. Click OK.

 To remove an image from the slide show:
Click on the slide show block, place the mouse pointer over the image thumbnail, and click
the icon

.

 To remove a slide show with all pictures:
Place the mouse pointer over the slide show block and click Remove.
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Embedded Video
You can embed into website pages video clips located on popular video sharing sites, such
as YouTube (youtube.com), Vimeo (vimeo.com), MySpace (myspace.com), and Dailymotion
(dailymotion.com).

 To insert a video into a webpage:
1. Go to the Modules tab, select Embedded Video, and drag the module to the
page.
2. Insert a link to the video or select the option Embed code if you have obtained
a code from a file sharing site, and then paste the code.
3. Click OK.

 To remove a video:
Place the mouse pointer over the video and click Remove.

Contact Form
If you want your site visitors to be able to send you messages from your site, you can add a
contact form.

 To add a contact form:
1. Go to the Modules tab, select Contact Form, and drag the module to the page.
2. On the Settings tab, specify the following:


Recipient's email address. You can specify several email addresses separating them
with commas (,) or semicolons (;).



Message subject.



Text to be shown on the button that sends the message.



Protection from automated spam postings. Leave the checkbox Enable the protection
from automated spam postings selected if you want to avoid receiving spam sent by
scripts or spam bots through the contact form.
The protection is based on a highly efficient mechanism, called reCAPTCHA. In the
contact form, it is shown as an input box accompanied by a combination of distorted
words or symbols that can be recognized only by humans. Before a message can be
sent through the contact form, a user is prompted to recognize the symbols and type
them in.

3. If you want to add, move, or remove input fields from the form, or change
their labels, click the Fields tab, and make the required changes.
4. If you want to change the default message "Your message was sent. Thank
you." which is shown when a message is sent, click the Reply tab and type
the new text.
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5. Click OK.

 To remove a contact form:
Place the mouse pointer over the form and click Remove.

Blog
If you want to maintain an online diary on your site, or regularly publish articles on a subject
and automatically present them in a chronological order, then you need a blog.
A blog module can be added only to the first-level pages that do not have subpages. Within
blog posts, you can use text, images, embedded videos and scripts. Each blog post can
have its distinctive page description and meta information to be used by search engines.
Note that blog posts are not listed on the Pages tab (on page 108).
To let your visitors comment on your blog posts, you need to register with Disqus, a free
third-party service that provides commenting functions for your sites and keeps all
comments.

 To add a blog to your webpage:
1. Go to the Modules tab, select Blog, and drag the module to the page.
2. In the module properties, specify the following:


Number of blog posts to show on the page.



Specify whether the site visitors will be able to leave their comments.

3. Click OK.
4. To enable commenting, click the link Click here to add a new blog post.
5. Click within the gray information box at the bottom of the blank blog post.
6. To register with Disqus, click the Register button. A registration form will open
in a new browser window or tab.
7. Specify the following:


Your site's URL, desired name and shortname (unique ID). You will need to specify
this site ID (shortname) later in the Blog module settings to enable commenting.



Comment moderator's username, password, and email address. A confirmation
message will be sent to this email address, so be sure that it is valid.

8. Click Continue.
9. Specify your language and other settings, and click Continue.
10. On the last step of the registration form, no further action is required. Just
log out of the Disqus site.
11. Check your email inbox for the confirmation message from Disqus. In this
message, click the link to verify your address.
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12. Return to the browser window where you have the Presence Builder editor
with the Blog module properties opened.
13. In the box titled Apply here the website ID (shortname) received during registration, type
or paste the site ID that you specified during registration with Disqus in step
7.
14. Click Apply.
15. Click OK.
Now your blog can accept comments from visitors, and you can make the first post.

 To add a blog post:
1. Go to the website page containing a blog module.
2. Click the link Click here to add a new blog post (might also appear as New Post
Title).
3. Type the post title and content.
If you want to change the date of posting, click within the field Posted dd.mm.yy and then
select a date from the calendar.
If your post is lengthy and contains numerous text blocks, images, and embedded videos,
you might want to show only a portion (beginning of the post) to site visitors in your blog's
main page. To do this, while editing a blog post, move the divider element (containing the
line -------- Drag this above modules that should not appear in the list of posts --------) to the desired
area.

4. Click OK.
5. If you want to view, edit, or remove a concise description of the page that will
be displayed on search engines results pages and the keywords by which
the page will be found by search engines, click in a blank area to the right of
the post title, and then click the SEO Settings tab.
Note: Post link name is a required field. Meta description and Meta keywords are optional
fields. If you specify keywords for a page, they should be separated by commas without
white spaces.

6. To return to the blog's main page, click the Back link below the post you have
just created.

 To remove a blog post:
1. Go to the website page containing a blog module.
2. Place the mouse pointer over the post title and click Remove.
3. Click Yes to confirm removal.

 To edit a blog post:
1. Go to the website page containing a blog module.
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2. Click the post title.
3. Make the required changes and click OK.

 To remove a blog with all posted content:
1. Go to the website page containing a blog module.
2. Place the mouse pointer over the link Click here to add a new blog post and click
Remove.
3. Click Yes to confirm removal.
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Commenting
If you want to let your site visitors leave comments on webpages, you need to insert the
Commenting module into those webpages.
The commenting functionality is powered by Disqus, a third-party service that stores and
processes all comments. Before your visitors can leave comments, you need to register an
account with Disqus and then specify a site ID in the Commenting module settings.
You can insert several Commenting modules into a single website. Because all Commenting
modules on the site will use the same site ID, you will only need to specify the site ID once in
the module settings, when inserting the first Commenting module.

 To add commenting functions to a webpage:
1. Go to the Modules tab, select Commenting, and drag the module to the page.
2. If you have not registered an account with Disqus yet, click the Register
button. A registration form will open in a new browser window or tab.
3. Specify the following:


Your site's URL, desired name and shortname (unique ID). You will need to specify
this site ID (shortname) later in the Commenting module settings to enable
commenting.



Comment moderator's username, password, and email address. A confirmation
message will be sent to this email address, so be sure that it is valid.

4. Click Continue.
5. Specify your language and other settings, and click Continue.
6. On the last step of the registration form, no further action is required. Just
log out of the Disqus site.
7. Check your email inbox for the confirmation message from Disqus. In this
message, click the link to verify your address.
8. Return to the browser window where you have the Presence Builder editor
with the Commenting module properties opened.
9. In the box titled Apply here the website ID (shortname) received during registration, type
or paste the site ID that you specified during registration with Disqus in step
3.
10. Click Apply.
11. Click OK.
Now you can publish your website to the customer account and start receiving comments
from your visitors.
In addition to adding and viewing comments, you can do the following:


Edit comments.



Delete comments.
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Mark comments as spam.



Ban users (by email or IP address) from posting comments on your site.



Change the settings, such as appearance of comments, and remove the trackback URL.
You can do this by logging in to your account at www.disqus.com, and going to the
Settings tab.

 To moderate comments:
1. Log in to Disqus as the site administrator. You can do this in either of the
following ways:


Visit the Disqus site at www.disqus.com and log in there.



In the Presence Builder editor, go to the page where you have the Commenting
module and click inside the Add New Comment field. Click the Post as button, click the
Disqus link in the left navigation pane, type your username and password, and click
Login.

2. After you are logged in to Disqus, you can moderate comments in either of
the following ways:


On the Disqus site, use the items in the Dashboard and Admin areas.



In the Presence Builder editor or on the published site, go to the page where you have
the Commenting module, place the mouse pointer over the comment you want to
moderate, and use the Moderate link that will appear next to the comment.

Alternately, you can moderate comments by using links in the notification messages that
Disqus sends you when someone leaves a comment on your site.

 To remove commenting functions from a webpage:
1. In the Presence Builder editor, go to the website page containing the
Commenting module.
2. Place the mouse pointer over the Add New Comment field and click Remove.
3. Click Yes to confirm removal.
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Documents and Other Downloadable Files
The editor now provides a convenient control panel for working with files in your customer
account. You can upload your documents, images, and other files in various formats to the
editor (on the Documents tab), and then insert links to them in your website pages.
Alternatively, you can just keep them in your customer account for your own needs.

 To upload a file to the customer account:
1. Go to the Documents tab.
2. Click Upload.
3. Select the file and click Open.
Now, to let your site visitors download this file, you can insert a link to it in a webpage.

 To insert a link to file:
1. Select the text that you want to make into a link.
2. On the Text & Images module's toolbar, click the icon
3. Select the option A document on this site.
4. Select your file and click OK.

 To remove a file from the customer account:
1. Go to the Documents tab.
2. Select the file and click Remove.
3. Confirm removal and click OK.

.
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Buttons for Sharing on Social Networks
If you want to let your visitors easily share your content on social networks or online
bookmarking services, you can insert a toolbar with buttons for sharing on Facebook, Twitter,
Myspace, and other popular services.

 To add the Share on Social Media toolbar to a webpage:
1. Go to the Modules tab, select Social Sharing, and drag the module to the page.
2. Select the appearance of the toolbar.
3. If you want to modify the list of social networks and sharing services shown
on the toolbar, place the mouse pointer over the icon [+] and click the Settings
link.
The changes you make to the list of services will be visible after you publish the site.

4. Click OK.
Note: When someone shares your content on Twitter by using the Tweet button, the counter
of tweets is not increased immediately. It can take several hours for the counter to update.

 To remove the Social Media toolbar:
Place the mouse pointer over the toolbar and click Remove.

Site Search
If you want to let your visitors search for information on your website, you can add a search
bar to the site. After inserting the search bar into a webpage, it is automatically added to all
pages of the site.
By default, the search bar is configured to use the Google search engine. If you want to use
another search engine, you can obtain the search script code and insert it into the Search
module.

 To add a search bar to the site:
1. Go to the Modules tab, select Search, and drag the module to the page.
2. Do any of the following:


If you want to use the search service provided by Google, leave the Google option
selected.



If you want to use another search engine, select Other and paste the code that you
have obtained from that service.
Make sure that the code you insert is correct, as Presence Builder does not validate it.

3. Click OK.
The search bar will appear on your site after publishing.
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 To remove a search bar:
Place the mouse pointer over the search bar and click Remove.

Online Store
If you want to sell products or services through your site, you can use the Online Store and
Shopping Cart modules to add a fully functional online store to the site. You can add only one
store per site.
The store functionality is provided by Ecwid - a third-party SaaS solutions provider that
securely stores and processes all your data, including product catalogs, images, orders, and
customers' payments.

 To add an online store to your site:
1. Go to the Modules tab, select Online Store, and drag the module to the page.
2. Create an account with Ecwid if you do not have one yet, or specify the ID of
an existing store if you have previously created a store at Ecwid through
Presence Builder and want to show it on your site.
If you do not have an account with Ecwid yet, do the following:

a. In module settings, on the General tab, select the option Register with
Ecwid.
b. Type your name, email address, and password. You will use the
email address and password to sign in to Ecwid and manage your
store.
c. Click Send. A confirmation message from Ecwid will be sent to your
email address. You will need to confirm that you own this email
address within three days, otherwise the online store will be
deactivated.
If you already have an account with Ecwid, select the option Enter an ID of an existing shop,
specify the store ID and email address that you specified during account registration, and
click Apply.
Note: If the online store was created directly at the Ecwid website without using Presence
Builder, you can do the following: Create a new Ecwid account through Presence Builder,
log in to the previously existing Ecwid account, export all the goods to a CSV file. After
that, log in to the new account and import the file.

3. (Optional step.) If you want to let your customers add items to the cart by
dragging them to a shopping bag icon, go to the Modules tab, select the
Shopping Cart module, and drag it to the page.
Note that the shopping bag icon will be inserted into all pages of your site. If you do not
want that, do not use the Shopping Cart module. Your customers will still be able to add
items to the cart and proceed to checkout by using the Shopping Bag link that appears at
the top of the product catalog area.

4. (Optional step.) If you want to change the appearance of the product catalog,
in module settings, go to the View tab.
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5. To set up your store, fill the product catalog with items, and remove the
default fruit and vegetable items added by Ecwid, click the Manage link on the
module's toolbar.
The Ecwid control panel will open in a new browser window or tab.

6. After you have finished setting up the store in the Ecwid control panel, return
to the Presence Builder editor and click the Reload link on the Online Store
module's toolbar.
You must use the Reload link to synchronize the content of your online store with online
store at Ecwid.

7. Click OK to finish setting up the store.

 To manage a store:
Place the mouse pointer over the product catalog and click Manage. The Ecwid control panel
will open in a new browser window or tab.
Note: After publishing your site, you can also view information about new orders on the
Dashboard (on page 151).

 To remove a store:
Place the mouse pointer over the product catalog and click Remove.

Map
With the Map module, you can easily add a map with your location to a website. Maps are
provided by the Google Maps service, which is available free of charge.
The following functions are supported:


Searching for an object on a map by address or by latitude and longitude coordinates.



Selecting the mode of map display by switching between Map, Satellite, Satellite with labels,
and Terrain views.




Adjustment of the map scale: zoom in or out.
Selecting the map size: Small, Medium, or Large.



Adding map markers identifying locations on the map.



Displaying the overview map in the lower right corner of the map block. The overview
map shows the extent of your main zoomed map.

When you add a map, the module uses the information about your location that you specified
after selecting a website topic. You can specify a new location at any time.

 To add a map to your site:
1. Go to the Modules tab, select Map, and drag the module to the page.
2. Specify the desired location and click Search. You can type an address or
coordinates. For example: 37.754481,-122.383772.
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3. Select the desired map view from the map mode menu, and the zoom level
from the zoom level menu.
4. Select the desired map size from the Map size menu.
5. Specify desired locations on the map with map markers. To add a map
marker, change your mouse pointer to a marker by clicking the map marker
image in the upper left corner of the map, click a desired location on the
map, specify the marker title and description.
6. To add an overview map displaying the extent of your main map, click the
arrow image in the lower right corner of the map block.
7. Click OK.

 To remove a map:
Place the mouse pointer over the map and click Remove.
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Custom Scripts
You can insert custom scripts written in PHP, JavaScript, or VBScript in any page of your
website.

 To insert a script in a webpage:
1. Go to the Modules tab, select Script, and drag the module to the page.
2. Paste the code into the input field.
For PHP, use the opening tag <?php. Make sure the code you insert into this field is
correct, as Presence Builder does not validate it.

3. Click OK.
Your code will be active only on the published website.

 To remove a script:
Place the mouse pointer over the script block and click Remove.

Advertisements
If you are participating in a banner exchange or other online advertising programs, you might
want to add an advertisement block to your site. After inserting the block in a webpage, it will
be automatically added to all pages of your site.

 To add an advertisement block:
1. Go to the Modules tab, select Advertisement, and drag the module to the page.
2. Paste the code provided by your advertising vendor into the input field.
Make sure that the code you insert into this field is correct, as Presence Builder does not
validate it. With some advertising vendors, you will need to validate your account first.

3. Click OK.
Advertisements will appear on your website after publishing.

 To remove an advertising block:
Place the mouse pointer over the block and click Remove.
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Settings and Tools for Webmasters
This section describes how to do the following:


Change website name, description, and keywords.



Upload a site icon (favicon) for your website.



Make your website more visible in search results, and embed various search engine
services.



Prevent certain pages or areas of your website from being indexed by search engines
and shown in search results.



Notify site visitors about the use of non-essential cookies on your site. This might be of
interest only to webmasters residing in the European Union.

Changing Website Name, Description, and Keywords
Website name is a line of text that is shown in the title bar of a user's browser when they visit
your website. By default, it is "My website", but you can change it to anything you want.
Website description is shown by search engines when your website is listed in search
results. Website keywords are analyzed by search engines and are used for displaying your
website when people search for these keywords.
You can specify the site description and keywords that the editor will use for all pages of your
website (in Settings tab > Basic), and specify custom values for specific pages (in Pages tab >
page name > Edit page description and keywords).

 To edit your website name, description, and keywords:
1. Go to the Settings tab > Basic tab.
2. Specify the website name that your visitors will see as the title of their
browser window when they visit your website.
3. To show both your website name and the current page name in the browser
title window and to increase your website recognition in search engine
results, select the Add website name to page titles checkbox.
4. Add short description (up to 255 symbols) of your website.
5. Provide a list of keywords that describe your website (10-15 keywords are
recommended).
The description and keywords will be used by default for new and existing pages.

6. Click OK to save changes.
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Uploading a Site Icon (Favicon)
A favicon is a small icon displayed in the browser’s address bar when you visit a website,
and also appears next to the website name in the list of favorite bookmarks. You can create
a favicon using a variety of online tools and then upload your favicon through the Presence
Builder editor. All your website visitors will see this favicon.

 To upload a favicon for your website:
1. Go to the Settings tab > Basic tab.
2. Click Browse and select the location of the favicon to upload. The favicon will
be uploaded.
3. Click OK to save changes.

 To remove a favicon from your website:
1. Go to the Settings tab > Basic tab.
2. Click Remove in the Favicon section. The favicon will be removed.
3. Click OK to save changes.

Verifying Website Ownership
Most search engines require you to verify website ownership when you register your website
or sign up for webmaster assistance services. Verification is typically done by uploading or
creating a file with a specific file name.

 To verify website ownership:
1. Go to the Settings tab > Advanced tab.
2. Provide the verification file:


If you know the name of the verification file requested by a search engine, provide the
verification file name in the Create verification file field and click OK. Presence Builder
will create it in the correct place.



If you have already downloaded your verification file from a search engine, upload the
verification file to the Upload verification file field and click OK.

3. After the verification file is created or uploaded and your website is
published, confirm your ownership on the search engine website.
4. Click OK to save changes.
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 To edit the HTML <head> section of your website (for example, to add
ownership verification meta code):
1. Go to the Settings tab of the Presence Builder's main menu, then go to the
Advanced subtab.
2. Click Edit Metadata.
3. Insert the code into the provided field and click Add.
Note: Only valid HTML tags permitted for <head> section by HTML standards are
supported. Metadata changes will be available only after you publish your website.

4. Click OK to save changes.

Embedding Analytics Code
An analytics service is a tool that allows you to obtain information about your visitors. After
you register with an analytics service, such as Google Analytics, and acquire the required
code, you can embed the analytics service on your website.

 To embed an analytics service:
1. Register with an analytics service and acquire the code.
2. Go to the Settings tab > Advanced tab.
3. Click Embed Analytics.
4. Insert the code you have received from the analytics service into the
provided field and click Add.
Note: The analytics service will start working only after you publish your website.

5. Click OK to save changes.

Downloading the Sitemap
Some search engines will ask you to provide your sitemap for analysis and optimization
purposes. You can download your sitemap from the Presence Builder editor.

 To download your website sitemap:
1. Go to the Settings tab > Advanced tab.
2. Click Download Sitemap.
3. Click OK to start downloading the sitemap.xml file.
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Preventing Search Engines from Indexing Certain Pages of Your Site
To prevent search engines from indexing certain pages of your website, you can add the
appropriate directives into the robots.txt file. This file is stored on the customer account
to which your site is published.

 To prevent search engines from indexing certain areas of your website:
1. Go to the Settings tab > Advanced tab.
2. Click the link Edit robots.txt.
3. Type your directives into the input field. Place each directive on a new line.
For example, to prevent all search engine robots and crawlers from indexing the contents
of the directory /private and the file /my_secret.html on your customer account,
add the following lines:
User-agent: *
Disallow: /private/
Disallow: /my_secret.html
For more information about the robots.txt file and directives you can use, refer to
http://www.robotstxt.org/robotstxt.html.

Notifying Site Visitors About the Cookie Policy
If you are located in the European Union, your site must inform its visitors about the use of
non-essential cookies and obtain informed consent.
Cookies are small files that web servers save on visitors' computers. Cookies may be used
for a number of purposes, from remembering personal preferences to tracking users'
behavior for presenting targeted advertisements. Non-essential cookies are those that are
not required for websites to function properly. Examples of non-essential cookies include
those from analytics, advertising, and affiliate networks such as Google Analytics and Google
AdSense.
Most likely, your site uses non-essential cookies if it uses the following functions:


Google Analytics




Publishing to Facebook
Embedded video



Image gallery module (with Picasa selected as storage)



Online store module




Map module
Commenting module



Social sharing module



Script module



Site search
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If you choose to show a notice on the site, its visitors will be prompted to confirm that they
accept your policy.

If they accept it, the notice is no longer shown (the icon
is shown instead in the
page corner), and they can continue browsing your site. If they do not accept it, they are
taken to google.com.

 To show a cookie notice on the site:
1. Go to the Settings tab > Advanced tab.
2. Click the link Notify Site Visitors About the Cookie Policy.
3. Select the checkbox Show the cookie notice on the site and click OK.

145

146

Creating Websites with Parallels Presence Builder

Saving and Loading Copies of a Website
While working on the content and design of a website, you can save several copies of each
site to the server and restore sites from the saved copies (also referred to as snapshots).
Saving site copies can be useful in the following cases:


You want to prepare several versions of the same website, so that you can later load
them for review, choose the best designed or the most appropriate version, and publish it
to the Internet.



You want to make significant changes or experiment on the site design or content, but be
sure that you can safely undo the changes should anything go wrong.

Note: Pictures from the Image Gallery modules are not saved in snapshots. Images are stored
on your customer account or Picasa Web Albums (if you use that option).

 To save the current design and content of a site:
1. In the Presence Builder editor's main menu, click the icon
option.

next to the Save

Note: If you click Save, a quick-save site copy will be saved under the name auto-saved
snapshot. You will be able to restore a site from this copy later, by clicking Revert in the
main menu.

2. In the list that opens, select a free saving slot, type a name for the backup
copy, and click Save.

 To restore a site from a saved copy:
1. In the Presence Builder editor's main menu, click the icon
Revert option.

next to the

Note: If you click Revert, a site will be restored from the quick-save copy that was made
the last time you clicked Save.

2. In the list that opens, select a site copy and click Load.
3. Click Yes to confirm you want to restore.

 To download a site copy:
1. In the Presence Builder editor's main menu, click the icon
option.
2. Locate the copy that you want to download and click the

next to the Save
(Download) icon.

3. Select the directory on your computer where you want to save the file and
click OK.
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 To upload a site copy:
1. In the Presence Builder editor's main menu, click the icon
Revert option.
2. Click the
copy.

next to the

(Upload) icon next to the slot to which you want to upload the

3. Browse to the site snapshot file in the SSB format and select it.
4. If you want to restore a site from the uploaded snapshot, select it and click
Load.

 To remove a site copy:
1. In the Presence Builder editor's main menu, click the icon
option.

next to the Save

2. Locate the site copy that you want to remove and click the corresponding
(Remove) icon.
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Publishing a Website to the Internet
When your website design and content are ready to be published to the Internet, click Publish
in the top right corner of the main menu. Presence Builder will publish your website
automatically to the location specified by your hosting provider.
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Publishing a Website Copy to Facebook
After publishing a site on the Internet, you can drive more visitors to it by publishing a site
copy to the popular social network site - Facebook (www.facebook.com).
A site copy on Facebook will show most of the content from your site; however, the following
changes will be applied to its design, layout, and functionality:


Headers, sidebars, and footers will not be shown.



The navigation menu will be shown only at the top of the site pages.



Page width will be limited to 520 pixels. For pages wider than 520 pixels, a horizontal
scrollbar will be shown.



The font face, size, and color will be changed to comply with the Facebook design,
unless these font properties were specifically selected by the site owner in the Presence
Builder editor.



Image galleries, online store, and links for sharing on social media sites will not be
shown.
Any links pointing to other pages on Facebook will not work.



 If you want to add a site copy to Facebook, do the following:
1. In the main menu, click the Settings tab > Social Media tab.
2. Leave the checkbox Show a copy of my site on Facebook selected.
3. Click the link Add your site copy to Facebook. The Facebook home page opens in
a new browser window or tab.
4. To log in to your Facebook account, type your email address and password,
and click Log In.
5. If you do not have a Facebook page where you want to show a site copy,
create one. To do this, click Create It Now, and follow the onscreen guidelines.
After your page is created, return to the Parallels Presence Builder at Facebook
page, which is shown in another browser window or tab.
6. Click Add Parallels Presence Builder Application. This application provides
synchronization between the website on your hosting account and its copy
on Facebook.
7. To confirm that you want to add the application to your page, click Add
Parallels Presence Builder.
Now your site copy is added. To see it, click the Website link in the Facebook navigation pane
on your left.
Whenever you make changes to your site and republish it through the Presence Builder
editor, your site copy on Facebook will be updated accordingly.
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 To remove a site copy from Facebook, do the following:
1. In the Presence Builder editor's main menu, click the Settings tab > Social
Media tab.
2. Clear the checkbox Show a copy of my site on Facebook.
3. Click Yes to confirm.
4. Go to your Facebook page and remove the Presence Builder application
from there.
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Viewing Site Visits Statistics, Comments,
and New Orders on the Dashboard
After publishing a site, you can access the Dashboard from the Presence Builder's main
menu to perform the following tasks:


View statistics on website visits. The statistics are provided by Google Analytics and are
available after you specify the code for Google Analytics in website settings, as described
in the section Settings and Tools for Webmasters (on page 141).



View new comments left by site visitors on your website pages. The comments are visible
on the Dashboard after you set up the commenting functionality, as described in the
sections Blog (on page 130) and Commenting (on page 133).



View new orders from customers visiting your online stores. The new orders are visible
on the Dashboard after you set up an online store, as described in the section Online
Store (on page 137).

 To view website visits statistics:
1. On the main menu, click Dashboard.
2. If you access the dashboard for the first time, confirm association of your site
with your Google Account:
a. Click Log In to Google Analytics.
b. Log in to your Google Account.
c. Confirm that you want to allow access to your account.
3. Under the Website Visits Statistics chart, click the link See more charts, or click the
icon.
The Overview section shows the following statistics for the past 30 days:


A detailed chart for the metric currently selected under Profile report.



The total number of visits during the past 30 days.



The number of new visits.



Average time spent on a site by users.



The total number of page views.



The number of page views per each visit.

 The percentage of new visits.
The Traffic sources overview section shows the addresses of websites from which your
visitors were coming during the past 30 days. The (direct) item shows the percentage of
visitors who accessed your site by typing its address directly in their browsers.
The Visitors' locations section shows the geographic locations of the visitors for the past 30
days.
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 To view comments from your site visitors:
1. On the main menu, click Dashboard.
2. Under Comments, click the link See them, or click the

icon.

3. To go to the webpage where the comment was left, click Link to the comment.
4. To go to the Disqus site for moderating the comments, click Manage Comments.

 To view orders submitted by the customers visiting your online stores:
1. On the main menu, click Dashboard.
2. Under Orders, click the link See them, or click the
Orders tab.

icon, and then click the

3. To go to the Ecwid site for processing the orders, click Manage Orders.
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Deleting Websites
When you delete a site from the Presence Builder editor, only the current site draft opened in
the editor and saved site copies (snapshots) are removed.
By default, the site copy published to your hosting account is not removed. However, this
policy might be changed by your hosting provider.

 To delete a current site copy from the editor:
In the Presence Builder editor's main menu, select More > Remove Site.

CHAPTER 5

FTP Access to Your Websites
One of the most convenient ways to update your website content is to upload it through
FTP. FTP (File Transfer Protocol) is a standard network protocol that allows
transferring files between two hosts (for example, your computer and a Panel server).
Panel acts as an FTP server, while users should use some FTP client to access the
directories on the server. Panel provides all main FTP features:


Authorized access to the server. Learn more in the section Changing FTP Access
Credentials (on page 154).



Multiple user accounts for collaborative work. Learn more in the section Adding FTP
Accounts (on page 155).



Anonymous FTP access: The access without authorization that may be used, for
example, to share software updates. Learn more in the section Setting Up Anonymous
FTP Access.

In this chapter:
Changing FTP Access Credentials .................................................................... 154
Adding FTP Accounts........................................................................................ 155

Changing FTP Access Credentials
 To change FTP account username or password:
1. Click the Websites tab.
2. Click Web Hosting Access.
3. Type a new username or password.
4. Click OK.
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Adding FTP Accounts
If you are working on your website together with someone else or host subdomains for
other users, you might want to create separate FTP accounts for them.

 To create an additional FTP account:
1. Go to the Websites tab > FTP Access and click Create Additional FTP Account.
2. Specify the following:


FTP account name. Type an arbitrary name.



Home directory. Select the directory to which the user will be taken when he or
she connects to the FTP account.



FTP password.



Hard disk quota (on Windows hosting). To limit the amount of disk space on the
server that the FTP user can occupy, clear the Unlimited checkbox next to the
Hard disk quota box, and type the amount of disk space in megabytes.



Read permission (on Windows hosting). To allow the FTP user to view the
contents of the home directory and download files from it, select the Read
permission checkbox.



Write permission (on Windows hosting). To allow the FTP user to create, view,
rename and delete directories in the home directory, select the Write permission
checkbox.
On Windows hosting, if you do not grant any permissions, a connection to the
FTP account will be made, but the contents of the home directory will not be
shown to the user.

3. Click OK.

 To change the properties of an additional FTP account:
1. Go to the Websites tab > FTP Access.
2. Click the required FTP account name in the list.
3. Make the required changes and click OK.

 To remove an additional FTP account:
1. Go to the Websites tab > FTP Access.
2. Select the checkbox corresponding to the FTP account you want to
remove and click Remove.
3. Confirm removal and click OK.

CHAPTER 6

Mail
This chapter describes how to set up and use the following email services in the
Hosting Panel.


Mailboxes associated with your domain names.



Email aliases. These are additional email addresses that are associated with a
user's primary (or main) email address. Email aliases can be used as temporary
disposable addresses that can be published on the Internet. When spam starts
coming to an address that was set up as an email alias, you can remove that alias
and create another one.



Email forwarding. You can set up an email forwarding service that will send copies
of all incoming messages to another email address.



Auto-reply. You can switch on an automatic reply service, which will send a
predefined email message in reply to any incoming email message. This is useful
for sending "out of office" or "on vacation" notices when you are away.



Protection from spam. You can switch on the checking of all incoming messages by
an antispam filter. You can specify how to deal with messages identified as spam:
Remove them, move to a special folder, or just add some text to the message
subject.
Mail antivirus. Checking of all incoming and outgoing mail for viruses.




Webmail. You can select a webmail program that you want to use for working with
your email messages by means of a web browser.



Mail bounce settings. You can specify how to deal with incoming mail that is
addressed to nonexistent users.

In this chapter:
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Protecting from Spam ........................................................................................160
Protecting from Viruses ......................................................................................162
(Advanced) Configuring Mail Bounce Settings and Selecting Webmail ..............163
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Adding Mail Accounts
 To create an e-mail address:
1. Go to the Mail tab, and click Create Email Address.
2. Specify the following settings:


Email address. Type the left part of the email address before the @ sign, and, if
you have several domain names on your account, select the domain name
under which the email address will be created.



Access to the Control Panel. Select this option if you want Panel to create an
auxiliary user for the mail account owner. By default, this user has the role
Application user. However, you can change this role and other user's properties
later. For details, see the section (Advanced) Managing Auxiliary User Accounts (on
page 20).



Password. Set the password for accessing the mailbox. If you leave the option
Access to the Control Panel selected, the same password will be used for logging
the user in to the Hosting Panel.



Mailbox. Turning off this option makes sense only if you want to use this address
as a mail forwarder, which will forward all incoming mail to another address.



Mailbox size. If you leave the Mailbox option selected, specify the mailbox size or
use the default size defined by the provider's policy or your service plan.

3. Click OK.

Changing Mail Account Password
 If you need to change the password for a mail account, do the following:
1. Go to the Mail tab, and click the email address.
2. Type a new password and confirm it, then click OK.
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Setting Up Mail Forwarding
 To set up email forwarding for an email address:
1. Go to the Mail tab > email address > Forwarding tab.
2. Select the Switch on mail forwarding checkbox.
3. Specify one or several email addresses to which email must be
forwarded. When specifying email addresses, separate them with white
spaces, commas, semicolons, or type each of them on a new line.
4. Click OK.
5. If you do not want to keep the copies of forwarded messages in the
mailbox, go to the Mail tab > email address, clear the Mailbox checkbox,
and click OK.

 To switch off mail forwarding:
1. Go to the Mail tab > email address > Forwarding tab.
2. Clear the Switch on mail forwarding checkbox, and click OK.

Creating Mail Aliases
 To add or remove additional email addresses (email aliases) for a mail
account:
1. Go to the Mail tab > email address > Email Aliases tab.
2. Do any of the following:


To add an address, type it into the Email alias box, and click OK.



To remove an address, click the Remove link to the right of the address you want
to remove.

Mail

159

Setting Up Auto-Reply
 To set up an automatic reply for an email address:
1. Go to the Mail tab > email address > Auto-Reply tab.
2. Select the Switch on auto-reply checkbox, and specify the following
settings:


Auto-reply message subject.



Message format. We recommend that you leave the option Plain text selected
because some of your recipients might be unable to see the text formatted with
HTML.



Encoding. We recommend that you leave the UTF-8 encoding selected to ensure
that the letters in your message are displayed properly.



Message text.



Forward to. If you want to forward incoming messages to another email address,
type an email address in this box.



Send an automatic response to a unique email address no more than... The default value
is "1 time a day", meaning that if your mailbox receives several messages from
the same email address in one day, Panel will send automatic response only to
the first message. If the value is "2", than Panel will send automatic response to
the first and the second messages, and so on.



Attached files. If you want to attach a file to your message, click Browse and select
a file.

3. Click OK.
To switch off an automatic reply, clear the Switch on auto-reply checkbox and click OK.
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Protecting from Spam
 To switch on spam filtering for a mailbox:
1. Go to the Mail tab > email address > Spam Filter tab.
2. Select the checkbox Switch on spam filtering for this email address.
3. Specify what to do with messages classified as spam.


If you want to filter mail with the software on your local computer, select the
option Mark spam messages by adding the following text to message subject, and then
specify how spam filter should mark the messages recognized as spam. "XSpam-Flag: YES" and "X-Spam-Status: Yes" headers are added to the
message source by default, and if you want, the spam filter will also add a
specific text string to the beginning of the subject line and to the message body.



If you are sure that your spam filter is accurate, you may want to set the filter to
automatically delete all incoming messages recognized as spam. To do this,
select the option Delete all spam messages.



If you are accessing your mailbox over IMAP protocol and want the spam filter
to move all messages considered spam to the IMAP folder called Spam, select
the option Move spam to the Spam folder.
Because all messages are automatically removed from the Spam folder after 30
days, you will need to review the contents of the Spam folder on a regular basis
to make sure you do not miss any important messages, and move all non-spam
messages back to the Inbox folder.
When the option Move spam to the Spam folder is selected, you can train the spam
filter and improve its accuracy by moving spam messages from Inbox to Spam,
and non-spam messages from Spam to Inbox.

4. If you want to adjust the spam filter sensitivity, click Show Advanced
Settings, and type the number of points that a message must score to be
considered spam.
SpamAssassin performs a number of different tests on contents and subject line of
each message. As a result, each message scores a number of points. The higher
the number, the more likely a message is spam. For example, a message
containing the text string "BUY VIAGRA AT LOW PRICE!!!" in subject line and
message body scores 8.3 points. By default, the filter sensitivity is set so that all
messages that score 7 or more points are classified as spam.


If you receive lots of spam messages with the current setting, to make filter
more sensitive, try setting a lesser value in the Spam filter sensitivity box; for
example, 6.



If you are missing your emails because your spam filter thinks they are junk, try
reducing filter sensitivity by setting a higher value in the Spam filter sensitivity box.

Note: To further improve spam filter accuracy, you may want to train your spam
filter on email messages you receive, as described further in this section.
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5. If you want to be sure that you will not miss email from specific senders,
type email addresses or domain names into the White list field.
Place each address in one row, or separate addresses with a coma, a colon, or a
white space. You can use an asterisk (*) as a substitute for a number of letters, and
question mark (?) as a substitute for a single letter. For example:
address@mycompany.com, user?@mycompany.com, *@mycompany.com.
Specifying *@mycompany.com will add to the white list all email addresses that are
under the mycompany.com mail domain.

6. If you do not want to receive email from specific domains or individual
senders, type email addresses or domain names into the Black list field.
Place each address in one row, or separate addresses with a coma, a colon, or a
white space. You can use an asterisk (*) as a substitute for a number of letters, and
question mark (?) as a substitute for a single letter. For example:
address@spammers.net, user?@spammers.net, *@spammers.net. Specifying
*@spammers.net will block the entire mail domain spammers.net.

7. If you use a Windows-based hosting account, then you can also specify
trusted languages and character sets. Email messages written in the
specified languages and with the defined character sets will pass the
spam filter and will not be marked as spam.
8. On Windows-based hosting accounts, you can also specify IP
addresses of computers or networks from which email must always be
accepted. When specifying network addresses, type an address and
add a network mask after a slash. For example, 192.168.10.10/24.
9. Click OK.
You can improve the accuracy of spam detection if SpamAssassin spam filter on the
server is switched on for your account and you are accessing your mailbox over IMAP
protocol.

 To improve accuracy of spam detection:
1. Access your mailbox with webmail or a mail client program on your
computer.
2. Review the messages in your Inbox folder. Move all spam messages to
the Spam folder. This will make the SpamAssassin spam filter recognize
spam more efficiently.
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Protecting from Viruses
To defend your system from viruses, do not open suspicious email attachments, enable
antivirus protection on your hosting account, if this service is provided by your hosting
company, and be sure to have a firewall and antivirus software installed on your
personal computer. Also keep your operating system up-to-date and timely install
security hot fixes and patches.

 To switch on antivirus protection for a mailbox:
1. Go to the Mail tab > email address > Antivirus tab.
2. Select the checkbox Switch on antivirus protection for this email address.
3. Choose the desired mail scanning mode. You can switch on scanning
for incoming mail, outgoing mail, or both.
4. Click OK.
When an infected message comes, you will be notified by email.

 To switch off antivirus protection for a mailbox:
1. Go to the Mail tab > email address > Antivirus tab.
2. Clear the checkbox Switch on antivirus protection for this email address.
3. Click OK.
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(Advanced) Configuring Mail Bounce
Settings and Selecting Webmail
You can configure the following mail service settings that apply to all domains created
under a subscription:


Mail service status. You can switch the mail service on or off. If the mail service is
switched off, then email messages cannot be sent or received.



Mail bounce settings. When somebody sends an email message to an email
address that does not exist under your domain, the mail server, by default, accepts
mail, processes it, and when it finds out that there is no such a recipient under the
domain, it returns the mail back to sender with an error message. You can choose
to:





Continue returning all such mail back to senders (Bounce with message option).



Forward all such mail to the specified email address (Forward to address option).



Forward all such mail to another mail server with the specified IP address using
the option Redirect to external mail server with IP address (available only for
Windows hosting accounts).



Reject such mail without accepting it and without notifying senders (Reject
option).

Webmail. If your service plan provides the option to choose which webmail program
to use for your account, then you can select it in the mail service settings.

 To configure the mail service settings:
1. Go to the Mail tab, and then click Change Settings.
2. Select the required options, and click OK.

CHAPTER 7

Scheduling Tasks
If you need to run scripts on your hosting account at specific time, use the task
scheduler in the Panel to make the system automatically run the scripts for you.

In this chapter:
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Scheduling Tasks (Linux Hosting)
 To schedule a task:
1. Go to the Websites tab > Scheduled Tasks > <username>.
2. Click Schedule New Task.
3. Leave the Switched on checkbox selected.
4. Specify when to run your command:


Minute - enter the value from 0 to 59.



Hour - enter the value from 0 to 23.



Day of the month - enter the value from 1 to 31.



Month - enter the value from 1 to 12, or select the month from the menu.



Day of the week - enter the value from 0 to 6 (0 for Sunday), or select the day of
the week from a menu.

You can schedule the time using the UNIX crontab entry format. In this format, you
can:


Enter several values separated by commas. Two numbers separated by a
hyphen mean an inclusive range. For example, to run a task on the 4th, 5th, 6th,
and 20th of a month, type 4-6,20.



Insert an asterisk to specify all values allowed for this field. For example, to run
a task daily, type * in the Day of the month text box.

To schedule the task to run every Nth period, enter the combination */N, where N is
a value for this field (minute, hour, day, month). For example, */15 in the Minute field
schedules the task to start every 15 minutes.
You can type the contracted names of months and days of the week, which are the
first three letters: Aug, Jul, Mon, Sat, and so on. However, the contracted names
cannot be separated with commas or used together with numbers.

5. Specify the command to run. Type it into the Command input box.
For example, if you want to run a backup creation task at the specified time and
have the backup file sent to your email, you need to specify the following command
in the Command input box:
/usr/local/psa/admin/sbin/backupmng

6. Click OK.

 To receive notifications when the tasks are started:
1. Go to the Websites tab > Scheduled Tasks > <username>.
2. Click Settings and specify the notification policy.
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 To temporarily suspend execution of a scheduled task:
1. Go to the Websites tab > Scheduled Tasks > <username>.
2. Locate the task that you want to suspend and click the corresponding
link in the Command column.
3. Clear the Switched on checkbox and click OK.

 To resume execution of a scheduled task:
1. Go to the Websites tab > Scheduled Tasks > <username>.
2. Locate the task whose execution you want to resume and click the
corresponding link in the Command column.
3. Select the Switched on checkbox and click OK.

 To cancel a task:
1. Go to the Websites tab > Scheduled Tasks > <username>.
2. Select the checkbox to the left of the task that you want to cancel and
click Remove.
3. Confirm removal and click OK.
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Scheduling Tasks (Windows Hosting)
 To schedule a task:
1. Go to the Websites tab > Scheduled Tasks > <username>.
2. Click Schedule New Task.
3. Leave the Switched on checkbox selected if you want your scheduled
task to be active immediately after the creation.
4. Type a name for your task in the Description field.
5. In Scheduler notification, specify whether the scheduler should notify you
when it runs this task. The following options are available:


Switched off - do not notify you.



Send to the default email - send the notification to your default email address.



Send to the email I specify - send the notification to the email specified in the
corresponding field. After selecting this option, you need to type the required
email address in the field on the right.

6. Specify which command or executable file to run. Type it into the Path to
executable file input box. If you need to run the command with certain
options, type them in the Arguments field.


For example, if you want to run the statistics calculation task to count disc space
and see more detailed information for the example.com and example.net
domains, you need to specify the following path in the Path to executable file input
box:
C:\Program Files\Parallels\Parallels
Panel\admin\bin\statistics.exe
and the following options in the Arguments field:
--disk-usage --process-domains=example.com, example.net –
verbose



If you want to run your own PHP script using the task scheduler, you need to
specify the following path in the Path to executable file input box:
C:\Program Files (x86)\Parallels\Parallels
Panel\Additional\PleskPHP5\php.exe
and specify the script location in the Arguments field:
C:\Inetpub\vhosts\mydomain.tld\httpdocs\myscript.php

7. Select the appropriate priority in the Task priority field. Task priority can
be set to Low, Normal or High.
8. Specify when to run your command by selecting the appropriate
checkboxes in the Hours, Days of month, Months or Days of week fields.
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9. Click OK to schedule the task or click Run Now to schedule the task and
immediately run it.

 To temporarily suspend execution of a scheduled task:
1. Go to the Websites tab > Scheduled Tasks > <username>.
2. Choose a task that you want to suspend and click the corresponding
link in the Description column.
3. Clear the Switched on checkbox.
4. Click OK.

 To resume execution of scheduled task:
1. Go to the Websites tab > Scheduled Tasks > <username>.
2. Choose a task whose execution you want to resume and click the
corresponding link in the Description column.
3. Select the Switched on checkbox.
4. Click OK.

 To cancel a task:
1. Go to the Websites tab > Scheduled Tasks > <username>.
2. Select a checkbox to the left of the task that you want to cancel and
click Remove.
3. Confirm removal and click OK.

CHAPTER 8

(Advanced) Using Databases
If your website incorporates custom data processing applications or is designed to
generate web pages dynamically, you will probably need a database for storing and
retrieving data.
In Panel, you can manually create a new database for your site, make a database copy
and manage database user accounts. These operations are available in Websites tab >
Databases. In addition, you can use the third-party database management tools supplied
with Panel to edit tables in databases, export and import data, and run SQL queries.
These tools are available under the Webadmin link in Websites tab > Databases and may
vary depending on the database type. For example, Panel uses phpMyAdmin to
manage MySQL databases.
Note that when you install an app from the Application Catalog, all required databases
and database user accounts are created automatically. Alternatively, you can assign a
manually created user account to a database created by a web app. For more
information, see the section Using Website Applications > App Databases.
For details on operations on databases and database users, refer to the relevant
sections of this chapter.
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Creating Databases
 To create a database:
1. Go to the Websites tab > Databases > Add New Database.
2. Specify a database name.
3. Select the database type and the server where the database should be
hosted. This option might be unavailable depending on your service
plan.
4. To create a database user account, leave the Create a new database user
checkbox selected.
A database must have at least one user account associated with it. Otherwise, it will
be impossible to access the database. You can also clear the checkbox and select
a user later, for example, if you want to use one of the existing user accounts. For
more information, see Managing Database User Accounts (on page 172).

Accessing Databases
After you have created a database and assigned a database user to it, you can access
it from Panel using the Webadmin link in Websites tab > Databases. In this case, Panel
automatically uses the corresponding database user credentials.
If you want to access your database using other tools (like SQL Server Management
Studio) or want to give other applications access to it, you will need to provide these
tools and applications with the following:


To connect to MySQL and PostgreSQL, you will need to provide the host name (or
IP address) and the database user name and password.



To connect to Microsoft SQL Server, you will also need to specify the Microsoft
SQL Server instance. For Microsoft SQL Server 2008, Panel uses the
MSSQLSERVER2008 named instance. Therefore, the host can be specified as
mydomain.com\MSSQLSERVER2008 or
123.123.123.123\MSSQLSERVER2008. For Microsoft SQL Server 2005, Panel
uses the default instance (MSSQL 2005), and you do not need to specify the
instance name.
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Copying Databases
You can copy databases from one database server registered in Panel to another, as
well as to any remote server, provided that the source and the destination servers are
of the same type, for example, MySQL.

 To copy a database:
1. Go to the Websites tab > Databases, and click the Copy link corresponding
to the database.
2. Specify the destination server, the subscription, and the database.
For a remote server, you should select Other in the Destination database server menu
and provide the following additional information:


Host name or IP address of the remote database server.



Username and password of the remote database server’s administrator. For
example, the MySQL administrator’s credentials.
Note: When you choose an existing database as the destination, the tables in
the destination database whose names also appear in the source database
will be fully replaced.

3. Specify the type of data that should be copied. You can choose to
create a full database copy including data in the tables (the Create a full
copy option), or to copy only the database structure. In the latter case,
Panel will create tables without data in the destination database.

Exporting and Importing Databases
In Panel, to export a database means to save a source database in a file which can be
used for storage or distribution. To import a database means to restore data from a file
to a destination database. You can import a database to the same or another database
server. The only restriction is that the destination database should be of the same type,
for example, MySQL.
One reason for exporting databases is to back them up. On Windows-based accounts
there is a separate functionality for backing up databases, on Linux-based accounts,
exporting is the only option for creating separate database backup files.
The export and import functionality is provided by the database management tool
available through the Webadmin link in Websites tab > Databases.
For instructions on how to perform import and export with database management tools,
refer to the tools' built-in help sections.
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Managing Database User Accounts
When you work with a database in Panel, the latter accesses the database on behalf of
a user account associated with the database. Therefore, every database should have
at least one associated user account; otherwise, you will be unable to access it.
Any database user can be set as default for a certain database. Panel will always
access the database using this default user even if there are other users associated
with it. If a database has several associated user accounts, none of which are default,
the first account from the list will be used.

Types of Database Users
There are two types of database user accounts in Panel:


User accounts which have access to only one particular database.
If you collaborate with other people on managing a website and wish to give them
access to the database, you should create separate user accounts for them. Each
of these accounts is used to access only one database. In this case, you first create
a database and then user accounts.



Universal user accounts which have access to all databases.
Universal users have access not only to all existing databases, but to all newly
created databases as well.
If you plan to install a number of web apps on your site, it may be convenient to
create one universal user account, so that all the apps can access their databases
using this account. In this case, you first create a user account and then specify it
when installing apps.
Note: A universal user acts only within one database server. If you use several
database servers, create a separate universal user account for each server.

Operations on Database Users
You can create, update, or remove a database user by going to Websites tab >
Databases > Users tab.
When creating a database user, you will be prompted to provide the user credentials
for accessing the database and the name of the database which the specified user will
access. A universal database user can be created by selecting Any from the Database
menu.
Notes:
1. You can remove a default database user only by removing the database associated
with this user. Alternatively, you can edit the user and clear the Make the user default for
this database option, and then remove the user.
2. If a database user was created by an APS app, you can remove this user only by
removing the respective app.
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Removing Databases
Note that you can only remove the databases and database users that are not used by
APS apps. If the required checkbox is unavailable (not selectable), it means that this
database is used by an app and you can remove it only by removing the respective
app.
To remove a database, go to the Websites tab > Databases, select the checkbox next to
the database name and click Remove.

CHAPTER 9

(Advanced) Backing Up and Restoring
Data
To prevent the loss of data related to your websites and mailboxes, you can back them
up and restore when needed. You can perform a backup manually at any time, or
schedule it for a specific time. For example, do it once a day at night time when the
number of site visits is minimal.
This chapter describes how to do the following:



Back up sites.
Set up automatic backing up on a schedule.



Restore data from backup archives.
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Backing Up Data
 To back up all websites in a webspace:
1. If you are subscribed to several hosting packages and have access to
several webspaces under your account, select the required subscription
in the Subscription menu at the top of the screen, and then select the
required webspace on the Webspaces tab.
2. Go to the Websites tab > Backup Manager > Back Up.
3. Specify the following:


Backup file name prefix and description. You cannot specify an arbitrary file
name, however, you can set the Panel to add a prefix to backup file names.
Note that the Panel automatically adds the date and time of backup file creation
(in Universal Time) to backup file names.



Splitting of the backup file. To create a multivolume backup, select the
corresponding checkbox and specify volume size in megabytes.



Email notification on backup completion. If you want to be notified of the backup
completion, type your email address.



What data to back up. You can choose to back up:





Only website settings.



All settings and data with or without mail accounts and messages in
mailboxes.



Only mail accounts with messages.

Suspend domains until backup task is completed. Select this option to prohibit users
from making changes to content or settings of websites while they are being
backed up.
Note: If you select this option, then, after restoring the data from this backup
file, you will need to manually switch on every domain alias for every site
that needs to have domain aliases. This can be done at Websites tab >
domain alias name > Switch On.

4. Click Back Up.
When backing up is finished, the backup file will be saved to the repository you
selected.
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Scheduling Backups
 To schedule a backup of data in a webspace:
1. If you are subscribed to several hosting packages and have access to
several webspaces under your account, select the required subscription
in the Subscription menu at the top of the screen, and then select the
required webspace on the Webspaces tab.
2. Go to the Websites tab > Backup Manager > Scheduled Backup Settings.
3. Select the Activate this backup task checkbox and specify the following:


When and how often to run the backup.



A prefix that should be added to the backup file name.



Splitting of the backup file. To create a multivolume backup, select the
respective checkbox and specify volume size in megabytes. Note that volume
size cannot exceed 4095 megabytes.



Maximum number of backup files stored in the repository. Type a number if you
want to recycle backup files: When this limit is reached, the oldest backup files
are removed.



Email notification on backing up errors. If you want to send an email notice
when something goes wrong during backing up, type the email address you
need.



What data to back up. You can back up only account settings, or account
settings and all related data.



Suspend domains until backup task is completed. Select this option to prohibit users
from making changes to the content or settings of websites while they are being
backed up.

4. Click OK.
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Restoring Data
 To restore data from backups:
1. If you are subscribed to several hosting packages and have access to
several webspaces under your account, select the required subscription
in the Subscription menu at the top of the screen, and then select the
required webspace on the Webspaces tab.
2. Go to the Websites tab > Backup Manager, and click the backup file name
that you want to restore.
3. Specify the following:


Types of data to be restored.



Suspend domain until restoration task is completed. Select this if you want to avoid
possible conflicts that may occur when users modify site content or settings
while they are being restored.



Send an email notice when restoration task is completed. Type your email address if
you want the Panel to notify you when restoring is completed.

4. Click Restore.

